Please note: This project is no longer active. The website is kept online for historic purposes only.
If you´re looking for a Linux driver for your Atheros WLAN device, you should continue here .

Ticket #977 (closed defect: fixed)

Opened 13 years ago

Last modified 11 years ago

New version of D-Link DWL-AG660 H/W Ver B3 (AR5006X) do not see net packets in monitor mode after some time of work

Reported by: marek@atm.com.pl Assigned to:
Priority: major Milestone: version 0.9.5
Component: madwifi: other Version: trunk
Keywords: DWL-AG660 AR5006X Cc:
Patch is attached: 0 Pending:

Description

note: previously I've added this info as a comment to ticket #576, but as mrenzmann suggested this should be a separate ticket:

I've got a new model of D-Link AirPremier? AG DWL-AG660 (cardbus) and unfortunatelly have some issues in monitor mode. After some time (from 20 min up to 1 hour) in monitor mode (dumping a net traffic with airodump-ng) the card stops receiving frames/packets. LEDS blink as usual but the card do not see any traffic. After (un)plugging the card back everything works fine for some time. There is no sign of any problems in the log (I use ath_debug=1 option for ath_pci). I have only one ath interface.

I use snapshot madwifi-ng r1763 (with aircrack-ng patch 1756 and fixes from tickets #617 and #946) on Linux 2.6.17.14 (dmesg):

ath_hal: 0.9.18.0 (AR5210, AR5211, AR5212, RF5111, RF5112, RF2413, RF5413)
ath_rate_sample: 1.2 (svn r1763)
ath_pci: 0.9.4.5 (svn r1763)

The card have "H/W Ver.:B3 F/W Ver.:2.20" data on the sticker. lspci tells:

lspci -nn -v -s 03:00.0    
03:00.0 Ethernet controller [0200]: Atheros Communications, Inc. AR5006X 802.11abg NIC [168c:001b] (rev 01)
        Subsystem: D-Link System Inc D-Link AirPremier AG DWL-AG660 Wireless Cardbus Adapter [1186:3a19]
        Flags: bus master, medium devsel, latency 168, IRQ 185
        Memory at 32000000 (32-bit, non-prefetchable) [size=64K]
        Capabilities: [44] Power Management version 2

With the same drivers/Linux version the older D-Link AG650 (Cardbus) and D-Link G520 (PCI) work fine.

Last night I've done some net dumping with athdebug 0xffffffff, and for single sniffed channel I havent noticed any problems, for over 6 hours, later I did over 1 hour channel hopping net monitoring w/o problems, and later after 30 minutes of sniffing card moved to a deaf mode. I'm going to attach athdebug logs from the point of time.

With athdebug 0xffffffff the card still dumps some (but less) network information to logs, but airodump-ng shows nothing.

Is this HAL/too new hardware - related problem? In several days I should be able to test some more AG660 (the same model).

Attachments

dwl-ag660_noreceive_athdebug.txt (28.6 kB) - added by marek@atm.com.pl on 10/25/06 14:16:14.
DWL-AG6600 B3 stopped receiving packets near 12:54:21/12:54:22

Change History

10/25/06 14:16:14 changed by marek@atm.com.pl

  • attachment dwl-ag660_noreceive_athdebug.txt added.

DWL-AG6600 B3 stopped receiving packets near 12:54:21/12:54:22

10/25/06 22:38:46 changed by marek@atm.com.pl

The second card (the same model/revision/etc.) have the same problem - after some time it stops receiving packets.

10/26/06 07:02:27 changed by mrenzmann

  • milestone deleted.

11/01/06 16:51:25 changed by anonymous

I have the smae problem with a D-Link DWL-g520. There is some solution?

11/01/06 23:53:53 changed by marek@atm.com.pl

As of my DWL-G520 card I have not noticed this problem, but I use it mostly in AP mode. My DWL-G520 sticker says H/w ver.: B3 F/W Ver.:4.30

#  lspci -nn -v -s 00:0a.0
00:0a.0 Ethernet controller [0200]: Atheros Communications, Inc. AR5212 802.11abg NIC [168c:0013] (rev 01)
        Subsystem: D-Link System Inc D-Link AirPlus DWL-G520 Wireless PCI Adapter(rev.B) [1186:3a13]
        Flags: bus master, medium devsel, latency 168, IRQ 5
        Memory at e7000000 (32-bit, non-prefetchable) [size=64K]
        Capabilities: [44] Power Management version 2

What is your revision of the card? What is the chip of your DWL-G520 (AR5212 or AR5006X). Is the problem exists when sniffing on a single channel?

BTW. in the mean time I've tested r1784 snapshot and still got the problem (with DWL-AG660).

11/02/06 20:11:01 changed by anonymous

At first, I have to execute the next commands to set my D-Link card in Monitor mode:

# wlanconfig ath26 destroy # wlanconfig ath26 create nounit wlandev wifi0 wlanmode monitor

Also, when I do it, the unit number is incremented by one (yes, with nounit option).

I don't know how to get all the information that you said about my card, but I can execute lspci :)

[root@PC]# lspci -nn -v -s 01:02.0
01:02.0 0200: 168c:0013 (rev 01)
        Subsystem: 1186:3a13
        Flags: bus master, medium devsel, latency 168, IRQ 217
        Memory at cadd0000 (32-bit, non-prefetchable) [size=64K]
        Capabilities: [44] Power Management version 2

The chip of my DWL-G520 card is an AR5212. when I'm sniffing all channels, after 5 or 10 minuts aprox. , my card stop to recieving packets, but the application works. But, when I'm sniffing in a single channel, after 1 minute aprox., the application brokes and I have to kill the process, because the CPU Fan becomes to work a lot.

thanks for all, and please, If you have some solution or you can help me in any way.. I thank you it.

One more time... THANK YOU VERY MUCH!

11/02/06 23:24:24 changed by marek@atm.com.pl

Version/revision of the card hardware and firmware should be printed on a sticker glued to the box (and probably also on the card) From the lspci data I assume that we have the same DWL-G520 model.

I use DWL-G520 card as an Access Point for the most of the time and have got option 'options ath_pci autocreate=ap' in my /etc/modprobe.conf file (ie. my autocreated ath0 is in ap mode). To enter the monitor mode I simply create ath1 device with:

wlanconfig ath1 create wlandev wifi0 wlanmode monitor 

and then launch airodump with

airodump-ng -w file ath1

My ap on ath0 stops working (the card has only one radio unit), but I can monitor without problems (on DWL-G520), and resume ap connections after monitoring.

Questions: what version of madwifi-ng do you use (dmesg | grep -e ath_hal -e ath_pci -e ath_rate or grep -e ath_hal -e ath_pci -e ath_rate /var/log/kernel), what kernel/arch (uname -a), is ath26 the only ath interface you have got configured (check iwconfig - there are some issues when the first interface is in station mode)? Have you tried other PCI slot or another card (to exclude hardware problem)? lspci tells that your card uses IRQ 217 - you could check cat /proc/interrupts if any other hardware uses the same interrupt. From the number of irq I assume that you have got an APIC enabled kernel/hardware - you could try to disable the feature with noapic kernel parameter (in grub/lilo/... - btw. probably not a good idea, but sometimes could help).

01/23/07 21:14:41 changed by netgear-user

Same thing is happening to me with a WG511T

04/02/07 11:50:03 changed by marek@atm.com.pl

The problem is still present for madwifi-hal-0.9.30.10-r2249-20070329. The issue shows up even faster - after ~ 3-6 minutes the card stops reveiving any signals when in monitoring mode (and changing chanells).

05/20/07 04:16:17 changed by dhflegend@mixmail.com

please! help me for D-Link DWL-AG660 H/W Ver B3 notify me some solution, thanks.

05/20/07 16:06:51 changed by strasak@bubakov.net

Numbering of units - you have to blame/adjust udev. I don't use it so can't help with that much, take a look at another tickets.

Problem with card not receiving pakets - here famous stuck beacon problem did that recently. Link - AP <-> sta - worked for some minutes, then stopped to work and even hasn't been able to scan, i have tried to destroy and create vap again, to no avail, only reboot helped. So, if you can, check athstats -i wifi0 if there are missed beacon interrupts. Also, check dmesg if there are stuck beacon messages. You could also play - as Marek wrote - with some settings, take a look in interrupts distribution in /proc/interrupts, even you could try to play with kernel - especially apic - parameters.

02/22/08 19:58:11 changed by marek@atm.com.pl

It looks like problem is gone with the 20080124 snapshot of madwifi-ng:

ath_hal: 0.9.30.13
wlan: svn r3235
ath_pci: svn r3235

Tested with a custom 2.6.24.2 kernel. Now I'm monitoring for 17 hours and 45 minutes and my card (D-Link AirPremier? AG DWL-AG660, H/W Ver.:B3 F/W Ver.:2.20) still gets new frames.

02/24/08 19:32:39 changed by mrenzmann

  • status changed from new to closed.
  • resolution set to fixed.
  • milestone set to version 0.9.5.

Thanks for the feedback. I'll close this as fixed in trunk. Feel free to reopen the ticket in case the issue reoccurs.