Please note: This project is no longer active. The website is kept online for historic purposes only.
If you´re looking for a Linux driver for your Atheros WLAN device, you should continue here .

Ticket #936 (new defect)

Opened 13 years ago

Last modified 11 years ago

txpower falls back to 8 every x minutes

Reported by: Michael Helmling <supermihi@web.de> Assigned to:
Priority: major Milestone:
Component: madwifi: other Version: v0.9.2
Keywords: txpower,speed Cc:
Patch is attached: 0 Pending:

Description

I have this problem with madwifi for several months now: While connection generally works fine, every maybe two or three minutes it slows down dramatically. With iwconfig I can then confirm that the txpower has set itself down to 8, instead of 15 which seems to be the default (germany). With "iwconfig ath0 txpower 15" I can set it back and the connection is fast again, for another two minutes ... I don't know what causes this, it's definitively no system power daemon or something like that, since I tried several linux distributions, and also turned iwconfig's power management off. I remember that when I got this laptop in february, the problem wasn't there, but now is since about april or may.

Change History

10/06/06 09:52:45 changed by mrenzmann

Can you give more information about your system? What card are you using, what chipset is on it, what countrycode/regdomain is set in the card? Can you please also try the most current development snapshot - it has a new HAL release, and it would be interesting if this issue is visible there, too.

10/06/06 11:30:05 changed by Michael Helmling <supermihi@web.de>

Sorry, I forgot to add the information. I have a Lenovo (IBM) Z60t Laptop with "Thinkpad 802.11a/b/g Wireless" mini PCIe-Card, that turns out to be an AR5212 chip. Currently using Ubuntu Linux EdgyEft? beta; here I have the problem both with the module from linux-restricted-modules-2.6.17-10 as well as with self-compiled svn version. I also do have an existing gentoo installation with the same issue here, and always tried latest svn versions. I then switched to use ndiswrapper with the drivers from IBM, which works very well, so it isn't a hardware issue. Also, as I said I remember that in the time when I got that laptop, about february/march 2006, it worked well with svn madwifi-ng.

10/06/06 13:12:01 changed by mrenzmann

Your card definitely is not using the 5212, since that's a PCI-only chipset. It's more likely one of the AR5006-family. However, it would be interesting to learn which version of MadWifi you were using at the time it worked in february/march. Any chance you find out about that?

10/06/06 14:47:26 changed by anonymous

Hmm, lspci says: 13:00.0 Ethernet controller: Atheros Communications, Inc. AR5212 802.11abg NIC (rev 01) PCI-ID is 168c:1014 When I started to use the driver, it was also latest svn version, which I updated every few days. Unfortunatelly I don't know how to examine which version was in SVN at a given time.

10/06/06 16:33:42 changed by mrenzmann

lspci is wrong in this case, the 5212 is definitely no PCI-E chipset.

All revisions of the given time can be seen here.

10/07/06 07:34:05 changed by anonymous

That's strange that lspci lists the wrong chip ... may that be the problem? I will try some of the old versions from your link this day, thanks.

10/07/06 13:30:59 changed by mrenzmann

lspci does not determine the chip version by asking the chipset, but by looking at the PCI ID. It might well be that it's not set correctly (from the pov of lspci), but that usually does not cause any problems, since the driver knows how to correctly distinct chipsets. However, trying older versions is still a good idea, since it might help to determine which revision introduced the change that broke the card for you.

11/05/06 14:27:20 changed by Michael Helmling <supermihi@web.de>

Hello, please excuse my long silence, I've been quite busy ... I have problems compiling the older versions of madwifi-ng, because the get_arch_target.sh script in the older version fails for some reason. If I manually change Makefile.inc and add "i386" for ARCH and "i386-elf" for TARGET it works, but this is quite annoying when testing different revisions. Any idea what I could do to make 'make' work without changes?

11/07/06 18:22:54 changed by Michael Helmling <supermihi@web.de>

It seems like the problem occurs between rev. 1606 and 1605, the CVS comment says "Update HAL to version 0.9.17.0 (from ath_hal-20060506.tgz)" for this change. With 1605 it seems to work perfectly, as soon as I update to 1606 and reboot the computer txpower is at 8 and even if I raise it manually I have connection problems.

12/28/06 22:56:58 changed by Michael Helmling<supermihi@web.de>

Just to mention, I now installed fedora core 6, and still the same ... so this is really a driver bug and nothing from the operating system.

05/29/07 07:04:08 changed by electrocomputerw@hotmail.com

Hello, I am Having the exact same problem with txpower dropping to 8. the time span seems to be random. but usually drops to 8 within a few minutes. I have tried to change the power management settings but I get an error. "Error for wireless request "Set Power Management" (8B2C) : SET failed on device ath0 ; Operation not supported." Also as a note the card still works at 8 with a range of about 2 feet. I am using an Acer Ferrari 5000, this laptop has a pci-e A/B/G card model AR5BXB6. lspci also identifies my card incorrectly. ("Ethernet controller: Atheros Communications, Inc. Unknown device 001c (rev 01)"). I am using the svn r2350 madwifi release on slackware 11. I am using a custom 2.6.21.1 kernel. I had the same problem with the 2.6.18.2 kernel before.

Thanks,

06/23/07 02:46:47 changed by anonymous

same problem here with an IBM thinkpat t60p

06/26/07 18:54:33 changed by Spencer Russell <spencer.f.russell@gmail.com>

I also have the same problem on my ThinkPad? R60. Also, when I run "iwlist ath0 txpower" several times, I get different lists. Usually I get:

ath0 8 available transmit-powers :

0 dBm (1 mW) 5 dBm (3 mW) 7 dBm (5 mW) 9 dBm (7 mW) 11 dBm (12 mW) 13 dBm (19 mW) 15 dBm (31 mW) 17 dBm (50 mW) Current Tx-Power=8 dBm (6 mW)

Sometimes I get: ath0 8 available transmit-powers :

0 dBm (1 mW) 3 dBm (1 mW) 5 dBm (3 mW) 7 dBm (5 mW) 9 dBm (7 mW) 11 dBm (12 mW) 13 dBm (19 mW) 15 dBm (31 mW) Current Tx-Power=8 dBm (6 mW)

or:

ath0 8 available transmit-powers :

0 dBm (1 mW) 4 dBm (2 mW) 6 dBm (3 mW) 8 dBm (6 mW) 10 dBm (10 mW) 12 dBm (15 mW) 14 dBm (25 mW) 16 dBm (39 mW) Current Tx-Power=8 dBm (6 mW)

or:

ath0 8 available transmit-powers :

0 dBm (1 mW) 2 dBm (1 mW) 3 dBm (1 mW) 4 dBm (2 mW) 5 dBm (3 mW) 6 dBm (3 mW) 7 dBm (5 mW) 8 dBm (6 mW) Current Tx-Power=8 dBm (6 mW)

07/28/07 23:26:26 changed by kae@midnighthax.com

I'm seeing exactly the same problem, and I've been researching this (off and on) for some time. There are lots of reports of poor range with this AR5212 (or whatever it really is) chipset, but this is the first time I've seen mention of the txpower setting. I can confirm that the txpower can be set to 15, but soon drops back to 8 and the range is then measured in inches.

Happy to carry out any tests to help resolve this issue.

08/04/07 07:01:15 changed by ctt

FYI, this appears to be the same issue as is described in #939 (which has been closed as a duplicate. Thanks for noticing!).

09/06/07 06:25:26 changed by electrocomputerw@hotmail.com

This is no longer a problem for my AR5BXB6 on the Ferrari 5000. It seems to work well with subversion release r2695. I'm not sure witch release fixed the problem as I have not followed them too closely. Also I don't know if it fixed the AR5212 or not. Thanks for the hard work..

07/14/08 04:21:48 changed by maurer.it@gmail.com

This is still a problem with what is identified by lspci to be the: "03:00.0 Ethernet controller: Atheros Communications Inc. AR5212 802.11abg NIC (rev 01)" on my ThinkPad T61 Running Ubuntu Hardy with the following kernel and other information

uname -a (snippet):

    ... 2.6.24-19-generic !#1 SMP ... i686 GNU/Linux

linux-restricted-modules-2.6.24-19-generic
Which contains madwifi-0.9.4 (verified with current stable download to be identical)

ThinkWiki reports this specific card to be:
ThinkPad 11a/b/g Wireless LAN Mini Express Adapter [I'd supply a link but I can't :(]
I can verify the following information from physical inspection of the card itself:

Manufacturer: Anatel
Card Type: AR5BXB6
IC: 4104A-AR5BXB6

I have however successfully gotten the card to work now for 15 minutes without txpower fiddling using r2756 with current iwconfig output of:

ath0      IEEE 802.11g  ESSID:"[removed]"  Nickname:""[[BR]]
          Mode:Managed  Frequency:2.437 GHz  Access Point: 00:02:2D:8E:5A:03   [[BR]]
          Bit Rate:11 Mb/s   Tx-Power:17 dBm   Sensitivity=1/1  [[BR]]
          Retry:off   RTS thr:off   Fragment thr:off[[BR]]
          Power Management:off[[BR]]
          Link Quality=33/70  Signal level=-62 dBm  Noise level=-95 dBm[[BR]]
          Rx invalid nwid:26344  Rx invalid crypt:0  Rx invalid frag:0[[BR]]
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

Hopefully this helps someone :D.

Thanks for the effort with this driver, you've saved me from ndiswrapper (which I've confirmed to work):D.