Please note: This project is no longer active. The website is kept online for historic purposes only.
If you´re looking for a Linux driver for your Atheros WLAN device, you should continue here .

Ticket #930 (closed enhancement: fixed)

Opened 13 years ago

Last modified 11 years ago

adjust madwifi for WE21, which no longer reports SSID length + 1

Reported by: kelmo Assigned to:
Priority: major Milestone: version 0.9.5
Component: madwifi: driver Version: trunk
Keywords: Cc:
Patch is attached: 0 Pending:

Description

Wireless Extensions 21 no longer tacks on an extra byte to the essid, therefore we need check that ieee80211_ioctl_siwessid (net80211/ieee80211_wireless.c) handles this properly.

Change History

03/23/07 14:36:26 changed by anonymous

I just tried Madwifi-0.9.3 on Linux-2.6.20.1. Setting the SSID with iwconfig fails for an SSID with 32 characters. This seems to fit the ticket at hand.

03/24/07 01:56:30 changed by mentor

  • status changed from new to closed.
  • resolution set to fixed.

I've removed the fudge code when WIRELESS_EXT >= 21. However, the fudge shouldn't have broken correct operation.

In r2210

07/05/07 11:55:51 changed by mrenzmann

  • status changed from closed to reopened.
  • version set to trunk.
  • resolution deleted.
  • milestone changed from version 0.9.x - progressive release candidate phase to version 0.9.4.

Reopening the ticket due to this report in madwifi-devel.

(follow-up: ↓ 10 ) 07/05/07 12:01:04 changed by anonymous

I wrote the report mentioned by mrenzmann. I just tried SVN r2538 and it still fails.

Just try:

iwconfig ath0 essid 12345678901234567890123456789012

vs

iwconfig ath0 essid 1234567890123456789012345678901

07/05/07 12:34:17 changed by anonymous

The same bug exists with an Intel ipw2200bg and Linux-2.6.20, so it is probably in the generic WE-21 code.

07/09/07 11:59:11 changed by anonymous

Jean Tourrilhes confirmed that this is a bug in the generic wireless code. A patch for Linux 2.6.23 is coming soon that will be backported to older versions. I think this ticket can beclosed again.

07/09/07 13:07:57 changed by mrenzmann

Closing on request here and here.

07/09/07 13:08:08 changed by mrenzmann

  • status changed from reopened to closed.
  • resolution set to fixed.

02/11/08 06:13:04 changed by mrenzmann

  • milestone changed from version 0.9.4 to version 0.9.5.

(in reply to: ↑ 4 ) 08/30/08 02:51:41 changed by anonymous

Replying to anonymous:

I wrote the report mentioned by mrenzmann. I just tried SVN r2538 and it still fails. Just try: {{{ iwconfig ath0 essid 12345678901234567890123456789012 }}} vs {{{ iwconfig ath0 essid 1234567890123456789012345678901 }}}

Hi,

Quick update. The kernel patch was rejected, and therefore this bug (cannot read ESSID with 32 bytes) was still lingering. Recently, I found a way to fix that in userspace, and I implemented it in v30.pre7. So, upgrade Wireless Tools and that should be fixed...

Jean