Please note: This project is no longer active. The website is kept online for historic purposes only.
If you´re looking for a Linux driver for your Atheros WLAN device, you should continue here .

Ticket #926 (reopened defect)

Opened 13 years ago

Last modified 12 years ago

Kismet does not capture with Atheros

Reported by: acatala@moliprimer.com Assigned to:
Priority: major Milestone:
Component: madwifi: other Version: v0.9.2
Keywords: kismet powerbook wlan_scan_monitor Cc:
Patch is attached: 0 Pending:

Description

I can not capture traffic with my Atheros card and Kismet.

This is my hardware: Apple Powerbook G4 + Netgear WG511T

This is my software: Yellow Dog Linux 4.0 (kernel 2.6.8), MadWifi driver 0.9.2, kismet 2006-04-R1

I can use and capture traffic with Netgear card in monitor mode with airsnort and airodump-ng, but I can not do it with Kismet.

Every time I run Kismet I get this lines with dmesg: unable to load wlan_scan_monitor device kis entered promiscuous mode

Best regards.

Change History

09/30/06 11:03:58 changed by kelmo

  • status changed from new to closed.
  • resolution set to worksforme.
  • milestone changed from version 0.9.3 to version 0.9.x - progressive release candidate phase.

So you followed this guide and it still fails to work?

This works for me and many others (the wla_scan_monitor warning is already know) so I will clode as WorksForMe? until you can provide more compelling evidence.

09/30/06 17:49:05 changed by acatala@moliprimer

  • status changed from closed to reopened.
  • resolution deleted.

I have followd that guide and still fails to work. I have used Kismet with a Cisco Aironet card and it worked, now I have changed parameters to run with my Atheros following the guide you have said and it does not work.

Kismet is not difficult to configure. But I am getting no traffic at all. But I can get traffic with this computer + this Atheros card + this MadWifi driver and airsnort and airodump too.

Thanks.

10/02/06 18:50:42 changed by mrenzmann

  • milestone deleted.

The "cannot load wlan_scan_monitor" message can be ignored for now. That's an issue that should be fixed, but it's most certainly not the source of your problems.

Please give more exact details about the steps that are needed to reproduce your problems. You mentioned that you're using a previously installed version of Kismet - did you double-check that this version matches the criteria as explained on UserDocs/kismet? Read: is it a current Subversion checkout of kismet-devel?

10/13/06 09:14:35 changed by anonymous

Dear mrenzmann,

currently I am using latest stable version of kismet and I have tried too a subversion checkout of kismet-devel. I also have applied that it is said at UserDocs/kismet. I think my problem is not due a wrong use of kismet or configuration.

I have just downloaded source code of madwifi driver (both stable 0.9.2 and subversion) and I have compiled and instaled. I have also downloaded source code of kismet (stable and subversion too) and I have compiled and instaled. I have not found any problem with compilation and instalation.

Then I have configured kismet following instructions at UserDocs/kismet.

Recall that I am using a PowerPC Apple PowerBook? G4 with YellowDog? Linux 4.0 (based on Fedora).

Best regards.

10/13/06 09:16:06 changed by acatala@moliprimer

By the way, last message is sent by me, I have forgotten to write my e-mail, I am sorry.

10/30/06 13:59:41 changed by anonymous

same problem with latest version of Kubuntu (Linux version 2.6.15-27-386 (buildd@terranova) (gcc version 4.0.3 (Ubuntu 4.0.3-1ubuntu5)))

-start Kismet -device enter promiscous mode -after a few minutes no more packets -performing the command "iwpriv ath0 sleep 1" -kismet capture paketes again (for a few Minutes)

+Oct 30 13:25:15 localhost kernel: [17186379.504000] unable to load wlan_scan_monitor +Oct 30 13:25:16 localhost kernel: [17186380.508000] device kis entered promiscuous mode Oct 30 13:23:34 localhost kernel: [17186278.324000] ath_rate_sample: no rates for 00:60:b3:5a

12/04/06 19:48:41 changed by mikael@0hlsson.se

I have exactly the same problem. madwifi compiles installs and seems to run just fine but withe the following exceptions:

kismet - Doesnt find any networks aircrack (with patched driver) - Everything but packet injection works fine. dogbrain@hal:~/egen$ sudo aireplay-ng -1 0 -e ap -a XX:XX:XX:XX:XX:XX -h 00:11:22:33:44:55 ath1 19:45:51 Sending Authentication Request 19:45:51 Authentication successful 19:45:51 Sending Association Request 19:45:56 Sending Authentication Request 19:45:56 Authentication successful 19:45:56 Sending Association Request ....

feel free to contact me if you need more information... or need to test on a ppc... (only developers of madwifi)

12/04/06 19:55:34 changed by mikael@0hlsson.se

btw i tested with the latest svn version patched and unpatched for aircrack. I also tested with r1816.

01/19/07 16:53:27 changed by acatala@moliprimer.com

I have new data about this problem.

When I use my Netgear WG511T to link to my AP and I write "iwconfig ath0", I get this values:

ath0 IEEE 802.11g ESSID:"MyESSID" Nickname:"my_name"

Mode:Managed Frequency:2.422GHz Access Point: 00:11:22:33:44:55 Bit Rate:54Mb/s Tx-Power:18 dBm Sensitivity=0/3 Retry:off RTS thr:off Fragment thr:off Power Management:off Link Quality:65/94 Signal level:-30 dBm Noise level:-95 dBm Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0 Tx excessive retries:0 Invalid misc:0 Missed beacon:0

But, when I destroy all non-monitor VAPs and start kismet, and I write "iwconfig kis", I get this values:

kis IEEE 802.11g ESSID:""

Mode:Monitor Frequency:2.422GHz Access Point: 00:11:22:33:44:55 Bit Rate:0kb/s Tx-Power:18 dBm Sensitivity=0/3 Retry:off RTS thr:off Fragment thr:off Encryption key:off Power Management:off Link Quality:0/94 Signal level:-95 dBm Noise level:-95 dBm Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0 Tx excessive retries:0 Invalid misc:0 Missed beacon:0

Look at "Signal level" in both cases. With "kis" interface "Signal level" and "Noise level" are the same !!.

04/21/07 05:07:29 changed by martind@noxam.com

Got the same problem here!

Running Backtrack 2 tried 2 pcmacia atheros based card (D-Link DWL-G650 and the D-Link WNA-1330)

Kismet stoped gathering info after a couple minute... sometime up to a 30 min. I notice that when setting lowering the channel hopping, it seem to help gathering info for a longer time...

doing "iwpriv kis sleep 1" ( "kis" is the interface created by kismet instead of ath0 ) seem to fix up the issue until it re-apear...

I think I'll do a little script doing a loop issuing the iwpriv command every 30 sec...

btw... sorry for my english... not my primary language... ;-)