Please note: This project is no longer active. The website is kept online for historic purposes only.
If you´re looking for a Linux driver for your Atheros WLAN device, you should continue here .

Ticket #894 (new defect)

Opened 13 years ago

Last modified 11 years ago

Connection stops after 3 seconds. ath_rate_sample: no rates for ...

Reported by: Peter <pva@gentoo.org> Assigned to:
Priority: major Milestone:
Component: madwifi: other Version: v0.9.2
Keywords: Cc:
Patch is attached: 0 Pending:

Description (Last modified by mrenzmann)

Hello.

I have a problem that is very similar to already reported in ticket #287 by erik.tews at gmail.com. But as this is another issue not related to that ticket I opened a new one.

I'm trying to connect two coomputers with adhoc network. I'm using the following commands:

# modprobe ath_pci autocreate=none
# wlanconfig ath0 create wlandev wifi0 wlanmode adhoc
# iwconfig ath0 essid "hn" key open 1234-1234-65
# ip addr add 192.168.0.3/24 brd + dev ath0
# ip link set dev ath0 up

After this wireless connection works for three seconds or so (I'm pinging the other end and only three pings pass), after that I receive a message in kernel log

ath_rate_sample: no rates for 00:05:4e:4b:09:2d?

And connection stops. I've tryied to play with channels on both ends, but still no luck. I've tryed to change rate_sample on rate_amrr, but then connection dies without any kernel message. I have this problem with madwifi-ng-0.9.2 and madwifi-ng-0.9.1, but I do not have such problem with madwifi-ng-0.0.1531.20060427.

I have built in wifi card in thinkpad T41 notebook:

02:02.0 Ethernet controller: Atheros Communications, Inc. AR5212 802.11abg NIC (rev 01)

And seems that it is important (this drivers versions worked with some wireless access point) another end of connection is windows XP with "LNW 802.11g Wireless USB Card LSC-710".

Are there any ideas what can be done?

TIA

Change History

09/19/06 09:25:04 changed by mrenzmann

  • description changed.

11/25/06 20:48:10 changed by duke@splatterworld.de

same behaviors here. maybe i'll give the cvs a try.

01/04/07 06:21:45 changed by anonymous

I have the same problem. Neither sample nor amrr work - however, onoe seems to work fine (with 0.9.2).

06/01/07 17:15:59 changed by mentor

  • priority changed from critical to major.

Can the original submitter confirm that this is still a problem?

(follow-up: ↓ 10 ) 07/18/07 16:08:07 changed by vm2

Hi, I am having the above mentioned problem.

I have two adhoc interfaces up with Madwifi 0.9.3.1. I set the network up using the same bssid on both. For the initial few minutes things work fine and i can ping from one to the other,i have tried long ping sessions which work fine. But once the card is idle for a sometime the network seems to be down and even ping's dont get through. And i get ath_rate_sample: no rates for 00:05:4e:4b:09:2d?

Please do let me know what more debug info is needed.

08/09/07 04:52:42 changed by madcow-vt

Hi I am using madwifi ath_pci: 0.9.4.5 (0.9.2.1) and I have encountered the same problem. Has this been fixed?

08/09/07 10:06:19 changed by mrenzmann

As written in 4: we're awaiting feedback from either the original poster or any other person who experienced that problem in the past that the issue still exists. A clarification to this is that it should be tested with the latest trunk, not with any of the release versions.

02/19/08 01:35:16 changed by ibr@radix50.net

I still experience the "no rates" issue with a PCI AR5212 802.11abg and r3358. Ping doesn't work at all, but I've seen it working before, with r1842, without WEP. Scanning works, essid and cell are automatically set to the values of the other ad-hoc node. The other end supports 11 Mbps at most. I've used the following commands:

sudo wlanconfig ath0 destroy sudo wlanconfig ath0 create wlandev wifi0 wlanmode ad-hoc # This says "ath0" but creates ath1 sudo iwconfig ath1 key 1234-5678-90 # Actually, 26-digit sudo iwpriv ath1 authmode 2 sudo ifconfig ath1 inet 192.168.2.1 up

I would be also glad to know if at least a workaround exists.

08/14/08 05:21:34 changed by Andrej Podzimek

The same problem here. Those messages appear ocassionally. The AP device:

01:06.0 Ethernet controller: Atheros Communications Inc. AR5212/AR5213 Multiprotocol MAC/baseband processor (rev 01)

(in reply to: ↑ 5 ) 09/19/08 00:40:09 changed by anonymous

And I have the same issue.

Acer Aspire One madwifi-hal-0.10.5.6-r3835-20080801.tar.gz

Can connect to access point (WPA personal) but connection is 'blocked'

dmesg showing "no rates for xx:xx:xx:xx"

09/19/08 00:58:57 changed by anonymous

Sorry to reply to my own post. And so quickly. Good news for me: it works. Probably worked all along?

It turned out my Ubuntu install wasn't correctly signaling an ifdown on cable disconnect of wired NIC. This was preventing the WiFi NIC from being actually used (apparently there is no link combining, load balancing or round robin routing going on. Funny, since both NICs are on the same subnet)

It could just be that others have run into the same problem since this is pretty much stock Ubuntu on Acer Aspire One (see https //help.ubuntu.com/community/AspireOne for steps followed)

I'd venture that in my case the "no rate" log was spurious/incidental