Please note: This project is no longer active. The website is kept online for historic purposes only.
If you´re looking for a Linux driver for your Atheros WLAN device, you should continue here .

Ticket #891 (closed defect: fixed)

Opened 13 years ago

Last modified 11 years ago

Problem with MADWiFi on PowerPC

Reported by: anonymous Assigned to:
Priority: major Milestone: version 0.9.5
Component: madwifi: other Version:
Keywords: Cc:
Patch is attached: 0 Pending:

Description

We are using SR5 wlan module in our project. We have downloaded the driver source from sourceforge.net version madwifi-0.9.2.tar.bz2. We successfully compiled the source and installed for X86 platform with out errors. The SR5 module is communicating with Acess point and peers.

Now our requirement is the SR5 WLAN module has to work for PowerPC platform. The same source code is used for PowerPC. The source code was successfully compiled for the powerPC and generated the ".ko" files. After that when we are trying to install the "ath_pci.ko" module, it is giving the following error messages

unable to attach hardware : Hardware revision not supported (HAL status 13)

What could be the reason? Please provide your comments/suggestions to avoid the problems. Your help is highly appreciated.

Change History

09/22/06 19:42:28 changed by mentor

Could you try with the latest subversion as I've just commited some changes modifying PCI register access...

r1727

05/29/07 04:18:32 changed by Elmar Hoffmann <elho@elho.net>

I've also seen that error on PowerPC, but also in later versions. pccardctl eject ; pccardctl insert helped, with 0.9.3 that was only necessary once after boot (but every time), previously it could take a couple of attempts.

I switched to trunk (r2380) today, and it is the first time I did not see that error since switching from madwifi-old to -ng.

05/29/07 04:48:42 changed by mrenzmann

  • status changed from new to closed.
  • resolution set to fixed.
  • milestone set to version 0.9.4.

Thanks for the feedback. I close this ticket as being fixed.

In case the original (anonymous) reporter follows the ticket and is still struck by this issue after upgrading to trunk, please feel free to reopen it. The same applies to others, of course.

(follow-up: ↓ 6 ) 05/30/07 19:07:30 changed by kos@arhont.com

have the similar problem with card not being initialised

As suggested, downloaded the latest version through svn, and nothing has changed. Have tried several atheros cards. Stuck with the same error pccard: CardBus card inserted into slot 0 PCI: Enabling device 0001:11:00.0 (0000 -> 0002) MadWifi: unable to collect channel list from HAL; regdomain likely 53 country code 16

05/30/07 19:58:28 changed by kos@arhont.com

My apologies,

tried madwifi-old-openhal and now it works third time i reinsert the card :)

(in reply to: ↑ 4 ) 05/31/07 05:51:43 changed by mrenzmann

Replying to kos@arhont.com:

MadWifi: unable to collect channel list from HAL; regdomain likely 53 country code 16

That's a different issue, caused by requesting to use a countrycode that does not match the regdomain setting stored in the EEPROM of your card. Omitting the countrycode module parameter should fix this.

02/11/08 06:12:42 changed by mrenzmann

  • milestone changed from version 0.9.4 to version 0.9.5.