Please note: This project is no longer active. The website is kept online for historic purposes only.
If you´re looking for a Linux driver for your Atheros WLAN device, you should continue here .

Ticket #799 (new defect)

Opened 15 years ago

Last modified 15 years ago

EMP 8602 mini-pci card HAL Status 3

Reported by: soulbuzz@gmail.com Assigned to:
Priority: major Milestone:
Component: madwifi: driver Version: trunk
Keywords: HAL Status 3 Cc:
Patch is attached: 0 Pending:

Description

I am using a mini-pci card EMP 8602 from embedded-works on a freescale MPC83xx board. I keep getting wifi%d: unable to attach device (HAL Status 3)

Change History

08/03/06 10:51:48 changed by soulbuzz@gmail.com

Adding to the above post

I tried several things, switching off the radio by passing module param, masking pin 13 none helped.

09/04/06 04:31:16 changed by mentor

  • priority changed from critical to major.
  • owner deleted.
  • milestone deleted.

11/08/06 17:24:08 changed by d.baker@mchsi.com

I am also using the EMP-8602 mini-pci card and have the same problem attaching this device. My target is the IXP425-based Pronghorn Metro board from ADI. Some snippets from my output are shown below.

# modprobe ath_pci
Using /lib/modules/2.4.31-uc0-adi0/kernel/drivers/net/wlan.o
wlan: 0.8.4.2 (svn r1784)
Using /lib/modules/2.4.31-uc0-adi0/kernel/drivers/net/ath_hal.o
ath_hal: 0.9.18.0 (AR5210, AR5211, AR5212, RF5111, RF5112, RF2413, RF5413, REGOPS_FUNC)
Using /lib/modules/2.4.31-uc0-adi0/kernel/drivers/net/ath_rate_sample.o
ath_rate_sample: 1.2 (svn r1784)
Using /lib/modules/2.4.31-uc0-adi0/kernel/drivers/net/ath_pci.o
ath_pci: 0.9.4.5 (svn r1784)
wifi%d: unable to attach hardware: 'Hardware revision not supported' (HAL status 13)
...
# rmmod ath_pci
ath_pci: driver unloaded
# lsmod
Module                  Size  Used by
ath_rate_sample         9424   0
ath_hal               197616   0 [ath_rate_sample]
wlan                  157056   0 [ath_rate_sample]
ixp400_eth             23820   0 (unused)
ixp400               4561744   0 [ixp400_eth]
# insmod ath_pci rfkill=0
Using /lib/modules/2.4.31-uc0-adi0/kernel/drivers/net/ath_pci.o
ath_pci: 0.9.4.5 (svn r1784)
wifi%d: unable to attach hardware: 'Hardware didn't respond as expected' (HAL status 3)