Please note: This project is no longer active. The website is kept online for historic purposes only.
If you´re looking for a Linux driver for your Atheros WLAN device, you should continue here .

Ticket #714 (closed defect: worksforme)

Opened 13 years ago

Last modified 10 years ago

Scanning does not work in pseudo ad-hoc mode

Reported by: matt@mattb.net.nz Assigned to:
Priority: major Milestone:
Component: madwifi: driver Version: v0.9.0
Keywords: Cc:
Patch is attached: 0 Pending:

Description

When operating in Pseudo Ad-Hoc mode the card is not able to scan.

# iwlist ath0 scan
ath0       No scan results

Switching the interface to managed or normal Ad-Hoc mode correctly returns scan results.

I suspect this is due to the scan module not being correctly loaded/configured for pseudo ad-hoc mode.

Change History

06/23/06 01:12:47 changed by georg@boerde.de

If by pseudo ad-hoc you mean the Ad Hoc Demo mode, then this is a feature and not a bug. In Ad Hoc Demo mode there is only one cell without a BSSID, basically covering all devices in Ad Hoc Demo mode. Thus, scanning is neither required nor wanted.

06/23/06 01:27:05 changed by matt@crc.net.nz

I disagree

It is still of interest to know about other 802.11 networks that are operating in different modes for the purpose of choosing a channel to operate on.

Scanning is used for much more than just finding other nodes to associate to.

I see no fundamental reason why the driver shouldn't provide this information to the user if it is requested.

07/17/07 15:08:26 changed by mtaylor

  • status changed from new to closed.
  • resolution set to worksforme.

This ticket has not been updated in over six months and is being marked as "works for me" automatically.

If the ticket is still applies to the head revision of trunk, please re-open the ticket and provide any additional details needed and progress on the problem to date. Thanks.

03/10/09 08:48:53 changed by anonymous

You could make an sta vap and scan on that?