Please note: This project is no longer active. The website is kept online for historic purposes only.
If you´re looking for a Linux driver for your Atheros WLAN device, you should continue here .

Ticket #663 (new defect)

Opened 15 years ago

Last modified 13 years ago

Unspecified connection packet loss, dropping, etc. problems

Reported by: fca Assigned to:
Priority: major Milestone:
Component: madwifi: other Version:
Keywords: receive sensitivity Cc:
Patch is attached: 0 Pending:

Description (Last modified by mrenzmann)

Hello -

Using the latest madwifi -

I have two cards, a D-Link DWL-G122 and an Atheros one in a Fujitsu laptop. My access point is about 1 metre from the computer. The D-Link, using ndiswrapper, always reports 100% quality and no noise, even away from the access point. The Atheros reports 45/94 quality under Linux, with lots of noise, and stops working about 5m from the access point. Under windows, the card works normally. This makes the card practically useless under Linux.

I also noticed that most people using madwifi, when reporting about some problem, and when they include some iwconfig output, always have a very low link quality.

I am now in another room, away from the access point:

D-Link reports:

wlan0     IEEE 802.11g  ESSID:"cardonet"
          Mode:Managed  Frequency:2.462 GHz  Access Point: 00:60:B3:E2:59:96
          Bit Rate:24 Mb/s   Tx-Power:20 dBm   Sensitivity=-115 dBm
          RTS thr:2347 B   Fragment thr:2346 B
          Encryption key:off
          Power Management:off
          Link Quality:100/100  Signal level:-62 dBm  Noise level:-256 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

however, the Atheros can't even find the access point, as it only works when very near the transmitter:

ath0      No scan results

Any clues?

ath_pci is loaded with rfkill=0 wlan_scan_sta is also loaded OK

Change History

06/03/06 23:58:14 changed by mentor

Could you give the output of athstats and 80211stats. Please enclose preformatted text in:

{{{
Text
}}}

06/04/06 00:50:08 changed by anonymous

BTW, 45/94 is a very good signal (don't understand it as a division between 45 and 94). For windows, such signal quality equal 100% (50% under windows is more or less 20/94), that's why ndiswrapper reports 100% link. The windows driver doesn't report noise value, that's why ndiswrapper tells there's no noise

06/06/06 14:39:41 changed by mrenzmann

  • priority changed from blocker to major.
  • description changed.

What version of the wireless tools are you using?

06/07/06 23:30:03 changed by fca

Hello -

just upgraded to wireless-tools 28 just in case, but the problem persists. Computer cannot connect even in the same room as the access point, when it gets about 2 metres away from it...

to (slightly) increase link quality I turned diversity off

/proc/sys/dev/wifi0/diversity is set to "0" /proc/sys/dev/wifi0/txantenna is set to "1" /proc/sys/dev/wifi0/rxantenna is set to "1"

athstats output:

73 tx management frames
1046 tx failed due to too many retries
11861 long on-chip tx retries
68 tx frames with no ack marked
3221 tx frames with short preamble
791 tx frames with an alternate rate
631 rx failed due to bad CRC
2494 rx failed due to frame too short
52337 PHY errors
    5157 OFDM timing
    2 OFDM illegal parity
    2 OFDM illegal service
    11 OFDM restart
    25591 CCK timing
    123 CCK header crc
    3562 CCK illegal rate
    17889 CCK restart
183 periodic calibrations
rssi of last ack: 50
rssi of last rcv: 49
1 switched default/rx antenna
Antenna profile:
[1] tx     2146 rx     9894
[2] tx        0 rx     1155

80211 stats:

577 rx from wrong bssid
9423 rx discard due to it's a dup
18 rx discard due to mcast echo
78 rx discard mgt frames
2 rx frame chan mismatch
197 rx bad authentication request
3 active scans started
1 nodes timed out inactivity

06/07/06 23:45:35 changed by fca

Hello -

did some more testing and fiddling and this happens about 10 metres from the access point (behind a wall):

ath0      Scan completed :
          Cell 01 - Address: 00:60:B3:E2:59:96
                    ESSID:"cardonet"
                    Mode:Master
                    Frequency:2.412 GHz (Channel 1)
                    Quality=29/94  Signal level=-66 dBm  Noise level=-95 dBm
                    Encryption key:off
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 22 Mb/s
                              6 Mb/s; 9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s
                              36 Mb/s; 48 Mb/s; 54 Mb/s
                    Extra:bcn_int=200

... and yet I cannot connect...

Internet Systems Consortium DHCP Client V3.0.3-RedHat
Copyright 2004-2005 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/products/DHCP

wifi0: unknown hardware address type 801
/sbin/dhclient-script: configuration for ath0 not found. Continuing with defaults.
/etc/sysconfig/network-scripts/network-functions: line 62: ath0: No such file or directory
wifi0: unknown hardware address type 801
Listening on LPF/ath0/00:c0:a8:aa:4e:0f
Sending on   LPF/ath0/00:c0:a8:aa:4e:0f
Sending on   Socket/fallback
DHCPREQUEST on ath0 to 255.255.255.255 port 67
DHCPREQUEST on ath0 to 255.255.255.255 port 67
DHCPREQUEST on ath0 to 255.255.255.255 port 67
DHCPDISCOVER on ath0 to 255.255.255.255 port 67 interval 6
DHCPDISCOVER on ath0 to 255.255.255.255 port 67 interval 18
DHCPDISCOVER on ath0 to 255.255.255.255 port 67 interval 9
DHCPDISCOVER on ath0 to 255.255.255.255 port 67 interval 15
DHCPDISCOVER on ath0 to 255.255.255.255 port 67 interval 7
DHCPDISCOVER on ath0 to 255.255.255.255 port 67 interval 6
No DHCPOFFERS received.
Trying recorded lease 192.168.1.100

any clues?

10/02/06 13:06:43 changed by uglymouse@saunalahti.fi

Hi, I have noticed the same problem. It doesn't depend on chipset. I have used ar5213 and ar5414 based cards. Your athstats looks very similar to mine and there is one interesting thing I would like you to check. Antenna profile on your athstats shows that even you have configured deversity off and statically defined rx/txantenna to 1 it tries to use rxantenna 2 for some reason. Could you check, while making some throughput, if /proc/sys/dev/wifiX/rxantenna setting changes on fly from 1 to 2. This happens quite often with ar5414 based card and bit rarely with ar5213 based card with my setup. One weird thing is that this happens only with wlan1 if I have two wlan-interfaces. wlan0 works just fine.

-Kristian

11/01/06 14:19:36 changed by email@svenk.info

Hello-

i have the same problem. I'm using latest madwifi and with 10-20 meters to AP and 1 wall, i can't connect. But, with windows and freebsd it works without any problem.

Sven

12/31/06 19:05:15 changed by martin.bures@gmail.com

I too have the same problem. I have a macbook. Here is the information that I have gotten out of OS X - they don't have a /proc so I don't know how to get it to tell me anything more...

AirPort? Card Information:

Wireless Card Type: AirPort? Extreme (0x168C, 0x86) Wireless Card Locale: USA Wireless Card Firmware Version: 0.1.27 Current Wireless Network: 1234 Wireless Channel: 6

On the same machine, I am running Ubuntu Edgy: Linux martin-laptop 2.6.17-10-generic #2 SMP Tue Dec 5 22:28:26 UTC 2006 i686 GNU/Linux

From demsg: [17179587.932000] ath_hal: module license 'Proprietary' taints kernel. [17179587.932000] ath_hal: 0.9.17.2 (AR5210, AR5211, AR5212, RF5111, RF5112, RF2413, RF5413) [17179588.912000] ath_rate_sample: 1.2 (0.9.2) [17179588.920000] ath_pci: 0.9.4.5 (0.9.2) [17179589.464000] wifi0: 11a rates: 6Mbps 9Mbps 12Mbps 18Mbps 24Mbps 36Mbps 48Mbps 54Mbps [17179589.464000] wifi0: 11b rates: 1Mbps 2Mbps 5.5Mbps 11Mbps [17179589.464000] wifi0: 11g rates: 1Mbps 2Mbps 5.5Mbps 11Mbps 6Mbps 9Mbps 12Mbps 18Mbps 24Mbps 36Mbps 48Mbps 54Mbps [17179589.464000] wifi0: turboG rates: 6Mbps 12Mbps 18Mbps 24Mbps 36Mbps 48Mbps 54Mbps [17179589.464000] wifi0: H/W encryption support: WEP AES AES_CCM TKIP [17179589.464000] wifi0: mac 10.3 phy 6.1 radio 10.2 [17179589.464000] wifi0: Use hw queue 1 for WME_AC_BE traffic [17179589.464000] wifi0: Use hw queue 0 for WME_AC_BK traffic [17179589.464000] wifi0: Use hw queue 2 for WME_AC_VI traffic [17179589.464000] wifi0: Use hw queue 3 for WME_AC_VO traffic [17179589.464000] wifi0: Use hw queue 8 for CAB traffic [17179589.464000] wifi0: Use hw queue 9 for beacons [17179589.468000] wifi0: Atheros 5424: mem=0x90100000, irq=169 [17179628.392000] ath0: no IPv6 routers present

It displays half the connection strength that is displayed in OS X. Even when the computer is touching the wireless router, I cannot get a full strength signal. Looking in proc, it seems that it is trying to use channel two, like the cases above. Additionally, were the Mac takes a second or two to establish a connection, running Linux, it can take up to a minute. And some connections with low signal strength that can be established with the Mac cannot be seen or connected to with linux.

Here is information from the /proc output: Diversity : 1 Debug : 0 fftxqmin : 3 rxantenna : 2 txantenna : 0

Let me know if I can provide you with more information. I am trying to figure out all of this, so be patient with me! ;)

01/04/07 03:32:49 changed by anonymous

I've the same problems. Acer Aspire 3620.

01/20/07 08:06:41 changed by hbock@providence.edu

I'm having a very similar problem - when I'm directly under an access point at school (actually, there are 2 of them in close proximity) I only get 24%-ish signal, while on Windows I consistently get 95%. The connection as a result is unstable, although it works just fine while it is up. This isn't so much a problem as when I'm in an engineering lab and I can only get 10% signal, so the connection continually is established and then dropped, while in Windows it is around 70% and stable. Finally, sitting less than a foot away from my new Linksys router, I only get 36% signal. I'm using the signal strength reported by NetworkManager, not iwlist, if that matters.

I am using wireless-tools 28 on Fedora Core 6, using the most recent kernel (2.6.19.2) and kmod-madwifi packages from livna. Output from athstats:

1105 tx management frames
1 long on-chip tx retries
1084 tx frames with no ack marked
790 rx failed due to bad CRC
31544 PHY errors
    16636 OFDM timing
    14908 CCK timing
1245 periodic calibrations
1 rfgain value change
rssi of last rcv: 36
126 switched default/rx antenna
Antenna profile:
[1] tx      673 rx     8555
[2] tx       28 rx     4933

From 80211stats:

1102 rx from wrong bssid
75 rx discard due to mcast echo
13231 rx element unknown
91 rx frame chan mismatch
10 rx bad authentication request
1 tx failed due to no defkey
20 active scans started
1 nodes timed out inactivity

If any more information is necessary, let me know :) Thanks!

01/21/07 14:26:12 changed by aleksabl-gmail

I can also confirm this bug, along with other Ubuntu users (https ://launchpad.net/ubuntu/+bug/66481 and http ://ubuntuforums.org/showthread.php?t=305491).

I'm using a SMC EZ Connect Wireless G PCI 108 Mbps card which has the AR5212 chip.

$ lspci | grep -i 'ath'
04:08.0 Ethernet controller: Atheros Communications, Inc. AR5212 802.11abg NIC (rev 01)

$ lsmod | grep -i 'ath'
ath_pci               100000  0 
ath_rate_sample        16512  1 ath_pci
wlan                  207708  5 wlan_tkip,wlan_scan_sta,ath_pci,ath_rate_sample
ath_hal               192976  3 ath_pci,ath_rate_sample


$ iwconfig ath0
ath0      IEEE 802.11g  ESSID:"ev30bh0102"  
          Mode:Managed  Frequency:2.417 GHz  Access Point: 00:18:F8:3C:0F:EE   
          Bit Rate:18 Mb/s   Tx-Power:18 dBm   Sensitivity=0/3  
          Retry:off   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=27/94  Signal level=-65 dBm  Noise level=-95 dBm
          Rx invalid nwid:25355  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

The PC is located 3 meters away from the AP. I'm having problems with loss of connectivity and low speeds.

If anyone knows a workaround for this bug, please let me know.

- Aleksander

01/22/07 07:15:05 changed by mrenzmann

@hbock:

when I'm directly under an access point at school (actually, there are 2 of them in close proximity) I only get 24%-ish signal

What is the exact signal quality output from iwconfig in such a situation?

@aleksabl-gmail:

...
Link Quality=27/94  Signal level=-65 dBm  Noise level=-95 dBm
...

The PC is located 3 meters away from the AP. I'm having problems with loss of connectivity and low speeds.

The iwconfig output you quote is made from the described position, 3m away from the AP? If so, that looks more like a physical problem, such as when the pigtail is not fixed properly to the antenna connector of the card.

01/28/07 03:33:39 changed by GlemSom

I can confirm the exact same problem using the latest snapshot of madwifi

02/07/07 00:24:51 changed by stinger1@30gigs.com

low signal with me too, atheros card in an acer travelmate 2420, im currently 2 metters from the router and get 38% signal in network manager, running ubuntu edgy

02/13/07 23:35:55 changed by Ron Dippold

For what it's worth, somewhere between r1497 and r1797 (yes I know that's a huge range) if you don't set the txpower explicitly the card(AR5213As here) now sends with much lower power.

Just swapping an old driver for new in the same hardware resulted in 10 dBm lower output on the spectrum analyzer (and much higher packet loss in a multi-node setup) - explicitly setting 'iwconfig wlan0 txpower XX' brought them back into line.

It sounds like there may be more going on here as well, but I thought I'd mention it.

02/14/07 06:32:54 changed by mrenzmann

@Ron: it would be great if you could narrow the mentioned huge range down a bit. Using something like "binary search" to select the revisions to use should bring you to the culprit revision quite fast.

02/25/07 20:27:22 changed by nathan.elshout@gmail.com

I can also confirm this problem with the AR5005G (AR2413) with madwifi-ng 0.9.2.1 and the 24-2-2007 snapshot using Gentoo, and so do some other people on Gentoo as well.

When sitting in line of sight of the AP it loses signal after not so long. When using WinXp? in the exact same spot the signal strength is excellent and not losing the connection.

I do have to say that when I set my router (D-Link DI-524) to operate 802.11g-only and set the TX-rate to 54 mb/s-only in the router the connection does not drop out anymore, but the signal remains weak according to NetworkManager, +/- 28% at 3m open space direct line of sight. At the same time however the Gnome Network Monitor reports 72%, so I guess the signal is relatively fine, but NetworkManager just reports a lower number due to the different calculation.

ath0      IEEE 802.11g  ESSID:"xxxx"  Nickname:""
          Mode:Managed  Frequency:2.437 GHz  Access Point: XX:XX:XX:XX:XX:XX   
          Bit Rate:54 Mb/s   Tx-Power:31 dBm   Sensitivity=0/3  
          Retry:off   RTS thr:off   Fragment thr:off
          Encryption key:xxxx-xxxx-xxxx-xxxx-xxxx-xxxx-xxxx-xxxx   Security mode:restricted
          Power Management:off
          Link Quality=27/94  Signal level=-67 dBm  Noise level=-94 dBm
          Rx invalid nwid:26928  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

My thinking is that it has something to do with switching modes. Since I'm not really into this stuff I don't know how to find out either.

(follow-up: ↓ 19 ) 02/25/07 21:24:10 changed by nathan.elshout@gmail.com

Sorry, a small addendum after some more observing:

If I select 802.11g + 54mb/s-only it still drops, but automatically reconnects. Without this (802.11b+g + any mb/s) it drops out and NetworkManager does not automatically reconnect, so the switching modes argument might be off the table.

(in reply to: ↑ 18 ) 03/16/07 11:28:01 changed by whstrain

I also have this problem when using networkmanager. I don't have the problem when using the default tool in edgy.

(follow-up: ↓ 21 ) 03/27/07 23:05:55 changed by mazor

Yes I too have that problem!! It never really happened in Dapper, but in Edgy, wireless Internet is continuously disconnecting and reconnecting. Signal strength right next to the Access point is only like 70%. Funny though the network connection monitor registers full signal strength, whereas on network manager it gives the more accurate half strengths.

Mazor

(in reply to: ↑ 20 ; follow-up: ↓ 22 ) 04/30/07 05:32:50 changed by gohalien@gmail.com

Same problem here, using TP-Link WN551G (Atheros 5211), 90% signal strengh in windows, 0%-15% in Ubuntu 6.06 LTS, I get an IP via DHCP OK, I ping Access Point (same one that gives me the IP address via DHCP) and if I am luck, from 100 packets, 1 reply. I am 10 meters away from access point. I am using latest MadWifi drivers.

(in reply to: ↑ 21 ) 04/30/07 13:39:20 changed by strasak@bubakov.net

Do ya also get rx invalid nwid as the poster above ? iwconfig ath0 will show you that ...

05/31/07 18:42:59 changed by nathan.elshout@gmail.com

My issue (disconnecting very often) was solved by switching to a Linksys WRT54G router, seems that the D-Link DI 524 router and this card don't go together very well.

The link quality remains quite low (50% at 3 meters open space) but it doesn't drop out and holds 54/48 mbps with constant reliable troughput.

06/01/07 21:07:00 changed by mentor

I have recently updated signal quality reporting on advice from elho (#1008). Please note that "signal quality" is an arbitary value defined by the vendor, and cannot necessarily be compared from one chipset to the next, never mind vendor.

Is the issue here that the signal quality is reported as "low"? If so, then I am inclined to close this ticket as "low" is arbitary.

If you are having problems with packet loss, or maintaing association, would you speak up?

06/05/07 06:02:30 changed by dangilikethat@gmail.com

Im going to vouch and say that with windows i see a huge boost in speed... I can download the same file about 10X faster.... Also i keep getting dropped from my network under ubuntu around every 5 minutes.

* Using festy with a trendnet 108 network card. Using drivers that came preinstalled with ubuntu (all updates have been made)

10/13/07 00:44:05 changed by anonymous

Same here with a 5213A chipset (see #1269)

(follow-up: ↓ 29 ) 11/25/07 18:35:39 changed by matteosistisette@gmail.com

Hi,

I have a D-Link DWL-G650 card which is Atheros AR-5212 or 5213 based.

I have tried various linux distributions (all live CD's booting out of the box) and I always get the same problem: I can connect but the connection is lost after a few minutes, or sometimes seconds. Even in the short intervals when I am connected, connection is slow and unreliable. All these distros I'm talking about include madwifi and correctly recognize my card as atheros AR5212/AR5213.

Pings do show a lot of packet loss.

Under Windows I can connect and surf and download and listen-to-internet-radios all day; under windows it reports a signal strength of 25%.

Note that most previous posts do mention connection losses, impossibility to connect and/or packet loss, so it is definitely NOT a problem of not liking the reported signal strength value. Don't close the ticket, it's a very real issue.

11/25/07 18:37:44 changed by anonymous

No fix or workaround after more than a year?

(in reply to: ↑ 27 ) 11/26/07 06:41:48 changed by mrenzmann

Replying to matteosistisette@gmail.com:

under windows it reports a signal strength of 25%.

I suppose this meant to say "Linux" rather than "Windows" here.

First of all, don't rely on percentages when looking at the signal strength of a WLAN link. The reason simply is that various drivers handle the signal strength fields provided by the wireless extensions of the kernel differently.

Look at the output of "iwconfig ath0" when you are associated with an AP, and show us the line that tells you something like this:

Link Quality=12/70  Signal level=-68 dBm  Noise level=-80 dBm

Then tell us about the distance between the client and the AP at the time when you grabbed the mentioned line.

07/07/08 22:45:01 changed by Arjen

Any news or workaround for this bug?

07/08/08 18:34:27 changed by mentor

  • summary changed from very low link quality using madwifi (current-ng) to Unspecified connection packet loss, dropping, etc. problems.

Would those having problems confirm that they have checked antenna diversity settings as per UserDocs/Troubleshooting?