Please note: This project is no longer active. The website is kept online for historic purposes only.
If you´re looking for a Linux driver for your Atheros WLAN device, you should continue here .

Ticket #510 (closed defect: duplicate)

Opened 16 years ago

Last modified 16 years ago

txpower issue ....

Reported by: pstaszewski@artcom.pl Assigned to: dyqith
Priority: major Milestone:
Component: madwifi: driver Version:
Keywords: Cc:
Patch is attached: 0 Pending:

Description (Last modified by mrenzmann)

Hello:

Access Point with : Sparklan WMIA-166AG

and when i try to set txpower to 17dbm

~ $ iwconfig ath0 txpower 17
~ $ iwconfig
eth0      no wireless extensions.

lo        no wireless extensions.

wifi0     no wireless extensions.

ath0      IEEE 802.11a  ESSID:"wdsik"
          Mode:Managed  Frequency:5.64 GHz  Access Point: 00:0E:8E:01:DD:B9
          Bit Rate=24 Mb/s   Tx-Power=16 dBm   Sensitivity=0/3
          Retry:off   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=35/94  Signal level=-60 dBm  Noise level=-95 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

br0       no wireless extensions.

~ $
~ $ iwlist ath0 tx
ath0      unknown transmit-power information.

          Current Tx-Power=16 dBm       (39 mW)

I have no change : card is always on 16dbm I can change txpower to lower value.

Module init:

modprobe ath_pci autocreate=none countrycode=616

max power on 5Ghz-5.8GHz in Poland is 1W in outdoor mode.

I want only 79mW :) from my card to do (802.11a) 8km link.

Change History

04/05/06 21:57:20 changed by dyqith

Can you please take a look at http://madwifi.org/ticket/508

make sure you bring the card up first before changing the txpower.

04/05/06 21:58:04 changed by dyqith

  • status changed from new to assigned.
  • owner set to dyqith.

04/06/06 07:13:46 changed by mrenzmann

  • description changed.

04/06/06 17:59:31 changed by pstaszewski@artcom.pl

Yes device is up when i down interface and do: iwconfig ath0 txpower 17

iwconfig shows: Bit Rate:24 Mb/s Tx-Power=17 dBm Sensitivity=0/3

but if i do ifconfig ath0 up iwconfig : Bit Rate:24 Mb/s Tx-Power=16 dBm Sensitivity=0/3

and if i do : ifconfig ath0 up iwconfig ath0 essid wdsik iwconfig ath0 rate 24M iwconfig ath0 txpower 17

iwconfig shows: Bit Rate:24 Mb/s Tx-Power=16 dBm Sensitivity=0/3

and : ifconfig ath0 up iwconfig ath0 essid wdsik rate 24M txpower 17 iwconfig shows: Bit Rate:24 Mb/s Tx-Power=16 dBm Sensitivity=0/3

Only when interface is down i can change txpower but when i up interface then txpower is changing to 16dbm

And another try with diff.. config:

cm9 card: mode 11b ifconfig ath0 up iwconfig ath0 essid test1 iwconfig ath0 txpower 19

iwconfig shows: Bit Rate:0 Mb/s Tx-Power=17 dBm Sensitivity=0/3

but when i change mode from 11b to 11g: cm9 card: mode 11g ifconfig ath0 up iwconfig ath0 essid test1 iwconfig ath0 txpower 19

iwconfig shows: Bit Rate:0 Mb/s Tx-Power=19 dBm Sensitivity=0/3

i try with wireless-tools v17 , v18 , v19 , v20 , v21 with the latest madwifi-ng And every time i have the same results:

04/06/06 18:17:14 changed by dyqith

Maybe your card only allows up to 16dBm ? Let me fix the patch in http://madwifi.org/ticket/508 and you can check to see whats the max you can set your card at.

--dyqith

04/07/06 03:55:41 changed by dyqith

Patch should be fixed, please go check it out whenever you're ready

04/07/06 20:42:27 changed by pstaszewski@artcom.pl

Where can i get this patch ??

04/07/06 20:46:27 changed by pstaszewski@artcom.pl

ok i have it .

04/20/06 05:34:41 changed by dyqith

Was this issue fixed with the latest revision ?

04/20/06 19:15:28 changed by pstaszewski@artcom.pl

Hmm

iwconfig ath0 channel 11 iwlist ath0 tx ath0 8 available transmit-powers :

0 dBm (1 mW) 5 dBm (3 mW) 7 dBm (5 mW) 9 dBm (7 mW) 11 dBm (12 mW) 13 dBm (19 mW) 15 dBm (31 mW) 17 dBm (50 mW) Current Tx-Power=17 dBm (50 mW)

iwconfig ath0 channel 10 iwlist ath0 tx ath0 8 available transmit-powers :

0 dBm (1 mW) 5 dBm (3 mW) 8 dBm (6 mW) 11 dBm (12 mW) 14 dBm (25 mW) 17 dBm (50 mW) 20 dBm (100 mW) 23 dBm (199 mW) Current Tx-Power=17 dBm (50 mW)

iwconfig ath0 channel 1 iwlist ath0 tx ath0 8 available transmit-powers :

0 dBm (1 mW) 5 dBm (3 mW) 7 dBm (5 mW) 9 dBm (7 mW) 11 dBm (12 mW) 13 dBm (19 mW) 15 dBm (31 mW) 17 dBm (50 mW) Current Tx-Power=17 dBm (50 mW)

When channel 1 and 11 are set then max txpower is 17dBm

When i set any countrycode then max txpower in 11b is 17dBm Without countrycode max txpower in range 2-10 channel is 23dBm

In mode 11g with countrycode set max txpower is 23dBm But in 11b mode max txpower with countrycode set is 17dBm

04/20/06 19:39:24 changed by dyqith

Which country code did you set to ?

when the txpower is up to 23dBm, can your card go that high ?

04/20/06 19:48:20 changed by pstaszewski@artcom.pl

Countrycodes i use for test: 276 Germany max txpower in 11g mode 23dBm in 11b 17dBm 616 Poland max txpower in 11g mode 23dBm in 11b 17dBm

And Yes when ath_pci is probed without countrycode then i can set 23dBm on card but when i use channel in range 2-10 .

In "channel 1" max txpower is 17dBm And in channel 11 max txpower ix 17dBm

04/20/06 19:57:35 changed by dyqith

I have no idea what to say, Maybe people at Atheros or the makers of the card know more.

sorry, i don't have a clue as to why its like that.

04/22/06 21:09:52 changed by dyqith

05/26/06 08:07:18 changed by dyqith

closing this ticket, since its a duplicate of ticket:531

05/26/06 08:08:05 changed by dyqith

  • status changed from assigned to closed.
  • resolution set to duplicate.