Please note: This project is no longer active. The website is kept online for historic purposes only.
If you´re looking for a Linux driver for your Atheros WLAN device, you should continue here .

Ticket #378 (closed defect: invalid)

Opened 13 years ago

Last modified 13 years ago

Kernel oops after mode setting with iwpriv

Reported by: red@meshnode.org Assigned to: dyqith
Priority: major Milestone: version 1.0.0 - first stable release
Component: madwifi: rate module 'sample' Version: trunk
Keywords: Cc:
Patch is attached: 0 Pending:

Description

I was playing arround in ad-hoc mode with 'iperf' to test the transmission rate with olsr and adhoc. Im using the latest svn (1444) and kernel 2.6.15. The wifi card is a sparklan atheros abg 5214 minipci card. I set the following options before the oops:

modprobe ath_pci
wlanconfig ath0 create wlandev wifi0 wlanmode adhoc
iwconfig ath0 essid speedtest channel 10
ifconfig ath0 192.168.0.25 up

After a while i have changed the mode with "iwpriv ath0 mode 11b". After i hit enter for this command the msg was displayed and i had enough time to copy it. I was not able to reproduce it.

The message can be found at http://nopaste.php-q.net/190528

Attachments

iwpriv-mode-oops.txt (2.1 kB) - added by mrenzmann on 02/09/06 06:32:11.
Attached the oops as file, just to make sure it isn't lost when that nopaste service cleans up

Change History

02/09/06 06:32:11 changed by mrenzmann

  • attachment iwpriv-mode-oops.txt added.

Attached the oops as file, just to make sure it isn't lost when that nopaste service cleans up

04/28/06 05:38:50 changed by dyqith

  • status changed from new to assigned.
  • owner set to dyqith.

05/26/06 08:40:43 changed by dyqith

Its been a long while, any updates with the latest releases ? If no reply comes by in a week, i'm going to close this ticket

09/07/06 19:12:19 changed by mrenzmann

  • status changed from assigned to closed.
  • resolution set to invalid.

No reply for several weeks now, closing the ticket. Feel free to reopen if the problem still exists.