Please note: This project is no longer active. The website is kept online for historic purposes only.
If you´re looking for a Linux driver for your Atheros WLAN device, you should continue here .

Ticket #354 (closed defect: duplicate)

Opened 14 years ago

Last modified 12 years ago

ath_attach: unable to attach hardware: 'Hardware didn't respond as expected' (HAL status 3)

Reported by: jtm-madwifi@smoothsmoothie.com Assigned to:
Priority: major Milestone:
Component: madwifi: HAL Version: trunk
Keywords: Cc:
Patch is attached: 0 Pending:

Description (Last modified by mrenzmann)

When I try to load the driver, I get this HAL status 3 error:

/ # insmod ath_hal
Using /lib/modules/2.6.12/net/ath_hal.ko
ath_hal: module license 'Proprietary' taints kernel.
ath_hal: 0.9.14.9 (AR5210, AR5211, AR5212, RF5111, RF5112, RF2413)
/ # insmod wlan
Using /lib/modules/2.6.12/net/wlan.ko
wlan: 0.8.6.0 (EXPERIMENTAL)
/ # insmod ath_rate_sample
Using /lib/modules/2.6.12/net/atath_rate_sample: 1.2
h_rate_sample.ko
/ # insmod ath_pci
Using /lib/modules/2.6.12/net/ath_pci.ko
ath_pci: 0.9.6.0 (EXPERIMENTAL)
PCI: Enabling device 0000:00:0c.0 (0000 -> 0002)
ath_attach: unable to attach hardware: 'Hardware didn't respond as expected'
(HAL status 3)

This is with 2.6.12 on a MIPS system. I'm using a version of the driver from CVS. If I use the exact same driver source on the exact same hardware but with a 2.4.24 kernel everything works fine.

This problem also happens with the madwifi-ng driver in SVN.

It looks like the error comes rom _ath_hal_attach()

I tried putting printk()s in ath_hal_read/write_reg() (and defined the AH_DEBUG macro so that that those functions exist) but the printk()s never get hit.

Change History

02/03/06 05:44:41 changed by mrenzmann

  • status changed from new to closed.
  • version set to madwifi-old.
  • resolution set to invalid.
  • description changed.

There is no sense in asking for help on two mailing lists and posting a ticket about the same issue at the same time. As mentioned in reply to one of your postings, the first thing to do get a current version of the sources, CVS isn't supported anymore.

Feel free to reopen the ticket once it's sure that your problem is caused by a bug in MadWifi.

02/08/06 04:05:02 changed by anonymous

  • status changed from closed to reopened.
  • version changed from madwifi-old to trunk.
  • resolution deleted.

I did try this with madwifi-ng with the same results - HAL status 3.

As for writing the bug and posting to the mailing list - I only created the bug after not getting a response on the mailing list after several days. Likewise, I'm reopening this since nobody replied to my updated post on the mailing list. I understand that there are more things to work on than time, and not every mailing list post gets answered. That's why I created the bug report - in case anyone in the future wishes to look into it.

I'd be happy to help solve this bug, but I can't even begin without knowing what that error means. If I can find out what causes that error code, I could look into this problem further.

02/08/06 04:05:57 changed by jtm-madwifi@smoothsmoothie.com

The previous comment was posted by me - I forgot to update the email address.

02/08/06 07:29:49 changed by mrenzmann

Which revision of madwifi-ng did you try?

02/08/06 14:25:44 changed by jtm-madwifi@smoothsmoothie.com

Rev 1416

02/08/06 17:22:00 changed by mrenzmann

Please retry with a more recent one, just to be sure.

02/09/06 14:24:07 changed by jtm-madwifi@smoothsmoothie.com

Rev 1446 - same problem: / # modprobe ath_pci Using /lib/modules/2.6.12-cadenux2/net/wlan.ko wlan: 0.8.4.2 (svn 1446) Using /lib/modules/2.6.12-cadenux2/net/ath_hal.ko ath_hal: module license 'Proprietary' taints kernel. ath_hal: 0.9.16.13 (AR5210, AR5211, AR5212, RF5111, RF5112, RF2413, RF5413, DFS) Using /lib/modules/2.6.12-cadenuath_rate_sample: 1.2 (svn 1446) x2/net/ath_rate_sample.ko Using /lib/modules/2.6.12-cadenux2/net/ath_pci.ko ath_pci: 0.9.4.5 (svn 1446) PCI: Enabling device 0000:00:0c.0 (0000 -> 0002) wifi%d: unable to attach hardware: 'Hardware didn't respond as expected' (HAL status 3) / #

02/09/06 14:27:03 changed by jtm-madwifi@smoothsmoothie.com

Reformatted comment:

Rev 1446 - same problem

/ # modprobe ath_pci
Using /lib/modules/2.6.12-cadenux2/net/wlan.ko
wlan: 0.8.4.2 (svn 1446)
Using /lib/modules/2.6.12-cadenux2/net/ath_hal.ko
ath_hal: module license 'Proprietary' taints kernel.
ath_hal: 0.9.16.13 (AR5210, AR5211, AR5212, RF5111, RF5112, RF2413, RF5413, DFS)
Using /lib/modules/2.6.12-cadenuath_rate_sample: 1.2 (svn 1446)
x2/net/ath_rate_sample.ko
Using /lib/modules/2.6.12-cadenux2/net/ath_pci.ko
ath_pci: 0.9.4.5 (svn 1446)
PCI: Enabling device 0000:00:0c.0 (0000 -> 0002)
wifi%d: unable to attach hardware: 'Hardware didn't respond as expected' (HAL status 3)
/ # 

04/01/06 11:48:32 changed by schorpp

if windos driver doesnt work too or windows xp hangs after some time until removing the device (if it is pcmcia) manually so it is hardware regression. pls try the device on a X86 with windows xp. since youre on mips i dont expect youre on a laptop.

interesting would be what causes the hw regression.

i suspect hal issues or hw quality. for hw regressions speaks that i have got this issue occured 2x and after switching of the machine after kernel crash. devices should tolerate that, if not, then it is a manfacturers problem. someone with contacts to card manufacturers should involve them.

in my case D-Link did warranty exchange 2x but refuses to let me talk with their design engineers.

regards. tom schorpp

05/16/06 03:58:49 changed by dyqith

Architecture more info there, if not, please add some, thanks.

05/16/06 09:39:29 changed by aschultz@warp10.net

This is an endianess issue, it can be worked arround with the 0.9.16.26 HAL by switching off the byteswapping in _OS_REG_WRITE() / _OS_REG_READ() in ah_osdep.h. The card will then be detected. However, this will result in the problem described in #574

11/08/06 10:45:01 changed by gorec AT netman DOT ru

Help me please i have similar trouble but under mips and ath_ahb: when i try'ed up interface ath1

root@(none):/# ifconfig ath1 up

i have hardware error:

<4>wifi1: unable to reset hardware: 'Hardware didn't respond as expected' (HAL status 3) (freq 2412 flags 0xa0)

what i do wrong? and what can i do now?

ar531x rev 0x00005742 firmware startup...
SDRAM TEST...PASSED



  WAP-D15   Boot Procedure                       V1.0
---------------------------------------------------------
  Start ..Boot.B14..

Atheros AR5001AP default version 3.0.0.43A


 1
 0

auto-booting...

Attached TCP/IP interface to ae0.
Attaching network interface lo0... done.
Loading... 1475144 + 1518752
Starting at 0x8016e040...

<4>CPU revision is: 00018009
<4>Primary instruction cache 16kB, physically tagged, 4-way, linesize 16 bytes.
<4>Primary data cache 16kB, 4-way, linesize 16 bytes.
<4>Linux version 2.4.32 (root@oleg-desktop) (gcc version 3.4.6 (OpenWrt-2.0)) #21 Срд Ноя 8 00:04:08 MSK 2006
<4>Determined physical RAM map:
<4> memory: 01000000 @ 00000000 (usable)
<4>Initial ramdisk at: 0x80199000 (1081344 bytes)
<4>On node 0 totalpages: 4096
<4>zone(0): 4096 pages.
<4>zone(1): 0 pages.
<4>zone(2): 0 pages.
<4>Kernel command line: console=ttyS0,9600
<4>Using 110.000 MHz high precision timer.
<4>Calibrating delay loop... 219.54 BogoMIPS
<6>Memory: 13256k/16384k available (1440k kernel code, 3128k reserved, 1144k data, 76k init, 0k highmem)
<6>Dentry cache hash table entries: 2048 (order: 2, 16384 bytes)
<6>Inode cache hash table entries: 1024 (order: 1, 8192 bytes)
<6>Mount cache hash table entries: 512 (order: 0, 4096 bytes)
<6>Buffer cache hash table entries: 1024 (order: 0, 4096 bytes)
<4>Page-cache hash table entries: 4096 (order: 2, 16384 bytes)
<4>Checking for 'wait' instruction...  available.
<4>POSIX conformance testing by UNIFIX
<6>Linux NET4.0 for Linux 2.4
<6>Based upon Swansea University Computer Society NET3.039
<4>Initializing RT netlink socket
<4>Starting kswapd
<6>devfs: v1.12c (20020818) Richard Gooch (rgooch@atnf.csiro.au)
<6>devfs: boot_options: 0x1
<5>JFFS2 version 2.1. (C) 2001 Red Hat, Inc., designed by Axis Communications AB.
<6>squashfs: version 3.0 (2006/03/15) Phillip Lougher
<4>pty: 256 Unix98 ptys configured
<6>Serial driver version 5.05c (2001-07-08) with no serial options enabled
<4>
<6>ttyS00 at 0xbc000003 (irq = 37) is a 16550A
<6>Software Watchdog Timer: 0.05, timer margin: 60 sec
<4>RAMDISK driver initialized: 16 RAM disks of 3072K size 1024 blocksize
<6>loop: loaded (max 8 devices)
<5>physmap flash device: 400000 at be000000
<5> Amd/Fujitsu Extended Query Table v1.0 at 0x0041
<4>Physically mapped flash: JEDEC Device ID is 0xC8. Assuming broken CFI table.
<4>Physically mapped flash: Swapping erase regions for broken CFI table.
<5>number of CFI chips: 1
<5>cfi_cmdset_0002: Disabling fast programming due to code brokenness.
<6>mtd: Giving out device 0 to Physically mapped flash
<5>No RedBoot partition table detected in Physically mapped flash
<6>Initializing Cryptographic API
<6>NET4: Linux TCP/IP 1.0 for NET4.0
<6>IP Protocols: ICMP, UDP, TCP
<6>IP: routing cache hash table of 512 buckets, 4Kbytes
<6>TCP: Hash tables configured (established 1024 bind 2048)
<6>NET4: Unix domain sockets 1.0/SMP for Linux NET4.0.
<6>NET4: Ethernet Bridge 008 for NET4.0
<6>802.1Q VLAN Support v1.8 Ben Greear <greearb@candelatech.com>
<6>All bugs added by David S. Miller <davem@redhat.com>
<5>RAMDISK: squashfs filesystem found at block 0
<5>RAMDISK: Loading 1055 blocks [1 disk] into ram disk...
|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/done.
<6>Freeing initrd memory: 1056k freed
<4>VFS: Mounted root (squashfs filesystem) readonly.
<6>Mounted devfs on /dev
<6>Freeing unused kernel memory: 76k freed

init started:  BusyBox v1.1.3 (2006.11.03-10:37+0000) multi-call binary
<4>Algorithmics/MIPS FPU Emulator v1.5

Please press Enter to activate this console. <6>wlan: 0.8.4.2 (svn)
<6>ath_hal: 0.9.18.0 (AR5212, AR5312, RF5111, RF5112, TX_DESC_SWAP)
<6>ath_rate_sample: 1.2 (svn)
<6>wlan: mac acl policy registered
<6>device eth0 entered promiscuous mode



BusyBox v1.1.3 (2006.11.03-10:37+0000) Built-in shell (ash)
Enter 'help' for a list of built-in commands.

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 KAMIKAZE (bleeding edge, r4888) -------------------
  * 10 oz Vodka       Shake well with ice and strain
  * 10 oz Triple sec  mixture into 10 shot glasses.
  * 10 oz lime juice  Salute!
 ---------------------------------------------------
root@(none):/# insmod ath_ahb
<6>ath_ahb: 0.9.4.5 (svn)
<4>wifi0: 11a rates: 6Mbps 9Mbps 12Mbps 18Mbps 24Mbps 36Mbps 48Mbps 54Mbps
<4>wifi0: 11b rates: 1Mbps 2Mbps 5.5Mbps 11Mbps
<4>wifi0: 11g rates: 1Mbps 2Mbps 5.5Mbps 11Mbps 6Mbps 9Mbps 12Mbps 18Mbps 24Mbps 36Mbps 48Mbps 54Mbps
<4>wifi0: turboA rates: 6Mbps 9Mbps 12Mbps 18Mbps 24Mbps 36Mbps 48Mbps 54Mbps
<4>wifi0: turboG rates: 6Mbps 12Mbps 18Mbps 24Mbps 36Mbps 48Mbps 54Mbps
<4>wifi0: H/W encryption support: WEP AES AES_CCM TKIP
<4>wifi0: mac 5.7 phy 4.2 radio 3.6
<4>wifi0: Use hw queue 1 for WME_AC_BE traffic
<4>wifi0: Use hw queue 0 for WME_AC_BK traffic
<4>wifi0: Use hw queue 2 for WME_AC_VI traffic
<4>wifi0: Use hw queue 3 for WME_AC_VO traffic
<4>wifi0: Use hw queue 8 for CAB traffic
<4>wifi0: Use hw queue 9 for beacons
<6>wifi0: Atheros 5312 WiSoC: mem=0xb8000000, irq=2
<4>wifi1: 11b rates: 1Mbps 2Mbps 5.5Mbps 11Mbps
<4>wifi1: 11g rates: 1Mbps 2Mbps 5.5Mbps 11Mbps 6Mbps 9Mbps 12Mbps 18Mbps 24Mbps 36Mbps 48Mbps 54Mbps
<4>wifi1: turboG rates: 6Mbps 12Mbps 18Mbps 24Mbps 36Mbps 48Mbps 54Mbps
<4>wifi1: H/W encryption support: WEP AES AES_CCM TKIP
<4>wifi1: mac 5.7 phy 4.2 radio 4.6
<4>wifi1: Use hw queue 1 for WME_AC_BE traffic
<4>wifi1: Use hw queue 0 for WME_AC_BK traffic
<4>wifi1: Use hw queue 2 for WME_AC_VI traffic
<4>wifi1: Use hw queue 3 for WME_AC_VO traffic
<4>wifi1: Use hw queue 8 for CAB traffic
<4>wifi1: Use hw queue 9 for beacons
<6>wifi1: Atheros 5312 WiSoC: mem=0xb8500000, irq=5
root@(none):/# iwconfig ath1
ath1      IEEE 802.11b  ESSID:""  
          Mode:Managed  Channel:0  Access Point: Not-Associated   
          Bit Rate:0 kb/s   Tx-Power:0 dBm   Sensitivity=0/3  
          Retry:off   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

root@(none):/# iwconfig ath1 channel 7 
root@(none):/# iwconfig ath1 essid tower_n
ath1      IEEE 802.11b  ESSID:"tower_n"  
          Mode:Managed  Frequency:2.442 GHz  Access Point: Not-Associated   
          Bit Rate:0 kb/s   Tx-Power:0 dBm   Sensitivity=0/3  
          Retry:off   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

root@(none):/#
root@(none):/# iwconfig ath1 rate 11M
root@(none):/# iwconfig ath1 
ath1      IEEE 802.11b  ESSID:"tower_n"  
          Mode:Managed  Frequency:2.442 GHz  Access Point: Not-Associated   
          Bit Rate=11 Mb/s   Tx-Power:0 dBm   Sensitivity=0/3  
          Retry:off   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

root@(none):/# ifconfig ath1 up
<4>wifi1: unable to reset hardware: 'Hardware didn't respond as expected' (HAL status 3) (freq 2412 flags 0xa0)
root@(none):/# ifconfig wifi1 up
<4>wifi1: unable to reset hardware: '' (HAL status 0) (freq 2412 flags 0xa0)
SIOCSIFFLAGS: Input/output error
root@(none):/# ifconfig wifi1
wifi1     Link encap:Ethernet  HWaddr 00:11:95:FF:F9:F5  
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:199 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:5 Memory:b8500000-b85ffffc 
root@(none):/# ifconfig ath1
ath1      Link encap:Ethernet  HWaddr 00:11:95:FF:F9:F5
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          
root@(none):/# wlanconfig ath1 list active
Channel   1 : 2412  Mhz 11g          Channel   7 : 2442  Mhz 11g
Channel   2 : 2417  Mhz 11g          Channel   8 : 2447  Mhz 11g
Channel   3 : 2422  Mhz 11g          Channel   9 : 2452  Mhz 11g
Channel   4 : 2427  Mhz 11g          Channel  10 : 2457  Mhz 11g
Channel   5 : 2432  Mhz 11g          Channel  11 : 2462  Mhz 11g
Channel   6 : 2437  Mhz 11g Dynamic
root@(none):/#

root@(none):/# tcpdump -i ath1
tcpdump: bind: Network is down
root@(none):/# ifconfig ath1 down
root@(none):/# wlanconfig ath1 destroy
root@(none):/# wlanconfig ath1 create wlandev wifi1 wlanmode monitor
ath1
root@(none):/# ifconfig ath1 up
<4>wifi1: unable to reset hardware: 'Hardware didn't respond as expected' (HAL s
tatus 3) (freq 2412 flags 0xa0)

root@(none):/# lsmod
Module                  Size  Used by
ath_ahb                87004   0
wlan_xauth               332   0 (unused)
wlan_wep                4252   0 (unused)
wlan_tkip              10684   0 (unused)
wlan_acl                2380   0 (unused)
ath_rate_sample        10424   0 [ath_ahb]
ath_hal               151072   2 [ath_ahb ath_rate_sample]
wlan_scan_sta           9404   0 (unused)
wlan_scan_ap            2732   0 (unused)
wlan                  176720   2 [ath_ahb wlan_xauth wlan_wep wlan_tkip wlan_acl ath_rate_sample wlan_scan_sta wlan_scan_ap]
root@(none):/# 

11/09/06 20:35:39 changed by anonymous

appendix formated:

# iwlist ath0 power
ath0      Supported modes :
                        o Receive all packets (unicast & multicast)
                        o Receive Unicast only (discard multicast)
                        o Receive Multicast only (discard unicast)
          Fixed period  ;  min period:1.024ms
                           max period:67.1078s
          Fixed timeout ;  min timeout:1.024ms
                           max timeout:1.024s
          Current mode:off

# iwlist ath0 txpower
ath0      unknown transmit-power information.

          Current Tx-Power:0 dBm        (1 mW)

11/10/06 06:30:48 changed by mrenzmann

Boy, is it that hard to press the preview button before you submit your comment? I had to delete the two comments before your last one, since my Firefox freaked out displaying this ticket.

10/11/07 22:42:20 changed by sh0ckfile@gmail.com

(sorry for bad english)

My AR5006EG didn't work after loading ath_pci :(

Laptop: Acer Aspire 5310. OS: OpenSuse 10.3 x86_64 Kernel: 2.6.22.5-31-default madwifi 0.9.3.99-36 x86_64 madwifi-kmp-default: 0.9.3.2_2.6.22.5_31-0.1 x86_64

dmesg:

ath_hal: 0.9.18.0 (AR5210, AR5211, AR5212, RF5111, RF5112, RF2413, RF5413)
wlan: 0.8.4.2 (0.9.3.2)
ath_pci: 0.9.4.5 (0.9.3.2)
ACPI: PCI Interrupt 0000:05:00.0[A] -> GSI 19 (level, low) -> IRQ 19
PCI: Setting latency timer of device 0000:05:00.0 to 64
wifi%d: unable to attach hardware: 'Hardware didn't respond as expected' (HAL status 3)
ACPI: PCI interrupt for device 0000:05:00.0 disabled

iwlist, ifconfig etc. doesn't show any wifi devices. /dev/ath0 isn't created.

Please help... T_T

10/12/07 02:23:38 changed by sh0ckfile@gmail.com

Sorry guys for my upper post... problem has "solved" - I have Atheros AR5BXB63 ("pseudo-AR5006EG"), which is not supported by madwifi. Trying to use ndiswrapper now.

Will support of this card be in the future? :-P

(follow-up: ↓ 20 ) 11/03/07 17:38:10 changed by woyzek

I have the same problem; how did you find out it is a AR5BXB63 instead of 5006EG ???

11/03/07 17:41:52 changed by anonymous

Maybe, supported chipsets depends on the HAL and thus madwifi developper can't make it working. So, wait for a new HAL release.

Note: posting forever for asking if a card/chipset is not really useful.

11/03/07 17:42:32 changed by anonymous

I meant that without the hal supporting a particular chipset, madwifi developper can't make a chipset working.

(in reply to: ↑ 17 ) 11/03/07 22:22:24 changed by anonymous

Replying to woyzek:

I have the same problem; how did you find out it is a AR5BXB63 instead of 5006EG ???

In the Vista this wifi-adapter identified as 5007, this "feature" is described in the HCL (/wiki/Compatibility/Atheros#AtherosAR5BXB63).

I started it with no problems with ndiswrapper.

11/04/07 09:40:37 changed by mrenzmann

  • status changed from reopened to closed.
  • resolution set to duplicate.

AR5BXB63 uses the not yet supported AR5007 chipset family, which is already addressed in #1192. Closing this ticket as duplicate.