Please note: This project is no longer active. The website is kept online for historic purposes only.
If you´re looking for a Linux driver for your Atheros WLAN device, you should continue here .

Ticket #352 (closed defect: worksforme)

Opened 13 years ago

Last modified 12 years ago

iwpriv mode fail under Monitor

Reported by: anonymous Assigned to: dyqith
Priority: major Milestone:
Component: madwifi: driver Version: trunk
Keywords: Cc:
Patch is attached: 0 Pending:

Description

trying to issue iwpriv ath0 mode 2 under Monitor mode will fail and cause atomic scheduling issue.

I found a temporary workaround by creating the device under STA mode, calling iwpriv ath0 mode 2, then destroying and re-create under monitor.

Change History

02/01/06 04:53:33 changed by mrenzmann

Please provide a dump of the kernel oops that is generated by this issue. DevDocs/KernelOops might be of help.

02/01/06 16:33:12 changed by anonymous

  • patch_attached changed.

Confirmed, the 802.11 protocol does not change under monitor.

04/28/06 05:38:41 changed by dyqith

  • status changed from new to assigned.
  • owner set to dyqith.

07/17/07 13:34:17 changed by mtaylor

  • status changed from assigned to closed.
  • resolution set to worksforme.

This ticket has not been updated in over twelve months and is being marked as "works for me" automatically.

If the ticket is still applies to the head revision of trunk, please re-open the ticket and provide any additional details needed and progress on the problem to date. Thanks.