Please note: This project is no longer active. The website is kept online for historic purposes only.
If you´re looking for a Linux driver for your Atheros WLAN device, you should continue here .

Ticket #318 (closed defect: fixed)

Opened 13 years ago

Last modified 12 years ago

r1401 oops ieee80211_scan_ap.c

Reported by: jason@skycon.net Assigned to: svens
Priority: major Milestone:
Component: madwifi: other Version: trunk
Keywords: Cc:
Patch is attached: 0 Pending:

Description (Last modified by mrenzmann)

Created an AP mode on ath0/wifi0
created a STA mode on ath1/wifi0
ath0 has 0 clients, ath1 is connected to orinoco outdoor router which is in AP mode.
The madwifi-ng based device is a WRAP board with dual ubiquiti SR2's.

I could swear I had it working one time, I wonder if it has to do with the order of the bridging even though it's not including ath0 or ath1

wrong opmode 1------------[ cut here ]------------
kernel BUG at /usr/src/madwifi-ng/net80211/ieee80211_scan_ap.c:282!
invalid operand: 0000 [#1]
Modules linked in: md5 ipv6 bridge wlan_scan_sta wlan_scan_ap ath_pci ath_rate_sample wlan ath_hal
CPU:    0
EIP:    0060:[<c880b7ac>]    Tainted: P      VLI
EFLAGS: 00010292   (2.6.14.3)
EIP is at ap_end+0x2bc/0x2d0 [wlan_scan_ap]
eax: 00000011   ebx: 00020002   ecx: c11629e0   edx: 00001b08
esi: c77cb800   edi: c7e72240   ebp: c1312000   esp: c02f7dd4
ds: 007b   es: 007b   ss: 0068
Process swapper (pid: 0, threadinfo=c02f6000 task=c02adba0)
Stack: c880b8fc 00000001 c79a9240 c7e72240 c79a9240 c7bfb00c 00000003 00000000
       c7bfb000 c7e72240 c7bfb924 00000924 c889b69d c7e72240 c7bfb000 c79a9240
       c7e72bc0 c79a945c c7e72bc0 c7e72240 c887577e 00000286 c887581f c7e72240
Call Trace:
 [<c889b69d>] ath_node_alloc+0x8d/0x110 [ath_pci]
 [<c887577e>] ieee80211_alloc_node+0x9e/0x1a0 [wlan]
 [<c887581f>] ieee80211_alloc_node+0x13f/0x1a0 [wlan]
 [<c8874969>] ieee80211_reset_bss+0x49/0x110 [wlan]
 [<c887e404>] ieee80211_check_scan+0x244/0x2a0 [wlan]
 [<c887d29e>] __ieee80211_newstate+0x2ee/0x730 [wlan]
 [<c887d829>] ieee80211_newstate+0x149/0x200 [wlan]
 [<c88a0792>] ath_newstate+0xf2/0x780 [ath_pci]
 [<c887ce80>] ieee80211_tx_timeout+0x0/0x80 [wlan]
 [<c887cf94>] ieee80211_new_state+0x24/0x40 [wlan]
 [<c887ceea>] ieee80211_tx_timeout+0x6a/0x80 [wlan]
 [<c011feab>] run_timer_softirq+0xbb/0x180
 [<c011c0df>] __do_softirq+0x4f/0xb0
 [<c011c175>] do_softirq+0x35/0x40
 [<c01052df>] do_IRQ+0x1f/0x30
 [<c0103e8a>] common_interrupt+0x1a/0x20
 [<c0101030>] default_idle+0x0/0x40
 [<c0101061>] default_idle+0x31/0x40
 [<c01010cc>] cpu_idle+0x1c/0x60
 [<c02f8792>] start_kernel+0x142/0x160
Code: c0 e9 5d fe ff ff 89 d0 e8 62 0b 91 f7 b8 01 00 00 00 e9 41 ff ff ff 89 fd 89 d8 e9 a1 fe ff ff 50 68 fc b8 80 c8 e8 04 c5 90 f7 <0f> 0b 1a 01 14 b9 80 c8 5b 5f e9 70 fd ff ff 90 8d 74 26 00 c3

Following is my /etc/network/interfaces The problem only happens when I uncomment auto ath0


# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

auto eth0
#auto ath0
auto ath1
auto ath10
auto br0

# This is a list of hotpluggable network interfaces.
# They will be activated automatically by the hotplug subsystem.
mapping hotplug
        script grep
        map eth0

iface eth0 inet manual
        post-up ifconfig eth0 0.0.0.0 up

iface ath0 inet manual
        wireless-essid out-skycon.net
        pre-up wlanconfig ath0 create wlandev wifi0 wlanmode ap
        post-up ifconfig ath0 0.0.0.0 up

iface ath1 inet manual
        wireless-essid NMO
        wireless-rts 64
        wireless-frag 384
        pre-up wlanconfig ath1 create wlandev wifi0 wlanmode sta nosbeacon
        post-up ifconfig ath1 0.0.0.0 up
        post-up sysctl -w net.ipv4.conf.ath1.proxy_arp=1

iface ath10 inet manual
        wireless-essid in-skycon.net
        wireless-rts 64
        wireless-frag 2048
        pre-up wlanconfig ath10 create wlandev wifi1 wlanmode ap
        post-up ifconfig ath10 0.0.0.0 up
        post-up iwpriv ath10 wds 1

iface br0 inet static
        address 64.186.37.59
        netmask 255.255.255.0
        pre-up brctl addbr br0
        post-up brctl addif br0 eth0
        post-up brctl addif br0 ath10
        post-up sysctl -w net.ipv4.conf.br0.proxy_arp=1
        post-up ip route add 64.186.37.120 dev br0
        post-up ip route add 64.186.37.36 dev br0
        post-up ip route change 64.186.37.0/24 dev ath1
        post-up ip route add default via 64.186.37.1

Change History

01/16/06 17:50:35 changed by mrenzmann

  • version set to trunk.
  • description changed.

01/19/06 17:29:50 changed by jason@skycon.net

It WAS working before, when I did it by hand. There was enough time for the scan to settle between ifupping devices.

Just a guess here, the problem is bringing up the VAP devs on the wifi dev consecutively too rapidly. If I ifconfig the sta dev, sleep a few seconds to allow the scan to settle then I can bring up AP devs w/o oopsing.

01/20/06 14:31:33 changed by jason@skycon.net

In case anyone else is having this problem here's how I've been doing it. wlanconfig create ath1 first as a station iwconfig it the way you need ifconfig it up wait or sleep a few seconds wlanconfig create ath0 iwconfig it ifconfig up

01/20/06 22:53:38 changed by svens

another workaround: create the STA VAP first, and set a channel with `iwconfig athX channel Y' on the AP VAP before bringing the AP VAP up.

03/22/06 22:15:47 changed by svens

  • status changed from new to assigned.
  • owner set to svens.
  • patch_attached changed.

03/22/06 22:16:20 changed by svens

  • status changed from assigned to closed.
  • resolution set to fixed.

03/22/06 22:16:37 changed by svens

Fixed as of r1482.