Please note: This project is no longer active. The website is kept online for historic purposes only.
If you´re looking for a Linux driver for your Atheros WLAN device, you should continue here .

Ticket #312 (closed enhancement: fixed)

Opened 13 years ago

Last modified 13 years ago

[patch] some fixes for wds opmode, fixed node leaking bug

Reported by: jirif Assigned to: mrenzmann
Priority: major Milestone: version 0.9.0 - move to new codebase
Component: madwifi: 802.11 stack Version: trunk
Keywords: Cc:
Patch is attached: 1 Pending:

Description

In order to use madwifi and wds opmode i found and fixed those bugs:

- kernel oops when defined wds peer send probe request. WDS do not need process managment frames, whish this fix provide
- discrad frames from undefined WDS peers (all frames was passed to upper layer from any wds peers)
- reworked wds_add/del, iwconfig and wlanconfig list now show corect informations about wds peer
- node leaking caused by ieee80211_init, when the init is caled in running state (some iwpriv need its). The fix provide full state restart when its needed. This problem is commomn for all opmodes.

Signed-off-by: Jiri Fojtasek <jiri.fojtasek@hlohovec.net>

Attachments

80211patch.diff (4.6 kB) - added by jirif on 01/14/06 13:34:09.
wdsstats.diff (0.9 kB) - added by jirif on 02/16/06 15:24:39.
fixed mode checking mistake

Change History

01/14/06 13:34:09 changed by jirif

  • attachment 80211patch.diff added.

01/15/06 10:29:24 changed by mrenzmann

  • status changed from new to assigned.
  • owner set to mrenzmann.
  • type changed from defect to enhancement.

Thanks for the patch. I'll commit it tomorrow with some minor changes to the in-source comments you've added.

02/01/06 06:42:33 changed by kelmo

  • patch_attached set to 1.

02/03/06 12:30:36 changed by mrenzmann

  • status changed from assigned to closed.
  • resolution set to fixed.

Sorry for the long day (which actually was worth 19 days)...

Patch committed in r1434. Thanks.

02/16/06 15:23:37 changed by jirif

  • status changed from closed to reopened.
  • resolution deleted.

The patch was applied incorectly ! wlanconfig list still NOT show corect informations about wds peer because the mode checking was MOVED in to function get_sta_space(). But it must remain also in the get_sta_info() function :)

I posting patch wdsstats.diff whish fixing this mistake.

Signed-off-by: Jiri Fojtasek <jiri.fojtasek@hlohovec.net>

02/16/06 15:24:39 changed by jirif

  • attachment wdsstats.diff added.

fixed mode checking mistake

02/16/06 16:05:57 changed by mrenzmann

  • status changed from reopened to closed.
  • resolution set to fixed.

Oops, sorry, that was my fault, I guess. Thanks for the heads-up. New patch applied in r1452.