Please note: This project is no longer active. The website is kept online for historic purposes only.
If you´re looking for a Linux driver for your Atheros WLAN device, you should continue here .

Ticket #279 (closed defect: noresponse)

Opened 14 years ago

Last modified 8 years ago

kernel oops at ath_rate_findrate with kernel 2.6.14.5

Reported by: com_gmail_at_dimitris Assigned to:
Priority: major Milestone:
Component: madwifi: other Version: trunk
Keywords: Cc: dimitris@gmail.com
Patch is attached: 0 Pending:

Description

I upgraded my kernel from 2.6.14.4 to .5, and at the same time upgraded madwifi-ng from [1352] to [1372] and may have upgraded the gcc version (big debian dist-upgrade, many packages upgraded). Note that I'm not using the Debian package for hostapd; I build it myself.

I am using two AP VAPs on this box. The APs' configuration is the same one described in #191.

I am using hostapd 0.4.7.

Since the upgrade, I've used ath0 quite a bit without any problems. However, as soon as I would try to pass some light traffic on ath1 (128kbps MP3 stream), hostapd started reporting that the station that's the destination of the stream (a Squeezebox v1 BTW) would keep deassociating with a very regular pattern:

Jan  2 21:01:38 greebo hostapd: ath1: STA 00:04:20:05:35:0f IEEE 802.11: associated
Jan  2 21:01:45 greebo hostapd: ath1: STA 00:04:20:05:35:0f IEEE 802.11: deassociated
Jan  2 21:01:48 greebo hostapd: ath1: STA 00:04:20:05:35:0f IEEE 802.11: associated
Jan  2 21:02:38 greebo hostapd: ath1: STA 00:04:20:05:35:0f IEEE 802.11: associated
Jan  2 21:02:45 greebo hostapd: ath1: STA 00:04:20:05:35:0f IEEE 802.11: deassociated
Jan  2 21:02:48 greebo hostapd: ath1: STA 00:04:20:05:35:0f IEEE 802.11: associated
Jan  2 21:03:38 greebo hostapd: ath1: STA 00:04:20:05:35:0f IEEE 802.11: associated
Jan  2 21:03:45 greebo hostapd: ath1: STA 00:04:20:05:35:0f IEEE 802.11: deassociated
Jan  2 21:03:48 greebo hostapd: ath1: STA 00:04:20:05:35:0f IEEE 802.11: associated
Jan  2 21:04:18 greebo hostapd: ath1: STA 00:04:20:05:35:0f IEEE 802.11: deassociated
Jan  2 21:04:18 greebo hostapd: ath1: STA 00:04:20:05:35:0f IEEE 802.11: associated
Jan  2 21:04:25 greebo hostapd: ath1: STA 00:04:20:05:35:0f IEEE 802.11: deassociated
Jan  2 21:04:28 greebo hostapd: ath1: STA 00:04:20:05:35:0f IEEE 802.11: associated
Jan  2 21:04:35 greebo hostapd: ath1: STA 00:04:20:05:35:0f IEEE 802.11: deassociated
Jan  2 21:04:38 greebo hostapd: ath1: STA 00:04:20:05:35:0f IEEE 802.11: associated
Jan  2 21:04:55 greebo hostapd: ath1: STA 00:04:20:05:35:0f IEEE 802.11: deassociated
Jan  2 21:04:58 greebo hostapd: ath1: STA 00:04:20:05:35:0f IEEE 802.11: associated
Jan  2 21:05:15 greebo hostapd: ath1: STA 00:04:20:05:35:0f IEEE 802.11: deassociated
Jan  2 21:05:18 greebo hostapd: ath1: STA 00:04:20:05:35:0f IEEE 802.11: associated
Jan  2 21:05:25 greebo hostapd: ath1: STA 00:04:20:05:35:0f IEEE 802.11: deassociated

etc

Eventually the machine died with a kernel crash. It wasn't captured in the logs but I got a good photo of the console which I'll attach here.

This same setup has worked almost flawlessly with 2.6.14.3 and .4 and [1352] so I reverted to that version, but keeping the 2.6.14.5 kernel. The same behavior continued in the log, so I didn't keep that going very long so no crash with that combo.

Then I recompiled hostapd 0.4.7 (in case of compiler upgrade, see above) and rebooted, to ensure the startup scripts run with the "right" sequence for wlanconfig, hostapd etc. I saw the same behavior yet again.

Then I changed the hostapd config for ath1 to bump up the debug, to see if that might yield something useful. I restarted hostapd and now, as Mr Murphy would have it, I can't see the problem any more.

I'll still go ahead and report this though in case something useful can be extracted from the crash dump.

Attachments

madwifi_crash.jpg (272.7 kB) - added by anonymous on 01/03/06 07:52:35.
photo of console after crash, showing stack trace etc
greebo-config (38.3 kB) - added by dimitris on 01/06/06 20:51:49.
kernel config

Change History

01/03/06 07:49:22 changed by anonymous

  • cc set to dimitris@gmail.com.

01/03/06 07:52:35 changed by anonymous

  • attachment madwifi_crash.jpg added.

photo of console after crash, showing stack trace etc

01/03/06 08:22:56 changed by anonymous

  • summary changed from kernel oops at ath_rate with kernel 2.6.14.5 to kernel oops at ath_rate_findrate with kernel 2.6.14.5.

01/03/06 14:15:38 changed by mrenzmann

  • version set to trunk.

01/05/06 18:04:59 changed by anonymous

#287 looks like it may be related to this.

01/06/06 20:50:07 changed by anonymous

FWIW, I just got the same crash/stack with 2.6.15.

01/06/06 20:51:49 changed by dimitris

  • attachment greebo-config added.

kernel config

01/07/06 00:12:50 changed by anonymous

Forgot to mention: With 2.6.15 I'm using madwifi-ng [1390].

04/21/06 19:12:38 changed by dyqith

  • patch_attached changed.

Please check with latest revision if this issue has been fixed.

01/19/07 23:19:52 changed by proski

The problem is likely related to #162. In both cases ath_rate_findrate() is involved.

06/01/07 17:06:29 changed by mentor

  • status changed from new to closed.
  • resolution set to noresponse.