Please note: This project is no longer active. The website is kept online for historic purposes only.
If you´re looking for a Linux driver for your Atheros WLAN device, you should continue here .

Ticket #258 (closed task: fixed)

Opened 14 years ago

Last modified 12 years ago

Incorporate update from Sam

Reported by: mrenzmann Assigned to: mrenzmann
Priority: major Milestone: version 0.9.x - progressive release candidate phase
Component: madwifi: other Version: trunk
Keywords: Cc:
Patch is attached: 1 Pending:

Description

As pointed out by Lorant Kurthy, Sam provides some updates (new HAL plus several code changes):

The changes include:

  • updates for the sample rate control algorithm (from madwifi)
  • use a private taskq thread
  • improved sta mode beacon miss handling
  • mcast frames sent at fixed rate (settable with ifconfig)
  • adhoc mode beacon timer fixups
  • packet capture now includes tsf and calibrated signal data
  • dfs wait-for-clear-channel handling (for ap mode)

Import these changes step by step, starting with the new HAL.

Attachments

madwifi-ng_sample-rate.patch (1.8 kB) - added by Stijn Tintel <stijn@linux-ipv6.be> on 01/05/06 07:49:57.
This patch contains two minor updates to the sample rate algorithm from http://people.freebsd.org/~sam/ath.patch

Change History

12/28/05 18:29:18 changed by mrenzmann

HAL v0.9.16.13 has been committed in r1367.

12/29/05 17:33:33 changed by mrenzmann

01/05/06 07:47:53 changed by Stijn Tintel <stijn@linux-ipv6.be>

It seems that the changes to the rate algorithms from http://people.freebsd.org/~sam/ath.patch are already in MadWifi-NG. The only differences I could find are in the sample algorithm, where MadWifi-NG uses jiffies VS ticks in Sam's patch, and two other minor changes. I'm attaching a patch for the latter. Can anyone confirm if this patch is necessary?

01/05/06 07:49:57 changed by Stijn Tintel <stijn@linux-ipv6.be>

  • attachment madwifi-ng_sample-rate.patch added.

This patch contains two minor updates to the sample rate algorithm from http://people.freebsd.org/~sam/ath.patch

01/05/06 11:48:25 changed by mrenzmann

No idea if these changes are necessary. But I found an issue by looking at your patch (which is not caused by your patch, but already in the source).

Have a look at this line: the KASSERT checks if rt is NULL. But rt is already dereferenced before that check here. That should be fixed, I think. Probably it would be a good idea to review the code for similar issues while we are at it.

01/07/06 09:01:59 changed by Stijn Tintel <stijn@linux-ipv6.be>

After checking the code in ath_rate/sample/sample.c again, I don't think these changes are necessary. With the changes, it is not possible anymore to disable multi-rate retry in the sample rate algorithm by changing

#define ENABLE_MRR 1

in ath_rate/sample/sample.c to

#define ENABLE_MRR 0

So it could either be left as it is now, or all references to ENABLE_MRR could be removed.

02/01/06 11:33:34 changed by kelmo

  • patch_attached set to 1.

02/03/06 11:42:26 changed by mrenzmann

@Stijnt: I agree, the patch you've added isn't needed IMO.

04/20/06 14:35:20 changed by kelmo

  • milestone changed from version 0.9.0 - move to new codebase to version 0.9.x - progressive release candidate phase.

So is there anything more required from this ticket? jbicket has been applying patches from Sam recently, so we must be kinda up to date in this regard, I would think.

05/16/06 04:54:48 changed by dyqith

  • status changed from new to closed.
  • resolution set to fixed.

closing ticket, i think everything needed was applied, feel free to reopen if i'm wrong.