Please note: This project is no longer active. The website is kept online for historic purposes only.
If you´re looking for a Linux driver for your Atheros WLAN device, you should continue here .

Ticket #2479 (new defect)

Opened 3 years ago

Last modified 3 years ago

Madwifi does not compile because of ndo_set_multicast_list

Reported by: blueboar_2@rambler.ru Assigned to:
Priority: minor Milestone:
Component: madwifi: other Version:
Keywords: Cc:
Patch is attached: 0 Pending: 0

Description (Last modified by mrenzmann)

I tried to install madwifi-ng, but it fails when compiling with error, something like "error: unknown field ‘ndo_set_multicast_list’".

It looks like the compilation error is because in kernel commit b81693d9149c598302e8eb9c20cb20330d922c8e the callback ndo_set_multicast_list was removed.

So i've changed all occurences of ndo_set_multicast_list in sources (there are three of them) to ndo_set_rx_mode and all worked fine.

There is a similar bug in another wireless program (if you need it) - and it does not compile for same reason

Reproducible: Always

Steps to Reproduce:

  1. Install kernel 3.2.1-r2
  2. Try to install madwifi-ng

Actual Results: Does not compile because field ndo_set_multicast_list not found

Change History

01/30/12 13:07:18 changed by mrenzmann

  • description changed.

02/12/12 16:57:05 changed by blueboar2

http : / / madwifi-project . org / changeset / 4176

The problem has been solved three months ago, i simply had old version of madwifi. I think, ticked can be closed.