Please note: This project is no longer active. The website is kept online for historic purposes only.
If you´re looking for a Linux driver for your Atheros WLAN device, you should continue here .

Ticket #2392 (new enhancement)

Opened 12 years ago

Last modified 12 years ago

Wistron DCMA-82 (AR5413) isn't recognized

Reported by: priority@marwe.net Assigned to:
Priority: minor Milestone:
Component: madwifi: driver Version: v0.9.4
Keywords: Wistron DCMA-82 mini-pci Cc:
Patch is attached: 0 Pending: 0

Description

I have 2 WLAN Cards, one 3Com PCI Card that works fine with the latest 0.9.4-r4119 and a Wistron DCMA-82 mini-pci that works not. Both cards have the AR5413.

In the latest madwifi-trunk the Wistron DCMA-82 is recognized, but the WLAN reconnects every minute. The 3Com PCI card has the same Problem with the trunk version (I will make an extra ticket for the problem with the trunk version).

Is it possible to add the Wistron DCMA-82 mini-pci to the 0.9.4 version?

Here is the lspci output for the Wistron DCMA-82:

00:0c.0 Ethernet controller: Atheros Communications Inc. AR5413 802.11abg NIC (rev 01)

Subsystem: Wistron NeWeb? Corp. DCMA-82 High Power WLAN 802.11a/b/g mini-PCI Module (Super A/G, eXtended Range, 400mW) Flags: medium devsel, IRQ 9 Memory at e00c0000 (32-bit, non-prefetchable) [size=64K] Capabilities: [44] Power Management version 2

Change History

03/22/10 17:57:25 changed by priority@marwe.net

Here are the pci ids for the Wistron DCMA-82:

00:0c.0 0200: 168c:001b (rev 01)

03/22/10 18:17:36 changed by priority@marwe.net

It seems there are wrong informations in lspci.

lspci reports the card as dcma-82, but the label on the card says it is a dcma-81.

At the Wistron Page i found both types:

h++p://www.wneweb.com/Networking/more/DCMA-81.htm <- this is my card h++p://www.wneweb.com/Networking/more/DCMA-82.htm <- this is NOT my card

Any ideas whats wrong?