Please note: This project is no longer active. The website is kept online for historic purposes only.
If you´re looking for a Linux driver for your Atheros WLAN device, you should continue here .

Ticket #2391 (new enhancement)

Opened 5 years ago

Last modified 3 years ago

[patch] Add support for ar9285 to ath_hal

Reported by: nickleiten@gmail.com Assigned to:
Priority: minor Milestone:
Component: madwifi: HAL Version: trunk
Keywords: Cc: nleiten
Patch is attached: 1 Pending: 0

Description

This patch adds support for ar9285 (maybe for ar9280 too). It was ported from FreeBSD ath_hal, so now it just make possible to use 802.11abg without 802.11n. I have encountered sme issues with ad-hoc mode, but can't say it's about patch. STA-mode works fine.

Attachments

madwifi-4122-ar9285.patch (194.3 kB) - added by nickleiten@gmail.com on 03/16/10 23:32:23.
patch for trunk-4122
madwifi-4122-ar9285-ani.patch (1.5 kB) - added by nickleiten@gmail.com on 03/17/10 17:41:19.
ANI support for ar9285
madwifi-4174-ar9285.patch (218.9 kB) - added by nickleiten@gmail.com on 11/18/11 14:08:36.
patch update for trunk-4174

Change History

03/16/10 23:32:23 changed by nickleiten@gmail.com

  • attachment madwifi-4122-ar9285.patch added.

patch for trunk-4122

03/16/10 23:41:25 changed by nickleiten@gmail.com

madwifi-4122-ar9285.patch

Signed-off By: N.Leiten aka Gamov Vadim <nickleiten@gmail.com>

03/17/10 17:41:19 changed by nickleiten@gmail.com

  • attachment madwifi-4122-ar9285-ani.patch added.

ANI support for ar9285

03/21/10 22:15:30 changed by nickleiten@gmail.com

All modes works fine, just needed to reboot system. It was famous SBP, I'm trying to solve it in several ways, so maybe new patch will arrive soon.

04/10/10 23:54:22 changed by ultiva

Works well with AR9285 on Sony Vaio VPC-EB1S1E (compiled on Ubuntu 9.10 32bit) (where ath9k and diswrapper + xp driver 7.7.0 worked with many issues like frequently interrupted transfer). Transfering file over LAN looks stable at about 2.8 MB/s. There are some problems but I cannot say if there are serious

1. dmesg reports lots of these: wifi0: ath_fatal_tasklet: Hardware error; resetting. 2. signal quality jumps frequently 3. link speed reported by iwconfig ath0 look weird - it drops down to 6MB/s and jumps up to 54MB/s very frequently 4. TXpower cannot be set above 14dBm, while on ath9k it is set to 20dBm.

These issues seems to have no impact at wireless speed. Done several tests with file transfer over LAN and it looks pretty stable. Also under WIN7 wifi works without problems.

(follow-up: ↓ 5 ) 04/11/10 23:08:26 changed by nickleiten@gmail.com

It seems to be some driver problem. you may try to not use ANI patch, it is just for testing. If problem occurs i'll try to do some fixes. For now i'm challenging problem with stuck beacons. I think your problem get same solve.

(in reply to: ↑ 4 ; follow-up: ↓ 6 ) 04/12/10 00:15:59 changed by ultiva

Thank you very much for your response ! I've done some research. I tried to disable device reset function call in procedure ath_fatal_tasklet. After this my card seems to lock-up occasionally just like with ath9k but not resumes on its own. I'll try to recompile driver without ANI patch and wait for your updated patches.

Regards Piotr Sikorski

(in reply to: ↑ 5 ) 04/20/10 16:12:48 changed by ultiva

Just want to let you know that on Ubuntu 10.04 (2.6.32-21-generic) there are no ath_fatal_tasklet errors in dmesg. After some tuning (intmit, rts=100) my wifi is quite usable. This madwifi driver still is not perfect but far better than ath9k in my case.

Regards

06/18/10 21:19:30 changed by Satarsa

It doesn't compile with trunk 4128 :(

06/18/10 22:24:10 changed by Satarsa

Sorry, it was my mistake. It works! Thank you!

(follow-up: ↓ 10 ) 07/02/10 00:01:08 changed by mauricio

"In case you use kernel 2.6.25 or newer, you need to get this snapshot of the madwifi-0.9.4 branch instead of the v0.9.4 release! That snapshot is basically v0.9.4 plus compilation fixes for recent kernels."

This patch doesn't work with the refered snapshot, right? Is there a way to make it work together?

I hope so :(

Thank's in advance.

(in reply to: ↑ 9 ) 08/31/10 17:41:09 changed by proski

Replying to mauricio: There is no way to support AR9285 or any new hardware in the madwifi-0.9.4 branch since it has a non-free HAL that cannot be patched.

07/20/11 22:53:40 changed by anonymous

So how do I actually install the madwifi that support the AR9285? Where can I download the version that was patched?

11/11/11 15:13:38 changed by anonymous

Just download 4122 and patch it! Get the kernel patches in gentoo distfiles (net-wireless/madwifi-ng).

11/18/11 14:08:36 changed by nickleiten@gmail.com

  • attachment madwifi-4174-ar9285.patch added.

patch update for trunk-4174