Please note: This project is no longer active. The website is kept online for historic purposes only.
If you´re looking for a Linux driver for your Atheros WLAN device, you should continue here .

Ticket #2376 (new defect)

Opened 12 years ago

PPPoE session through bridge with Fast Frame Enabled on WiFi Links

Reported by: isacco.fontana@trentinonetwork.it Assigned to:
Priority: minor Milestone:
Component: madwifi: other Version:
Keywords: Cc:
Patch is attached: 0 Pending: 0

Description

Hi, we're using atheros minipci 52x card with mad wifi drivers. We're using bridge to transport L2 frames. But we're seeing PPPoE session doesn't stay up and disconnect every 20-30 second with FastFrame? enabled.

I we disable Fast Frame the PPPoE work correctly. Do you known why ? Do is related to frame errors (see attached) ?

Follow the version of hosiapd and wpa_supplicant:

root@bellatrl:~# wpa_supplicant -v wpa_supplicant v0.5.11 Copyright (c) 2003-2008, Jouni Malinen <j@w1.fi> and contributors root@bellatrl:~# hostapd -v hostapd v0.5.11 User space daemon for IEEE 802.11 AP management, IEEE 802.1X/WPA/WPA2/EAP/RADIUS Authenticator Copyright (c) 2002-2008, Jouni Malinen <j@w1.fi> and contributors root@bellatrl:~#

root@bellatrl:~# ifconfig wifi0 wifi0 Link encap:UNSPEC HWaddr 00-17-63-02-0A-E6-00-00-00-00-00-00-00-00-00-00

UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1 RX packets:4860079 errors:737478 dropped:0 overruns:0 frame:737403 TX packets:11129855 errors:12 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:240 RX bytes:1351575215 (1.2 GiB) TX bytes:3874968914 (3.6 GiB) Interrupt:28

root@predatrl:~# ifconfig wifi0 wifi0 Link encap:UNSPEC HWaddr 00-17-63-02-0D-22-00-00-00-00-00-00-00-00-00-00

UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1 RX packets:14633632 errors:7690674 dropped:0 overruns:0 frame:7690674 TX packets:3369313 errors:3 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:240 RX bytes:3450276053 (3.2 GiB) TX bytes:1257982680 (1.1 GiB) Interrupt:28

AND CONF

modprobe ath_hal modprobe wlan modprobe ath_pci autocreate=none product=204 modprobe wlan_acl modprobe wlan_ccmp modprobe wlan_tkip modprobe wlan_wep modprobe wlan_xauth modprobe wlan_scan_ap modprobe wlan_scan_sta modprobe aes setpci -d *:* latency_timer=A0 athctrl -i wifi0 -d 6000 -s Setting distance on interface wifi0 to 6000 meters echo 1 >/proc/sys/dev/wifi0/ackrate echo 0 >/proc/sys/dev/wifi0/diversity echo 1 >/proc/sys/dev/wifi0/txantenna echo 1 >/proc/sys/dev/wifi0/rxantenna athctrl -i wifi1 -d 10000 -s Setting distance on interface wifi1 to 10000 meters echo 1 >/proc/sys/dev/wifi1/ackrate echo 0 >/proc/sys/dev/wifi1/diversity echo 1 >/proc/sys/dev/wifi1/txantenna echo 1 >/proc/sys/dev/wifi1/rxantenna wlanconfig ath0 create wlandev wifi0 wlanmode ap bssid ath0 iwpriv ath0 mode 1 ifconfig ixp0 0.0.0.0 hw ether 00:17:63:01:0E:8D txqueuelen 1024 mtu 2290 ifconfig ixp1 0.0.0.0 hw ether 00:17:63:01:0E:8E txqueuelen 1024 mtu 1500 iwpriv ath0 hostroaming 2 iwconfig ath0 essid WiNET-TR5G103 channel 108 iwpriv ath0 bintval 100 iwconfig ath0 rate 54M auto iwconfig ath0 rate 6M broadcast iwconfig ath0 rts off iwconfig ath0 frag off iwpriv ath0 xr 0 iwpriv ath0 ff 0 iwpriv ath0 wds 1 iwpriv ath0 maxtry 13 iwpriv ath0 wmm 0 iwpriv ath0 bgscan 0 iwpriv ath0 ap_bridge 1 ifconfig ath0 0.0.0.0 txqueuelen 1024 mtu 2290 iwconfig ath0 txpower 18 fixed modprobe switch echo +br0 > /sys/class/switch/masters echo 30000 > /sys/class/net/br0/switch/ageing_time echo 0 > /sys/class/net/br0/switch/stp_enabled echo "+ixp0" > /sys/class/net/br0/switch/slaves echo 128 > /sys/class/net/ixp0/swport/priority echo 1 > /sys/class/net/ixp0/swport/stp_enabled echo 0 > /sys/class/net/ixp0/swport/carrier_reenable_delay echo 1 > /sys/class/net/ixp0/swport/carrier_extended_reenable_delay echo 0 > /sys/class/net/ixp0/swport/carrier_extended_changes echo "+ath1" > /sys/class/net/br0/switch/slaves +ath1 echo 128 > /sys/class/net/ath1/swport/priority echo 1 > /sys/class/net/ath1/swport/stp_enabled echo 0 > /sys/class/net/ath1/swport/carrier_reenable_delay echo 1 > /sys/class/net/ath1/swport/carrier_extended_reenable_delay echo 0 > /sys/class/net/ath1/swport/carrier_extended_changes echo "+ath0" > /sys/class/net/br0/switch/slaves echo 128 > /sys/class/net/ath0/swport/priority echo 1 > /sys/class/net/ath0/swport/stp_enabled echo 0 > /sys/class/net/ath0/swport/carrier_reenable_delay echo 1 > /sys/class/net/ath0/swport/carrier_extended_reenable_delay echo 0 > /sys/class/net/ath0/swport/carrier_extended_changes echo 0 > /sys/class/net/ath0/swport/carrier_check_enabled echo 0 > /sys/class/net/ixp0/swport/vlan_id echo > /sys/class/net/ixp0/swport/vlan_port echo 0 > /sys/class/net/ath1/swport/vlan_id echo > /sys/class/net/ath1/swport/vlan_port echo 0 > /sys/class/net/ath0/swport/vlan_id echo > /sys/class/net/ath0/swport/vlan_port ifconfig br0 10.25.47.13 netmask 255.255.255.0 txqueuelen 1024 mtu 2290 arp up route add default gw 10.25.47.1 metric 0 hostapd -B /var/etc/hostapd.ath0.conf

root@predatrl:~# more /var/etc/hostapd.ath0.conf interface=ath0 driver=madwifi logger_syslog=-1 logger_syslog_level=2 logger_stdout=-1 logger_stdout_level=2 debug=0 dump_file=/tmp/hostapd.ath0.dump ssid=WiNET-TR5G103 ap_max_inactivity=60 eap_server=0 wpa=2 wpa_passphrase=ess07-yroe63dgen53 wpa_group_rekey=600 wpa_gmk_rekey=86400 wpa_strict_rekey=0 rsn_preauth=0 rsn_preauth_interfaces= wpa_key_mgmt=WPA-PSK wpa_pairwise=CCMP

Thanks Isacco