Please note: This project is no longer active. The website is kept online for historic purposes only.
If you´re looking for a Linux driver for your Atheros WLAN device, you should continue here .

Ticket #2352 (new defect)

Opened 12 years ago

Last modified 12 years ago

2.6.31 + madwifi 0.9.4.409x no connects

Reported by: spawels13@gmail.com Assigned to:
Priority: minor Milestone:
Component: madwifi: driver Version: trunk
Keywords: no connection 2.6.31 trunk Cc:
Patch is attached: 0 Pending: 0

Description

Hello,

After upgrade to kernel 2.6.31.x and madwifi 0.9.4.4096 (from Arch Linux repository) and the latest trunk version 0.9.4.4099-20090929 I can no longer connect to network. Card is working, but iwlist 'ath0 scan' shows less results then previous and it doesn't show the network I always connect to, which has the highest signal strange... I tried to use ath 5k, but results are similar or even worse. I connect using PPPoE. Log shows something like this:

Bad one (2.6.31.3, madwifi 0.9.4.4096):

pppd[3082] Plugin rp-pppoe.so loaded. pppd[3082] RP-PPPoE plugin version 3.3 compiled against pppd 2.4.4 pppd[3096] pppd 2.4.4 started by root, uid 0 pppd[3096] Timeout waiting for PADO packets pppd[3096] Timeout waiting for PADO packets pppd[3096] Timeout waiting for PADO packets pppd[3096] Timeout waiting for PADO packets

Good one (2.6.30.6, madwifi 0.9.4.3952):

pppd[3085] Plugin rp-pppoe.so loaded. pppd[3085] RP-PPPoE plugin version 3.3 compiled against pppd 2.4.4 pppd[3099] pppd 2.4.4 started by root, uid 0 pppd[3099] PPP session is 87 pppd[3099] Using interface ppp0 pppd[3099] Connect: ppp0 <--> ath0 pppd[3099] CHAP authentication succeeded

Ethernet controller: Atheros Communications Inc. AR2413 802.11bg NIC (rev 01)

Change History

10/09/09 19:21:05 changed by spawels13@gmail.com

delete this one please, duplicate due to mistake → 2351