Please note: This project is no longer active. The website is kept online for historic purposes only.
If you´re looking for a Linux driver for your Atheros WLAN device, you should continue here .

Ticket #2230 (new defect)

Opened 13 years ago

Last modified 13 years ago

softled = 1 causes packet loss on AR5005G/2413

Reported by: wbreyha@gmx.net Assigned to:
Priority: minor Milestone:
Component: madwifi: driver Version: trunk
Keywords: packet loss, softled, ledpin, no connection Cc:
Patch is attached: 0 Pending: 0

Description

Hi!

I recently updated my soekris net4801 from openwrt kamikaze 7.xx to 8.09rc1 with 2.6.25.17 kernel and new madwifi drivers. After doing that my WLAN was visible but nearly not accessible. WPA handshake and DHCP failed often cause of 70-90% packetloss.

My soekris has a

00:0e.0 168c:001a Ethernet controller: Atheros Communications, Inc. AR5005G 802.11abg NIC (rev 01)

card with one antenna. Kernel detects

ath_pci: wifi0: Atheros 2413: mem=0xa0010000, irq=11

I tried everything I found with google. Setting stuff in /proc/sys (diversity, tx/rxantenna) or with iwpriv (protmode, ..). I tried several versions of madwifi: 0.9.4, svn3314, svn3902, svn3917, 0.10.5.6 .... no difference. Only booting the old image helped instantly.

Today... don't know why... as a last try... i did a

echo "0" >/proc/sys/dev/wifi0/softled

and surprise, surprise ... packetloss is gone and all my laptops connect with stable 54MBit.

Currently I'm using madwifi-hal-testing-r3917-20090116... but I'm pretty sure it makes no difference which revision I'll try.

ledpin = 0 by default

I tried to set ledpin=1 and softled=1 and it still works. So, the only combination causing troubles here is the default softled=1, ledpin=0.

Maybe some other tickets with packetloss reports have the same cause.

Looking at the source it is clear that it's not even madwifi's fault. It's openwrt's fault setting softled=1 by default in /lib/wifi/madwifi.sh.

But maybe the driver can prevent configurations leading to packetloss caused by wrong softled/ledpin settings?

Regards, Wolfgang Breyha

Change History

02/19/09 15:25:04 changed by me@davidjmemmett.co.uk

I can confirm that the setting

softled=1, ledpin=0

causes me to lose wireless connectivity, also to note that i've not tried to change the value of ledpin from the default 0 yet.

I dont get any leds lighting up, does this require ledpin to be 1?