Please note: This project is no longer active. The website is kept online for historic purposes only.
If you´re looking for a Linux driver for your Atheros WLAN device, you should continue here .

Ticket #2211 (new defect)

Opened 13 years ago

Broadcast frames lost at the sender?

Reported by: bugs@qult.net Assigned to:
Priority: minor Milestone:
Component: madwifi: driver Version: trunk
Keywords: packet loss, broadcast Cc:
Patch is attached: 0 Pending: 0

Description

Unlike the 0.9.4 branch, the latest SVN revisions of trunk (r3878) exhibit a rather annoying bug: a process sending broadcast UDP packets in a burst do not get blocked and some (most?) packet obviously don't make it to the radio medium.

I tried first with a customized iperf (to enable it to send broacast UDP) and then with a custom code altogether. The measured throughput does not even come close to a plausible figure (around 90 MB/s), whereas with the 0.9.4 branch it clearly reflects the actual throughput (around 100-200 KB/s).

For information, the driver outputs the following about my hardware :

wifi0: Atheros AR5424 chip found (MAC 10.3, PHY SChip 6.1, Radio 10.2)

I tried with different kernel versions, 2.6.27.8 among others.