Please note: This project is no longer active. The website is kept online for historic purposes only.
If you´re looking for a Linux driver for your Atheros WLAN device, you should continue here .

Ticket #2199 (closed defect: fixed)

Opened 6 years ago

Last modified 3 years ago

MadWifi release 0.9.4 does not compile against kernel 2.6.27.9

Reported by: anonymous Assigned to:
Priority: minor Milestone:
Component: madwifi: other Version: v0.9.4
Keywords: Fujitsu Siemens Esprimo Mobile V5505 M52216 - Kubuntu8.10-desktop_amd64 - make error line 240: ./net80211/ieee80211_power.c (implicit declaration of function '__skb_append') Cc:
Patch is attached: 0 Pending: 0

Description (Last modified by mrenzmann)

Hardware: Fujitsu Siemens Esprimo Mobile V5505 (lspci: eth = Realtek, wlan = Atheros 242x, i think Atheros AR5007EG but wlan doesn't exist in iwconfig... only eth and lo)

Operative System: Kubuntu8.10_desktop-amd64

i have downloaded from here madwifi-0.9.4, i have execute the two scripts as in newbie-howto:

cd scripts
sudo ./madwifi-unload
sudo ./find-madwifi-modules.sh $(uname -r)
# i have choose r to remove all modules
cd ..

after that i have execute sudo make:

federica@federica-laptop:~/madwifi/madwifi-0.9.4$ sudo make
Checking requirements... ok.                               
Checking kernel configuration... ok.                       
make -C /lib/modules/2.6.27-9-generic/build SUBDIRS=/home/federica/madwifi/madwifi-0.9.4 modules                                                                
make[1]: Entering directory `/usr/src/linux-headers-2.6.27-9-generic'           
  CC [M]  /home/federica/madwifi/madwifi-0.9.4/ath/if_ath.o
  CC [M]  /home/federica/madwifi/madwifi-0.9.4/ath/if_ath_pci.o
  LD [M]  /home/federica/madwifi/madwifi-0.9.4/ath/ath_pci.o
  CC [M]  /home/federica/madwifi/madwifi-0.9.4/ath_hal/ah_os.o
  HOSTCC  /home/federica/madwifi/madwifi-0.9.4/ath_hal/uudecode
  UUDECODE /home/federica/madwifi/madwifi-0.9.4/ath_hal/x86_64-elf.hal.o
  LD [M]  /home/federica/madwifi/madwifi-0.9.4/ath_hal/ath_hal.o
  CC [M]  /home/federica/madwifi/madwifi-0.9.4/ath_rate/amrr/amrr.o
  LD [M]  /home/federica/madwifi/madwifi-0.9.4/ath_rate/amrr/ath_rate_amrr.o
  CC [M]  /home/federica/madwifi/madwifi-0.9.4/ath_rate/minstrel/minstrel.o
  LD [M]  /home/federica/madwifi/madwifi-0.9.4/ath_rate/minstrel/ath_rate_minstrel.o
  CC [M]  /home/federica/madwifi/madwifi-0.9.4/ath_rate/onoe/onoe.o
  LD [M]  /home/federica/madwifi/madwifi-0.9.4/ath_rate/onoe/ath_rate_onoe.o
  CC [M]  /home/federica/madwifi/madwifi-0.9.4/ath_rate/sample/sample.o
  LD [M]  /home/federica/madwifi/madwifi-0.9.4/ath_rate/sample/ath_rate_sample.o
  CC [M]  /home/federica/madwifi/madwifi-0.9.4/net80211/if_media.o
  CC [M]  /home/federica/madwifi/madwifi-0.9.4/net80211/ieee80211.o
  CC [M]  /home/federica/madwifi/madwifi-0.9.4/net80211/ieee80211_beacon.o
  CC [M]  /home/federica/madwifi/madwifi-0.9.4/net80211/ieee80211_crypto.o
  CC [M]  /home/federica/madwifi/madwifi-0.9.4/net80211/ieee80211_crypto_none.o
  CC [M]  /home/federica/madwifi/madwifi-0.9.4/net80211/ieee80211_input.o
  CC [M]  /home/federica/madwifi/madwifi-0.9.4/net80211/ieee80211_node.o
  CC [M]  /home/federica/madwifi/madwifi-0.9.4/net80211/ieee80211_output.o
  CC [M]  /home/federica/madwifi/madwifi-0.9.4/net80211/ieee80211_power.o
/home/federica/madwifi/madwifi-0.9.4/net80211/ieee80211_power.c: In function 'ieee80211_pwrsave':
/home/federica/madwifi/madwifi-0.9.4/net80211/ieee80211_power.c:240: error: implicit declaration of function '__skb_append'
make[3]: *** [/home/federica/madwifi/madwifi-0.9.4/net80211/ieee80211_power.o] Error 1
make[2]: *** [/home/federica/madwifi/madwifi-0.9.4/net80211] Error 2
make[1]: *** [_module_/home/federica/madwifi/madwifi-0.9.4] Error 2
make[1]: Leaving directory `/usr/src/linux-headers-2.6.27-9-generic'
make: *** [modules] Error 2
federica@federica-laptop:~/madwifi/madwifi-0.9.4$

Change History

12/06/08 18:19:39 changed by anonymous

i have just see an error as this in ticket #2189 it says: MadWifi v0.9.4 was released way before kernel 2.6.27 was available. This is a known issue, and a fix for this compilation problem is available in the madwifi-0.9.4 branch.

12/06/08 18:50:57 changed by anonymous

i have try it but now give:

federica@federica-laptop:~/downloads/madwifi-branch-0.9.4$ sudo make  
[sudo] password for federica:                                         
Checking requirements... ok.                                          
Checking kernel configuration... ok.                                  
make -C /lib/modules/2.6.27-9-generic/build SUBDIRS=/home/federica/downloads/madwifi-branch-0.9.4 modules                                                       
make[1]: Entering directory `/usr/src/linux-headers-2.6.27-9-generic'           
  CC [M]  /home/federica/downloads/madwifi-branch-0.9.4/ath/if_ath.o            

...

  CC [M]  /home/federica/downloads/madwifi-branch-0.9.4/net80211/ieee80211_wireless.o
  CC [M]  /home/federica/downloads/madwifi-branch-0.9.4/net80211/ieee80211_linux.o
cc1: warnings being treated as errors
/home/federica/downloads/madwifi-branch-0.9.4/net80211/ieee80211_linux.c: In function 'ieee80211_load_module':
/home/federica/downloads/madwifi-branch-0.9.4/net80211/ieee80211_linux.c:338: error: format not a string literal and no format arguments
make[3]: *** [/home/federica/downloads/madwifi-branch-0.9.4/net80211/ieee80211_linux.o] Error 1
make[2]: *** [/home/federica/downloads/madwifi-branch-0.9.4/net80211] Error 2
make[1]: *** [_module_/home/federica/downloads/madwifi-branch-0.9.4] Error 2
make[1]: Leaving directory `/usr/src/linux-headers-2.6.27-9-generic'
make: *** [modules] Error 2
federica@federica-laptop:~/downloads/madwifi-branch-0.9.4$

12/08/08 06:18:18 changed by mrenzmann

  • description changed.
  • summary changed from error make: net80211/ieee80211_power.c - implicit declaration of function skb_append to MadWifi release 0.9.4 does not compile against kernel 2.6.27.9.

(in reply to: ↑ description ) 12/09/08 17:00:00 changed by anonymous

i tried:

  1. get the latest "trunk": svn co "http: //svn.madwifi-project.org/madwifi/trunk madwifi
  2. make clean, make, sudo make install... it seems to be ok.

12/11/08 17:19:00 changed by proski

  • status changed from new to closed.
  • resolution set to fixed.

The issue is fixed in 0.9.4 branch.

(follow-up: ↓ 7 ) 12/17/08 20:06:01 changed by Luca

Hi all...i used the svn versione and i have the same problem:

luca@ubuntu:/usr/src/madwifi$ make
cd: 1: can't cd to /lib/modules/2.6.27-9-generic/build
Makefile.inc:66: *** /lib/modules/2.6.27-9-generic/build is missing, please set KERNELPATH.  Stop.

What can i do?

(in reply to: ↑ 6 ) 12/18/08 06:34:37 changed by mrenzmann

Replying to Luca:

Hi all...i used the svn versione and i have the same problem:

That's a different issue than what this ticket dealt with. Yours is that most probably don't have the source for the kernel installed for which you want to build MadWifi. It's no bug in the driver and thus off-topic for the bug tracker. If you need help to fix this, please contact our regular support channels. Thanks.