Please note: This project is no longer active. The website is kept online for historic purposes only.
If you´re looking for a Linux driver for your Atheros WLAN device, you should continue here .

Ticket #2189 (closed defect: fixed)

Opened 6 years ago

Last modified 5 years ago

can't make madwifi

Reported by: anonymous Assigned to:
Priority: major Milestone:
Component: madwifi: driver Version:
Keywords: Cc:
Patch is attached: 0 Pending: 0

Description (Last modified by mrenzmann)

Every time I try to make madwifi, I get the following error:

user@10110:~/Desktop/madwifi-0.9.4$ sudo make
Checking requirements... ok.
Checking kernel configuration... ok.
make -C /lib/modules/2.6.27-7-generic/build SUBDIRS=/home/user/Desktop/madwifi-0.9.4 modules
make[1]: Entering directory `/usr/src/linux-headers-2.6.27-7-generic'
  CC [M]  /home/user/Desktop/madwifi-0.9.4/net80211/ieee80211_power.o
/home/user/Desktop/madwifi-0.9.4/net80211/ieee80211_power.c: In function 'ieee80211_pwrsave':
/home/user/Desktop/madwifi-0.9.4/net80211/ieee80211_power.c:240: error: implicit declaration of function '__skb_append'
make[3]: *** [/home/user/Desktop/madwifi-0.9.4/net80211/ieee80211_power.o] Error 1
make[2]: *** [/home/user/Desktop/madwifi-0.9.4/net80211] Error 2
make[1]: *** [_module_/home/user/Desktop/madwifi-0.9.4] Error 2
make[1]: Leaving directory `/usr/src/linux-headers-2.6.27-7-generic'
make: *** [modules] Error 2

Change History

11/18/08 06:06:16 changed by mrenzmann

  • priority changed from blocker to major.
  • description changed.
  • reporter changed from anonymous@anonymous.com to anonymous.

MadWifi v0.9.4 was released way before kernel 2.6.27 was available. This is a known issue, and a fix for this compilation problem is available in the madwifi-0.9.4 branch. Get a copy of it like this:

svn co http://svn.madwifi-project.org/madwifi/branches/madwifi-0.9.4 madwifi-branch-0.9.4

and compile that against your kernel.

11/24/08 17:51:48 changed by anonymous

No joy for me. I loaded subversion, got the branch, went to scripts and removed everything.

After make I get /home/yak/Desktop/madwifi-branch-0.9.4/net80211/ieee80211_linux.c: In function 'ieee80211_load_module': /home/yak/Desktop/madwifi-branch-0.9.4/net80211/ieee80211_linux.c:338: error: format not a string literal and no format arguments make[3]: *** /home/yak/Desktop/madwifi-branch-0.9.4/net80211/ieee80211_linux.o Error 1 make[2]: *** /home/yak/Desktop/madwifi-branch-0.9.4/net80211 Error 2 make[1]: *** [_module_/home/yak/Desktop/madwifi-branch-0.9.4] Error 2 make[1]: Leaving directory `/usr/src/linux-headers-2.6.27-7-generic' make: *** [modules] Error 2

11/24/08 18:38:26 changed by anonymous

Same error here :(

11/30/08 02:26:48 changed by anonymous

Same here:

madwifi-branch-0.9.4/net80211/ieee80211_linux.c:338: error: format not a string literal and no format arguments

etc. etc.

On an Acer Aspire One...

11/30/08 07:39:27 changed by anonymous

building against 2.6.27.7 works fine for me with madwifi-0.9.4 trunk pulled at 2008-11-30 @ 12:30AM CDT

12/05/08 08:35:58 changed by anonymous

building agains 2.6.27.9 gives the same error: format not a string literal and no format arguments

12/06/08 20:15:19 changed by anonymous

Good job guys, way to commit garbage! Looks like amateur night. Please make sure it compiles

(in reply to: ↑ description ) 12/09/08 16:47:21 changed by anonymous

Hi, i using kernel 2.6.27-10, i downlaoded svn.madwifi-project.org/madwifi/branches/madwifi-0.9.4 madwifi-branch-0.9.4,

make:

......
cc1: warnings being treated as errors
/home/sobi/Desktop/madwifi-branch-0.9.4/net80211/ieee80211_linux.c: In function 'ieee80211_load_module':
/home/sobi/Desktop/madwifi-branch-0.9.4/net80211/ieee80211_linux.c:338: error: format not a string literal and no format arguments
make[3]: *** [/home/sobi/Desktop/madwifi-branch-0.9.4/net80211/ieee80211_linux.o] Error1
make[2]: *** [/home/sobi/Desktop/madwifi-branch-0.9.4/net80211] Error 2
make[1]: *** [_module_/home/sobi/Desktop/madwifi-branch-0.9.4] Error 2
make[1]: Leaving directory `/usr/src/linux-headers-2.6.27-10-generic'
make: *** [modules] Error 2

pls any idea how to solve this ? thx

12/11/08 17:20:04 changed by proski

  • status changed from new to closed.
  • resolution set to fixed.

Fixed in 0.9.4 branch in r3880.

(follow-up: ↓ 11 ) 12/12/08 14:02:12 changed by Valeria

and the solution is ? =( i have the same problem

(in reply to: ↑ 10 ; follow-up: ↓ 12 ) 12/12/08 14:05:29 changed by mrenzmann

Replying to Valeria:

and the solution is ? =( i have the same problem

The solution is to use a snapshot of the branch than contains the fix. If you need help with this, please contact our support, as such discussions are not suited for our bug tracker.

(in reply to: ↑ 11 ) 01/04/09 04:38:09 changed by anonymous

Replying to mrenzmann:

Replying to Valeria:

and the solution is ? =( i have the same problem

The solution is to use a snapshot of the branch than contains the fix. If you need help with this, please contact our support, as such discussions are not suited for our bug tracker.

Have anyone else confirmed this will work beside the dev team? I can't seem to get the r3880 changes to compile either. I manually made the changes to the 2 files myself following the changeset code changes. I have a freshly installed ubuntu 8.10 desktop i386.

01/06/09 03:21:56 changed by proski

You are not specific. What are the errors? What changes did you make? In which files? The ticket mentions a compile error in ieee80211_power.c and further comments refer to a compile error in ieee80211_linux.c. If you want to discuss some other compile problem, please open a new ticket. This is not a place to discuss all compile errors.

(follow-up: ↓ 15 ) 05/09/09 11:26:24 changed by anonymous

those are facing as below shown error .

        ser@10110:~/Desktop/madwifi-0.9.4$ sudo make
Checking requirements... ok.
Checking kernel configuration... ok.
make -C /lib/modules/2.6.27-7-generic/build SUBDIRS=/home/user/Desktop/madwifi-0.9.4 modules
make[1]: Entering directory `/usr/src/linux-headers-2.6.27-7-generic'
  CC [M]  /home/user/Desktop/madwifi-0.9.4/net80211/ieee80211_power.o
/home/user/Desktop/madwifi-0.9.4/net80211/ieee80211_power.c: In function 'ieee80211_pwrsave':
/home/user/Desktop/madwifi-0.9.4/net80211/ieee80211_power.c:240: error: implicit declaration of function '__skb_append'
make[3]: *** [/home/user/Desktop/madwifi-0.9.4/net80211/ieee80211_power.o] Error 1
make[2]: *** [/home/user/Desktop/madwifi-0.9.4/net80211] Error 2
make[1]: *** [_module_/home/user/Desktop/madwifi-0.9.4] Error 2
make[1]: Leaving directory `/usr/src/linux-headers-2.6.27-7-generic'
make: *** [modules] Error 2

Please add below mentioned in the respecitve dir of madwifi downloading them from branch folder of madwifi.

             ieee80211_power.c
             ieee80211_power.h
             ieee80211_linux.c
             ieee80211_linux.h
             ieee80211_wireless.c

Because after adding above mentioned files, madwifi compiled properly and installed the modules on linux version 2.6.27-7.

(in reply to: ↑ 14 ) 05/10/09 20:49:10 changed by mrenzmann

Replying to anonymous:

Please add below mentioned in the respecitve dir of madwifi downloading them from branch folder of madwifi.

Better get a full checkout of the madwifi-0.9.4 branch of MadWifi, rather than replacing just a few files.