Please note: This project is no longer active. The website is kept online for historic purposes only.
If you´re looking for a Linux driver for your Atheros WLAN device, you should continue here .

Ticket #2170 (new defect)

Opened 13 years ago

Last modified 13 years ago

AR5212 not working with Ubuntu 8.10 and Mandriva 2008 on R512 Thinkpad

Reported by: anonymous Assigned to:
Priority: minor Milestone:
Component: madwifi: other Version:
Keywords: Cc:
Patch is attached: 0 Pending: 0

Description (Last modified by mrenzmann)

I've reported this with every major distro release in the past 2 years: Here is a list of Distros I have tried where Madwifi with the latest driver for that period does not work.

  • Mandriva 2008
  • Mandriva 2008.1
  • Mandriva 2009
  • Fedora 8
  • Fedora 9
  • OpenSuse 11
  • Ubuntu 8.04
  • Kubuntu 8.04
  • Ubuntu 8.10

And todays candidate Ubuntu 8.10 fresh off the press. Same issue here, drops out after about 10 minutes of use.

I'm still using the old Mandriva 2007.1 (2.6.17-13) madwifi-0.9.2-1mdv2007.0 and it's never had a problem there.

See my other tickets:

#2026

#1951

Sorry about opening a new ticket each time but this has been going on for more than 2 years now.

Attachments

ar5212-lutz.txt (3.0 kB) - added by Eduardo Lutz <edlutz@gmail.com> on 01/15/09 15:17:45.
Comparing dmesg and lspci on Ubuntu 8.10 with Ubuntu 8.04 for AR5212

Change History

(follow-up: ↓ 2 ) 01/14/09 15:35:40 changed by Eduardo Lutz <edlutz@gmail.com>

Still not working on Ubuntu 8.10 for Encore ENLWI-SG (AR5212). No device (athX or wlanX) is created or bound to the card. lspci identifies the device as AR5001X+.

(in reply to: ↑ 1 ) 01/15/09 07:22:07 changed by mrenzmann

Replying to Eduardo Lutz <edlutz@gmail.com>:

Still not working on Ubuntu 8.10 for Encore ENLWI-SG (AR5212). No device (athX or wlanX) is created or bound to the card. lspci identifies the device as AR5001X+.

Check dmesg output for any message when MadWifi gets loaded.

(follow-up: ↓ 4 ) 01/15/09 07:22:53 changed by mrenzmann

  • description changed.

01/15/09 15:17:45 changed by Eduardo Lutz <edlutz@gmail.com>

  • attachment ar5212-lutz.txt added.

Comparing dmesg and lspci on Ubuntu 8.10 with Ubuntu 8.04 for AR5212

(in reply to: ↑ 3 ) 01/15/09 15:28:40 changed by Eduardo Lutz <edlutz@gmail.com>

Replying to mrenzmann:

I attached a file (ar5212-lutz.txt) with the relevant results from dmesg and lspci -vv for Ubuntu 8.10 (where the driver fails) and Ubuntu 8.04 (running on another computer) with the same board model (Encore ENLWI-SG). The older driver works without problems on Ubuntu 8.04.

Thanks.