Please note: This project is no longer active. The website is kept online for historic purposes only.
If you´re looking for a Linux driver for your Atheros WLAN device, you should continue here .

Ticket #2107 (new defect)

Opened 13 years ago

Packet flow stops on monitor mode, when fixed rate

Reported by: lsiudut@gmail.com Assigned to:
Priority: minor Milestone:
Component: madwifi: driver Version: v0.9.4
Keywords: monitor rate Cc:
Patch is attached: 0 Pending: 0

Description

When i run my card in monitor mode, and set fixed rate, packet flow stops and won't run again, or even my system hangs (depends on rate). Tested with airodump and simple tcpdump. I'm using iwconfig to configure devices.

wlanconfig  mon1 create wlandev wifi0 wlanmode monitor[[BR]]
iwconfig mon1 rate 1M[[BR]]
iwconfig mon1 rate 54M


First iwconfig command cause flow-stop problem, second hangs my system. I did't try another rates. When i set 1M rate, no messages occurs.

System info.
NEC Aterm WL54AG card, base on AR5212 controller:

03:00.0 Ethernet controller: Atheros Communications, Inc. AR5212 802.11abg NIC (rev 01)


Dmesg after module loaded:

AR5210, AR5211, AR5212, AR5416, RF5111, RF5112, RF2413, RF5413, RF2133)[[BR]]
ACPI: PCI Interrupt 0000:03:00.0[A] -> GSI 18 (level, low) -> IRQ 18[[BR]]
MadWifi: ath_attach: Switching rfkill capability off.[[BR]]
wifi0: Atheros AR5213 chip found (MAC 5.6, PHY 2112 4.1, Radio 3.6)[[BR]]
ath_pci: wifi0: Atheros 5212: mem=0xc4000000, irq=18


Linux version:

Linux lucks 2.6.26-gentoo-r1-lucks #2 SMP Thu Aug 28 09:42:42 CEST 2008 x86_64 GNU/Linux


Same problem with subversion drivers (rev 3853).