Please note: This project is no longer active. The website is kept online for historic purposes only.
If you´re looking for a Linux driver for your Atheros WLAN device, you should continue here .

Ticket #2066 (closed defect: fixed)

Opened 11 years ago

Last modified 11 years ago

iwconfig athX channel X, fail?

Reported by: burkbai@163.com Assigned to:
Priority: major Milestone: version 0.9.5
Component: madwifi: driver Version: v0.9.4
Keywords: Cc:
Patch is attached: 0 Pending:

Description (Last modified by mrenzmann)

I want scan all the channel with an atheros card, I set the card in the monitor mode

wlanconfig athX destroy
wlanconfig athX create wlandev wifi0 wlanmode monitor

then in the program, scan all the channel

for (i = 1;i <14;i++)
iwconfig athX channel i

but the card can't channge to every channel, there is allways one channel can't be set(it is random ), why?

I have try madwifi 0.9.3 and 0.9.4 , and change three cards, all fail.

My OS is Ubuntu 7.0.4.

When I use the rt73 driver and the ralink card ,there is no problem.

Change History

(follow-up: ↓ 3 ) 07/21/08 16:38:48 changed by mrenzmann

  • description changed.

What is the exact error message you get?

07/21/08 16:44:57 changed by mrenzmann

  • reporter changed from anonymous to burkbai@163.com.

(in reply to: ↑ 1 ; follow-up: ↓ 4 ) 07/21/08 17:45:32 changed by anonymous

Replying to mrenzmann:

What is the exact error message you get?

there is no error message, for example, use the command "$iwconfig athX channel 6" then "$iwconfig" the freq is set to 2.437. then "$iwconfig athX channel 7" and "iwconfig" , the freq is still 2.437, there is not error output.

I also use the iotcl() function to channge the channel, fail too.

If destroy the athX , and create it again, it work fine at first. But after channging the channel three times or more, it fail again.

My card is tplink 651G (atheros chip)made in china, what card do you use?

(in reply to: ↑ 3 ) 07/22/08 07:10:16 changed by mrenzmann

Replying to anonymous:

there is no error message,

Checked dmesg, too?

I also use the iotcl() function to channge the channel, fail too.

If it fails, there should be some error returned. If no error returned, the ioctl succeeded, but does not behave as expected - that's a difference. You should make use of the debugging functionality of MadWifi then.

07/22/08 12:54:17 changed by anonymous

The ioctl return succeeded, but the channel is not the one which I set. I try the Netgear G311 card, it fail too. I think it is a bug in the driver. I will try the debugg in Madwifi later.

07/24/08 04:39:18 changed by anonymous

OK, I download the newest madwifi from svn, it works fine. thank you.

07/24/08 06:38:11 changed by mrenzmann

So you confirm that the issue is fixed in trunk?

07/24/08 08:43:34 changed by anonymous

Yes, the madwifi 0.9.4 and 0.9.3 fail, but trunk succeed.

(follow-up: ↓ 10 ) 07/24/08 13:02:25 changed by mrenzmann

  • status changed from new to closed.
  • resolution set to fixed.
  • milestone set to version 0.9.5.

Thanks for the feedback.

(in reply to: ↑ 9 ) 11/03/08 16:44:12 changed by leehom_tan

yes, I met the same problem. The driver seems that can't be set on the specific channel after scanning all the channels.

I use Federo Core 9 and WG511T Netgear card.