Please note: This project is no longer active. The website is kept online for historic purposes only.
If you´re looking for a Linux driver for your Atheros WLAN device, you should continue here .

Ticket #2058 (new defect)

Opened 13 years ago

Last modified 13 years ago

Full system hang on creation of ap-mode VAP

Reported by: pavlina.chris@gmail.com Assigned to:
Priority: major Milestone:
Component: madwifi: other Version: v0.9.4
Keywords: Cc:
Patch is attached: 0 Pending:

Description

(I will attach lspci etc later; I don't have access to the system right now.)

On an Intel Mac Mini that I am trying to convert to an AP/router/server, the system invariably, completely hangs (no SysRq?, no nothing) on the command:

wlanconfig ath0 create wlandev wifi0 wlanmode ap

A couple other, older tickets have been opened, but none of the proposed fixes helped. It's not necessarily a kernel panic: Caps Lock doesn't blink, etc; and the cursor on the screen keeps on blinking.

I got it to work in FreeBSD, but I don't have enough experience with that to set it up, so I need madwifi to work.

Attachments

lspci.txt (1.7 kB) - added by pavlina.chris@gmail.com on 07/16/08 04:17:29.
Output of lspci
dmesg.txt (30.6 kB) - added by pavlina.chris@gmail.com on 07/16/08 04:20:42.
Output of dmesg (command has not yet been run)

Change History

07/16/08 04:17:29 changed by pavlina.chris@gmail.com

  • attachment lspci.txt added.

Output of lspci

07/16/08 04:20:42 changed by pavlina.chris@gmail.com

  • attachment dmesg.txt added.

Output of dmesg (command has not yet been run)

(in reply to: ↑ description ) 07/16/08 04:39:11 changed by pavlina.chris@gmail.com

I was going to include the excerpt from /var/log/syslog from when it crashes, but nothing was ever logged.