Please note: This project is no longer active. The website is kept online for historic purposes only.
If you´re looking for a Linux driver for your Atheros WLAN device, you should continue here .

Ticket #2026 (new defect)

Opened 13 years ago

Last modified 13 years ago

Thinkpad R51e with AR5212 drops out with Mandriva, Ubuntu, Kubuntu, Fedora, openSUSE

Reported by: anonymous Assigned to:
Priority: major Milestone:
Component: madwifi: other Version: v0.9.4
Keywords: Cc:
Patch is attached: 0 Pending:

Description

As with ticket #1951

I have now tried the following distros on my laptop (Thinkpad R51e):

Mandriva 2008 Mandriva 2008.1 (spring) Ubuntu Hardy Heron Kubuntu Hardy Heron Fedora 9 openSUSE 11.0

every time with the latest drivers from this website. On all of these the wifi works for a short time, if I'm lucky maybe a few hours and then drops out. There are no error messages in dmesg or syslog. If you do a "wlanconfig ath0 list ap", nothing appears in the list, an ifup and ifdown on the interface does nothing, a reboot is the only fix.

This same laptop has run older Mandriva distros 2007.1 and earlier without any wireless problems.

Today I just tried:

openSUSE 11.0

With the latest rpm from the madwifi website (featured in the news on the front page) and guess what? Same problem. This is with madwifi-0.9.4-1.i586.rpm

As usual my laptop is still running the old Mandriva 2007.1 (spring) in dual boot with never any problems, (it's on 24 hours a day almost and has worked since 2007.1 was released)

The driver on the Mandriva 2007.1 is madwifi-0.9.2-1 with a 2.6.17 kernel.

I have tried to install this driver on the newer distros but there are compatibility issues with gcc and such.

openSUSE 11.0 came with ath5k but this wouldn't even connect with any AP. When I installed the madwifi from this website it worked but dropped out again after an hour.

I'm stuck to using old distros. Rolling my own kernels and building everything from source is too time consuming and messes up the package management.

Obviously something happened in a kernel upgrade or the driver upgrade as it worked fine for years.

Change History

07/02/08 16:33:27 changed by anonymous

I also get intermittent disconnects using a Thinkpad R50P with atheros 5213 chipset (on OpenSUSE 11).

The card is detected by ath5k as: ath5k phy2: Atheros AR5213 chip found (MAC: 0x56, PHY: 0x41) ath5k phy2: RF5111 5GHz radio found (0x17) ath5k phy2: RF2111 2GHz radio found (0x23)

and I intermittently get: Michael MIC failure detected WPA: Sending EAPOL-Key Request (error=1 pairwise=1 ptk_set=1 len=99)

Niel