Please note: This project is no longer active. The website is kept online for historic purposes only.
If you´re looking for a Linux driver for your Atheros WLAN device, you should continue here .

Ticket #1989 (closed defect: fixed)

Opened 11 years ago

Last modified 11 years ago

Trunk builds fail

Reported by: anonymous Assigned to:
Priority: minor Milestone: version 0.9.5
Component: madwifi: other Version:
Keywords: Cc:
Patch is attached: 1 Pending:

Description

SVN revisions after 3653 fail to build into the kernel:

drivers/built-in.o: In function `ath_reset':
if_ath.c:(.text+0x8fb73): undefined reference to `ath_set_ack_bitrate'
drivers/built-in.o: In function `ath_sysctl_halparam':
if_ath.c:(.text+0x90b80): undefined reference to `ath_set_ack_bitrate'
drivers/built-in.o: In function `ath_init':
if_ath.c:(.text+0x94314): undefined reference to `ath_set_ack_bitrate'
drivers/built-in.o: In function `txcont_on':
if_ath.c:(.text+0x96384): undefined reference to `ath_set_ack_bitrate'
if_ath.c:(.text+0x963a9): undefined reference to `ar_device'
if_ath.c:(.text+0x963c3): undefined reference to `ar_device'
drivers/built-in.o: In function `ath_attach':
(.text+0x9c7d8): undefined reference to `ath5k_chip_name'
drivers/built-in.o: In function `ath_attach':
(.text+0x9c82f): undefined reference to `ath5k_chip_name'
drivers/built-in.o: In function `ath_radar_is_enabled':
(.text+0xa4e85): undefined reference to `ar_device'
drivers/built-in.o: In function `ath_radar_update':
(.text+0xa5111): undefined reference to `ar_device'
make: *** [.tmp_vmlinux1] Error 1

The problem is a missing file from the make file (this is the same problem that occurred with if_ath_radar, btw). The following fixes the problem:

--- linux-2.6.25.5/drivers/net/wireless/madwifi/ath/Makefile.orig	2008-06-10 14:44:16.000000000 -0400
+++ linux-2.6.25.5/drivers/net/wireless/madwifi/ath/Makefile	2008-06-10 14:28:39.000000000 -0400
@@ -37,7 +37,7 @@
 
 ifneq ($(VERSION).$(PATCHLEVEL),2.4)
 obj-$(CONFIG_ATHEROS)	+= ath_$(BUSNAME).o
-ath_$(BUSNAME)-objs	:= if_ath.o if_ath_radar.o if_ath_$(BUSNAME).o
+ath_$(BUSNAME)-objs	:= if_ath.o if_ath_radar.o if_ath_hal_extensions.o if_ath_$(BUSNAME).o
 endif
 
 ifeq ($(VERSION).$(PATCHLEVEL),2.4)

Change History

06/12/08 06:11:49 changed by mrenzmann

  • patch_attached set to 1.

Please test whether this issue still exists in the latest revision of trunk. If it does, please sign off your patch. Thanks.

06/19/08 04:39:10 changed by mentor

  • status changed from new to closed.
  • resolution set to fixed.
  • milestone set to version 0.9.5.

This was fixed in r3723 from benoit