Please note: This project is no longer active. The website is kept online for historic purposes only.
If you´re looking for a Linux driver for your Atheros WLAN device, you should continue here .

Ticket #1927 (closed defect: fixed)

Opened 11 years ago

Last modified 11 years ago

Monitor mode packet injection broken starting in svn r3481

Reported by: darkaudax@aircrack-ng.org Assigned to:
Priority: critical Milestone: version 0.9.5
Component: madwifi: driver Version: trunk
Keywords: monitor mode inection Cc:
Patch is attached: 0 Pending:

Description

Operating System: Fedora 8 (2.6.24.5-85.fc8) Card: Netgear WPN311 Chipset: Atheros Communications, Inc. AR5212 802.11abg NIC (rev 01)

Up to and including svn r3480, packet injection worked in monitor mode.

svn r3481 through svn r3531 fails due to a compile error.

svn r3532 and above compile but injection no longer works in monitor mode.

Injection was tested using the aircrack-ng suite.

Change History

(follow-up: ↓ 2 ) 05/12/08 05:07:59 changed by adolfotregosa@hotmail.com

any news on this ??

thank you

(in reply to: ↑ 1 ) 05/12/08 20:28:57 changed by sombrutz@informatik.hu-berlin.de

I tested revision 3480 up to 3620. I also get the result that packet injection does'nt work sincfe revision 3481, but in revision 3497 up to revision 3500 it works again. Revisions greater than 3500 compile but the kernel hangs when i start the interface using "ifconfig ath0 up". I try to find out whether it hangs and if i fix this, i'm maybe able to see since which revision greater than 3500 the packet injection doesn't work. Any other ideas to solve the problem ?

(follow-up: ↓ 4 ) 05/12/08 22:18:37 changed by mentor

Would you define the terms "doesn't work" and "kernel hangs" please?

(in reply to: ↑ 3 ) 05/13/08 01:24:31 changed by sombrutz@informatik.hu-berlin.de

with "It doesn't work" , i mean that the packet injection doesn't work if the device is started in Monitormode. I use click (read.cs.ucla.edu/click/) to send raw-packet using ath0 from one device to a second device. although neither click nor the driver announce some error, a second device doesn't receive the frames. Since the second-device receives other packets (beacons,...) it seems to me that the problem is to send frames in monitormode. Since revision 3501 up to 3518 machine crashes when i start the device with ifconfig ath0 up. The problem for debugging is, that it is a embedded device and i've only ssh-access (its a testbed at my university). The machine has a watchdog which reboots the machine after i bring up the device, so i assume that the kernel crashes(kernel hangs). I'll try to get physical access to the devices this week and will use the serial console to get more information.

05/15/08 03:24:23 changed by mentor

  • priority changed from major to critical.
  • milestone set to version 0.9.5.

This appears to be related to complete cessation of network traffic after/during the creation of a monitor mode VAP that I have been seeing.

Bumping priority

(follow-up: ↓ 7 ) 06/07/08 05:26:47 changed by mentor

Please test with r3711, which allows traffic to flow when a monitor mode interface is present. I have not tested packet injection specifically.

(in reply to: ↑ 6 ) 06/07/08 16:57:04 changed by anonymous

Replying to mentor:

Please test with r3711, which allows traffic to flow when a monitor mode interface is present. I have not tested packet injection specifically.

I am now running Fedora 9 (2.6.25.4-30.fc9.i686).

Monitor mode in r3711 works.

Injection in r3711 still fails.

06/12/08 07:26:18 changed by mentor

  • status changed from new to closed.
  • resolution set to fixed.

Heh. r3720. Easy when you finally look in the right place. Tested as working.