Please note: This project is no longer active. The website is kept online for historic purposes only.
If you´re looking for a Linux driver for your Atheros WLAN device, you should continue here .

Ticket #1922 (closed defect: fixed)

Opened 11 years ago

Last modified 11 years ago

Network connection hangs with r3548

Reported by: beat.zahnd@gmail.com Assigned to: mentor
Priority: major Milestone: version 0.9.5
Component: madwifi: driver Version:
Keywords: Cc:
Patch is attached: 0 Pending:

Description

When using code later from r3548 or newer, network connections are blocking under high load. ssh terminal connections still work well, but a http fetch on a 100M file immediately hangs. I verified this using channel 40 (5.2GHz 802.11a) without encryption. The master station used r3355 and the code on the client has been changed from r3547 to r3548. Using r3547 transfer rates of 3.7MB/s where possible. Using r3548 connections block immediately.

Change History

05/01/08 22:48:46 changed by foodoc

maybe you should describe your setup a bit more... since I have _zero_ problems here.

e.g:

hardware. (CPU-Platform/wifi-card/...)
software (daemons, that _may_ interfere)
wifi settings (XR/AR/WMM/FF/TURBO/...)

05/02/08 06:29:50 changed by mrenzmann

Also, what does "connection blocks" mean? Did you try to trace what happens on the medium (via tshark/wireshark/tcpdump or some similar tool)?

What's the signal quality of the link (check iwconfig for that information)? What is the distance of AP and client? Does this also happen on other channels, including 2.4 GHz?

05/03/08 00:18:45 changed by Przemyslaw Bruski

Hi,

I've noticed a problem with changeset r3548 that occurs when fast frames are enabled. The changeset assumes equivalence between ds->ds_link and bf->bf_desc->ds_link, however, the descriptor address for the last fast frame is in fact zeroed in this code section:

	ds->ds_link = (skbtmp->next == NULL) ? 
				0 : bf->bf_daddr + (sizeof(*ds) * (i + 2));

This means that for the last fast frame the assumed equivalence does not exist. Whenever a fast frame is processed, the transmission on card is for some time. Temporary solution - disable FF or back out r3458.

bye,

Przemek

05/03/08 00:26:35 changed by Przemyslaw Bruski

Sorry, I've meant: 'back out r3548' of course ;-)

05/03/08 11:29:26 changed by anonymous

I can confirm that this problem is related to fast frames. Switching of FF on the master is solving the problem.

The master is a PowerPC with a Netgear WG511U PC Card and the client used in this setup is a Intel machine using the same card. Distance is around 4m. Both machines are running Debian Etch. Signal quality is perfect. The same happens on 2.4GHz

The problem can be reproduced by initiating a high data rate connection. In my case I used wget to fetch a 100GB file from the web server running on the master machine. After the initial packets no further packets are exchanged until I cancel wget. pings running in parallel are also blocked but work well without losts before and after running wget.

05/03/08 11:30:47 changed by beat.zahnd@gmail.com

Sorry, that was me above. Forgot to set my email

05/05/08 06:23:44 changed by mrenzmann

  • owner set to mentor.

r3548 is a change made by mentor, so I assign this ticket to him. Matthew, can you please look at it?

05/06/08 02:18:43 changed by mentor

Please test that r3616 does indeed fix the issue.

05/06/08 02:18:53 changed by mentor

  • priority changed from critical to major.

05/06/08 09:58:25 changed by Przemyslaw Bruski

The fix works. Thanks!

05/06/08 10:04:16 changed by mentor

  • status changed from new to closed.
  • resolution set to fixed.
  • milestone set to version 0.9.5.

Well, 90% is working out what the problem is, which you did for me. Thanks.

Closing as fixed - r3616.