Please note: This project is no longer active. The website is kept online for historic purposes only.
If you´re looking for a Linux driver for your Atheros WLAN device, you should continue here .

Ticket #1904 (closed defect: fixed)

Opened 11 years ago

Last modified 11 years ago

Monitor mode only works for a few minutes.

Reported by: mitchell@ucar.edu Assigned to:
Priority: minor Milestone: version 0.9.5
Component: madwifi: other Version: v0.9.4
Keywords: Cc:
Patch is attached: 0 Pending:

Description

I have a problem where I only receive packets for a few minutes after entering monitor mode. I am using kismet_drone to receive packets. It works fine initially, but after some short period of time I stop receiving any packets. I've played with the debugging options on the driver, but can't identify any obvious problems. I did determine that after the output hangs, the debug options recv_desc, intr and recv_proc no longer produce any output. That's a big part of what convinces me the problem is in the driver and not in kismet. If I stop and restart kismet it gets packets again for a few minutes (but then I get the channel-change bug which I commented on in ticket #612).

I think I have up to date drivers. This is a laptop running Ubuntu 7.10. It reports ath_hal: 0.9.18.0, wlan: 0.8.4.2 (0.9.3.2), ath_pci: 0.9.4.5 (0.9.3.2). I'd be happy to do whatever testing or log gathering folks need to help me track this down.

Change History

04/23/08 06:15:59 changed by mrenzmann

It might be worth to try trunk, to see if this problem exists there, too.

04/23/08 23:17:08 changed by mitchell

Hey, that's seems to have fixed it. The channel-changing bug is fixed as well. Thanks!

04/24/08 06:16:03 changed by mrenzmann

  • status changed from new to closed.
  • resolution set to fixed.
  • milestone set to version 0.9.5.

Thanks for the feedback. Closing ticket as fixed.