Please note: This project is no longer active. The website is kept online for historic purposes only.
If you´re looking for a Linux driver for your Atheros WLAN device, you should continue here .

Ticket #1900 (new defect)

Opened 11 years ago

Last modified 11 years ago

clients cannot connect when ap in wep only mode

Reported by: Ken Roberts <ken@glaserelectronics.com> Assigned to:
Priority: major Milestone:
Component: madwifi: 802.11 stack Version: v0.9.4
Keywords: Cc:
Patch is attached: 0 Pending:

Description (Last modified by mrenzmann)

Kernel: Linux 2.6.21.5-smp Madwifi: 0.9.4-r3536 (compiled into kernel as module)

AP Configuration: br0:

  • eth0
  • ath0

WDS = 1

AP setup:

  • wlanconfig ath0 create wlandev wifi0 wlanmode sta
  • iwpriv ath0 wds 1
  • iwconfig ath0 essid 'ssid' nick "$(uname -r)"
  • ifconfig ath0 0.0.0.0 up {Tried with ifconig here and after setting keys}
  • iwconfig ath0 enc 0123456789 [1] open
  • athkey -i ath0 1 wep 0123456789 { tried with and without this command }

Notes:

  • Clients will sometimes connect when issuing commands from console
  • Clients will not connect when using above in script

Attached is Wireshark pcap of conversation

Attachments

wep_connect_ap_notebook.pcap (6.8 kB) - added by Ken Roberts <ken@glaserelectronics.com> on 04/21/08 21:42:34.
Wireshark PCAP of ap<->client association

Change History

04/21/08 21:42:34 changed by Ken Roberts <ken@glaserelectronics.com>

  • attachment wep_connect_ap_notebook.pcap added.

Wireshark PCAP of ap<->client association

04/22/08 06:05:12 changed by mrenzmann

  • description changed.