Please note: This project is no longer active. The website is kept online for historic purposes only.
If you´re looking for a Linux driver for your Atheros WLAN device, you should continue here .

Ticket #1819 (closed defect: fixed)

Opened 12 years ago

Last modified 12 years ago

panic with new stable 0.9.4 and Ubiquiti SR2

Reported by: jan@saxnet.de Assigned to:
Priority: major Milestone: version 0.9.5
Component: madwifi: driver Version: v0.9.4
Keywords: SR2 panic Cc:
Patch is attached: 0 Pending:

Description

Hi,

again I have to tell you that your stable versions do not work with Ubiquiti SR2 cards. A panic happens with the simplest setups. I have used my Alix board as client with wpa2 RSN encryption. After maybe 10 minutes of pinging the panic appears. Its the same thing as it was with 0.9.3.2 and 0.9.3.3. BUT: with the trunks between 30XX an 3279 the problem was gone. So my question is: what bug has the stable release which the trunk has not?...

My system: Alix boards (different types), kernel 2.6.24-mesh, voyage linux, 2x ubiquiti SR2, wpa_supplicant versions 0.5.9/0.6.1/0.6.3 ...I tested them all.

So do you madwifi-developer need some ubiquiti cards th fix this bugs in the stable release? If it is so, please tell me.

------------[ cut here ]------------
Kernel BUG at c0144e20 [verbose debug info unavailable]
invalid opcode: 0000 [#1] PREEMPT 
Modules linked in: wlan_ccmp wlan_scan_sta ath_pci bridge llc ipv6 dm_mod scx200_acb lm77 i2c_core natsemi ath_rate_sample snd_cs5535audio snd_ac97_codec snd_pcm snd_timer snd soundcore ac97_bus snd_page_alloc wlan cs5535_gpio ath_hal(P) ohci_hcd ehci_hcd usbcore via_rhine mii bitrev crc32

Pid: 0, comm: swapper Tainted: P        (2.6.24-mesh #1)
EIP: 0060:[<c0144e20>] EFLAGS: 00010046 CPU: 0
EIP is at kfree+0x47/0x6f
EAX: 00000000 EBX: cf905000 ECX: cf894360 EDX: c27ae0c0
ESI: 00000006 EDI: 7d7061c7 EBP: cf20d360 ESP: c0343d94
 DS: 007b ES: 007b FS: 0000 GS: 0000 SS: 0068
Process swapper (pid: 0, ti=c0342000 task=c031a320 task.ti=c0342000)
Stack: cf905000 cf20d360 cf894360 d08c66da d08b8ce0 000000fa 00000007 00000001 
       00000046 cf905000 d08efcef cf905000 cf905000 cf894ce8 d08c52af cf894360 
       d08e639f cf905000 00000000 d08c4b5c 00000505 003b0064 cf9aa05b cf9aa038 
Call Trace:
 [<d08c66da>] node_cleanup+0xe8/0x127 [wlan]
 [<d08efcef>] ath_node_cleanup+0x1a5/0x1c4 [ath_pci]
 [<d08c52af>] node_free+0xc/0x44 [wlan]
 [<d08e639f>] ath_node_free+0x26/0x2f [ath_pci]
 [<d08c4b5c>] _ieee80211_free_node+0xe5/0xed [wlan]
 [<d08c4d03>] ieee80211_free_node+0x31/0x6b [wlan]
 [<d08e787e>] ath_tx_draintxq+0xd0/0x120 [ath_pci]
 [<d08e79f5>] ath_draintxq+0x127/0x138 [ath_pci]
 [<d08ec110>] ath_recv_mgmt+0x0/0x19e [ath_pci]
 [<d08eb209>] ath_set_channel+0x138/0x44a [ath_pci]
 [<c0231f8f>] pskb_expand_head+0xe3/0x14b
 [<d08cc986>] change_channel+0xe/0xf [wlan]
 [<d08cd621>] scan_next+0x1ab/0x489 [wlan]
 [<c010bec2>] __update_rq_clock+0x1a/0xf3
 [<d08cd476>] scan_next+0x0/0x489 [wlan]
 [<c011662a>] run_timer_softirq+0x102/0x176
 [<d083f8be>] usb_hcd_irq+0x21/0x4d [usbcore]
 [<c012bf0f>] note_interrupt+0x116/0x237
 [<c0113909>] __do_softirq+0x35/0x75
 [<c011396b>] do_softirq+0x22/0x26
 [<c0113b2e>] irq_exit+0x25/0x30
 [<c0104c20>] do_IRQ+0x58/0x6b
 [<c0103503>] common_interrupt+0x23/0x30
 [<c010122a>] default_idle+0x0/0x39
 [<c035007b>] setup_IO_APIC+0x8c4/0xe44
 [<c0101251>] default_idle+0x27/0x39
 [<c0100d36>] cpu_idle+0x3c/0x65
 [<c03449b8>] start_kernel+0x23c/0x241
 [<c0344313>] unknown_bootoption+0x0/0x195
 =======================
Code: c9 37 c0 8b 02 25 00 40 02 00 3d 00 40 02 00 75 03 8b 52 0c 8b 02 25 00 40 02 00 3d 00 40 02 00 75 03 8b 52 0c 8b 02 84 c0 78 04 <0f> 0b eb fe 8b 4a 18 8b 19 8b 03 3b 43 04 72 0b 89 c8 89 da e8 
EIP: [<c0144e20>] kfree+0x47/0x6f SS:ESP 0068:c0343d94
Kernel panic - not syncing: Fatal exception in interrupt
Rebooting in 30 seconds..

Change History

03/11/08 15:54:29 changed by jan@saxnet.de

Hi,

atm the 0.9.4 stable works fine with wpa_supplicant and hostapd Vers. 0.5.10 stable. Maybe the problems are gone now. If it works stable till tomorrow I will tell you again. Then you can close the ticket.

So hopefully I can tell you good news tomorrow!

regards,

Jan.

03/12/08 16:32:13 changed by jan@saxnet.de

Ok, the stable version now works fine. please close this ticket!!!

regards,

Jan.

03/13/08 05:37:55 changed by mrenzmann

You did originally report this issue for v0.9.4 (and mentioned that it also exists on v0.9.3.x). Just to be sure: when you refer to "the stable version" above, you talk about v0.9.4?

03/13/08 08:39:40 changed by jan@saxnet.de

Hi,

yes, I mean the 0.9.4, which now works ok, but I still do not know, why it works now, because I only changed the hostapd/wpa_supplicant versions. But nevermind, it works!!

The older stable versions have still problems with SR2 Cards and setups with hostapd and wpasupp together in a bridge. But as I mentioned, these problems dissapear with the later trunk versions.

So if you want to close this ticket, please do it :)

regards,

Jan.

03/13/08 16:12:46 changed by mrenzmann

  • priority changed from critical to major.
  • status changed from new to closed.
  • resolution set to fixed.
  • milestone set to version 0.9.5.

Roger that, thanks for the feedback. Closing this as fixed, although it's unsure if everything really was caused by bugs in MadWifi.