Please note: This project is no longer active. The website is kept online for historic purposes only.
If you´re looking for a Linux driver for your Atheros WLAN device, you should continue here .

Ticket #1787 (closed defect: fixed)

Opened 11 years ago

Last modified 11 years ago

Problem compiling trunk version of madwifi in kernel 2.4

Reported by: henriquemarks@gmail.com Assigned to:
Priority: minor Milestone: version 0.9.5
Component: madwifi: other Version: trunk
Keywords: Cc:
Patch is attached: 0 Pending:

Description (Last modified by mrenzmann)

There is a problem compiling trunk for kernel 2.4

The file ieee80211_scan_ap.c (inside net80211) includes a file that do not exist for older kernel versions.

50 #if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,11)
51 #include "sort.c"
52 #else
53 #include <linux/sort.h>
54 #endif

As this file was not sent with madwifi, it is necessary to copy form a newer version of the kernel this file, sort.c, and the header file sort.h, put these files in the appropriate places in the 2.4 kernel (lib folder and include/linux folder inside the kernel sources) and recompile madwifi.

Doing this the problem is solved, i.e, madwifi compiles again for older kernels. But it wasnt tested if this solution brings some other effects.

svn version 3353.

Change History

02/13/08 06:03:56 changed by mrenzmann

  • description changed.

Which kernel version are you exactly talking about?

05/06/08 15:31:22 changed by anonymous

Kernel 2.4.32, for instance.

05/08/08 07:03:53 changed by mrenzmann

  • status changed from new to closed.
  • resolution set to fixed.
  • milestone set to version 0.9.5.

The originally reported issue does no longer exist in current trunk (r3620). I therefor close this ticket as fixed.

However, there is another compilation issue for 2.4.x kernels. Please follow up to #1932.