Please note: This project is no longer active. The website is kept online for historic purposes only.
If you´re looking for a Linux driver for your Atheros WLAN device, you should continue here .

Ticket #1783 (closed defect: fixed)

Opened 12 years ago

Last modified 11 years ago

[patch] build failure on xscale little endian due to changeset 2933

Reported by: rod@whitby.id.au Assigned to: proski
Priority: minor Milestone: version 0.9.5
Component: madwifi: other Version:
Keywords: Cc:
Patch is attached: 1 Pending:

Description

Changeset 2933 has introduced a regression in ath_hal/ah_os.h when building on xscale LE. As you will see on lines 206/210 in that changeset, ioread32be and iowrite32be are now required to be defined, even if AH_LITTLE_ENDIAN is set. Therefore on line 171 of ath_hal/ah_os.h, the condition checking AH_BYTE_ORDER needs to be removed from that conditional (so that ioread32be and iowrite32be are defined, even for the little endian case (even though they are not used in that case).

Attachments

30-define-ioreadwrite32be-for-little-endian-too.patch (0.6 kB) - added by rod@whitby.id.au on 02/11/08 14:12:32.
patch

Change History

02/11/08 14:12:32 changed by rod@whitby.id.au

  • attachment 30-define-ioreadwrite32be-for-little-endian-too.patch added.

patch

02/11/08 14:17:52 changed by rod@whitby.id.au

Signed-off-by: Rod Whitby <rod@whitby.id.au>

06/04/08 09:52:00 changed by proski

  • status changed from new to assigned.
  • owner set to proski.

I fixed that in r3402, but my changes were reverted in r3481 without informing me and without even mentioning that fact in the change log.

The real issue is that we cannot rely on gcc optimizing out the unneeded functions. The attached patch would work, but if gcc is so bad at optimization on xscale, it might actually emit code for those unused functions. I would prefer a streamlined solution, even if it's longer, because the device registers are accessed a lot.

06/05/08 18:45:36 changed by proski

  • status changed from assigned to closed.
  • resolution set to fixed.

Fixed again in r3700

06/06/08 09:19:51 changed by mrenzmann

  • milestone set to version 0.9.5.