Please note: This project is no longer active. The website is kept online for historic purposes only.
If you´re looking for a Linux driver for your Atheros WLAN device, you should continue here .

Ticket #1782 (new defect)

Opened 14 years ago

Last modified 14 years ago

no association with wpa_supplicant on weak signal-strength

Reported by: jan@saxnet.de Assigned to:
Priority: minor Milestone:
Component: madwifi: driver Version: trunk
Keywords: Cc:
Patch is attached: 0 Pending:

Description

Hi again,

I'm sorry to tell you this again, but I still have big problems with wpa_supplicant when I try to connect to an accesspoint which is behind a wall or under the roof (or on another place where the SNR is under 25 or weaker) which was always possible with the stable madwifi 0.9.3.2/3). I'm still using ALIX/WRAP boards with voyage images, now with kernel 2.6.24, hostapd 0.5.9 and wpa_supplicant 0.5.9 and SR2/CM9/Sparklan abg cards.

The supplicant trys to connect, but my ap always gets blacklisted by the supplicant. I tried all typs of wirelesscards I had, but with every card I tried I got the same trouble.

Then I tried an old image of mine with 0.9.3.2 stable and 2.6.21-7 kernel as client with wpa_supplicant 0.5.8 and it worked. It also worked with all of my wireless devices in the office: macbook, Imac, atheros cards in Windows-PCs etc pp. They all could connect without interference.

I discovered this behavior of wpa_supplicant since I tried a few trunks after I had these ugly kernel-panics with 0.9.3.3 with "wpa_supp and hostapd together in a bridge". With all the trunks I used I had the same troubles with weak SNR rates with wpa_supplicant and this dumb blacklisting-stuff.

Last point: If I do not use encryption, the client associates imediatly, but after I send few data-packages (iperf) the device gets down (ath0 entering disabled state) and it does not go into enabled state.

My script (it builds a chain of nodes (always ap/sta <-> ap/sta <-> ap/sta <- )) :

        killall hostapd
	killall wpa_supplicant
	ifconfig br0 down
	brctl delbr br0
	echo 1 > /proc/sys/net/ipv4/ip_forward
#madwifi neu laden 
	rmmod ath_pci
	modprobe ath_pci
#wifi0 hochfahren als sta
	wlanconfig ath0 create wlandev wifi0 wlanmode sta
	iwconfig ath0 essid strecke1
	ifconfig ath0 0.0.0.0 down
	iwpriv ath0 wds 1
	ifconfig ath0 0.0.0.0 up 
#wifi1 hochfahren als ap
	wlanconfig ath1 create wlandev wifi1 wlanmode master
	iwconfig ath1 essid strecke2
	iwconfig ath1 channel 52
	ifconfig ath1 0.0.0.0 down
	iwpriv ath1 wds 1
	ifconfig ath1 0.0.0.0 up 
#eth0 einschalten
	ifconfig eth0 0.0.0.0 up
#bridging
	brctl addbr br0
	brctl addif br0 ath0
	brctl addif br0 ath1
	brctl addif br0 eth0
	brctl setfd br0 1
#bridge hochfahren
	ifconfig br0 192.168.2.22 up

	hostapd -B /etc/hostapd/hostapd.conf
	sleep 1
	wpa_supplicant -B -i ath0 -D madwifi -b br0 -c /etc/wpa_supplicant/wpa_supplicant.conf

Change History

02/11/08 10:10:34 changed by jan@saxnet.de

Hi,

tried it with the unstable wpa_supplicant version 0.6.2 and it worked nicely. But sometimes my AP still gets blacklistet, but now I've found out why: it's a timeout. It occurs sometimes. But I cannot reproduce it.

Link quality is at 23/70.

regards

Jan Giera