Please note: This project is no longer active. The website is kept online for historic purposes only.
If you´re looking for a Linux driver for your Atheros WLAN device, you should continue here .

Ticket #1775 (new defect)

Opened 14 years ago

Last modified 14 years ago

Nokia E51 in powersave-mode becomes unusable after a short time with Madwifi as AP

Reported by: mail@amette.eu Assigned to:
Priority: major Milestone:
Component: madwifi: driver Version: v0.9.3.3
Keywords: Cc:
Patch is attached: 0 Pending:

Description (Last modified by mrenzmann)

I have an access point running on Linux 2.6.22-gentoo-r9 with madwifi-ng 0.9.3.3. Lately I bought a Nokia E51 cell phone which has WLAN integrated. After a short time browsing the web, page loading became very slow. With the phone comes the VoIP-application Gizmo, which wasn't able to connect at all to its server over WLAN. I switched off power-saving in the phone and suddenly everything worked fast and Gizmo could connect to its service. A reboot of the AP also makes the phone (in powersave-mode) work perfectly - this solution only lasts for about five minutes though.

Considering power saving in clients and getting worse over time, it looked to me like the stuck beacon problem, but I can't find any error messages about it in my logs neither can I say that my interrups go higher (they stay at around 40 per second).

I tried all the fixes on the Stuck Beacon page and in ticket #1081 - nothing helped and running the phone without power-save mode is no option as the battery then is empty in less than half a day.

Other clients don't seem to be affected, it's only the mobile phone that can't use network connectivity any more - and switching it to 'no powersaving' while the problem exists solves it.

Unloading all modules and reloading/restarting networking and hostapd didn't help either.

btw - I found reports from people having the same problems with Zyxel or Linksys routers: http://www.allaboutsymbian.com/forum/showthread.php?t=50908

Change History

02/04/08 06:13:39 changed by mrenzmann

  • description changed.
  • reporter changed from anonymous to mail@amette.eu.

02/06/08 02:50:04 changed by mentor

Can you reproduce with trunk?

02/11/08 21:54:24 changed by mail@amette.eu

I now got a new router (internet-provider changed) and it works perfectly with the Fritz!Box (the router).

At work I implemented the same access point as at home before, it's exactly the same atheros card. Only in this case the system is Debian 4.0 with 2.6.18 Debian sources compiled from hand and madwifi-0.9.3.3. No connection problems from the cell phone whatsoever - so do I have to set some kernel-options on my Gentoo machine or is it the newer kernel version? That debian machine freezes completely in irregular intervals since the atheros card is in - but I suspect that's a problem with the debian bridge utils. Apart from that the originally reported connection problems aren't present on the debian machine.

I'll try on my Gentoo-machine with trunk as soon as possible.