Please note: This project is no longer active. The website is kept online for historic purposes only.
If you´re looking for a Linux driver for your Atheros WLAN device, you should continue here .

Ticket #1765 (new defect)

Opened 14 years ago

Last modified 14 years ago

System Hang on Custom PCI Core

Reported by: lware2002@hotmail.com Assigned to:
Priority: minor Milestone:
Component: madwifi: other Version: v0.9.3.3
Keywords: Cc:
Patch is attached: 0 Pending:

Description (Last modified by mrenzmann)

ath_hal: module license 'Proprietary' taints kernel.
ath_hal: 0.9.18.0 (AR5210, AR5211, AR5212, RF5111, RF5112, RF2413, RF5413, REGOP
S_FUNC)
wlan: 0.8.4.2 (0.9.3.3)
ath_pci: 0.9.4.5 (0.9.3.3)
ath_attach: devid 0x13
ath_descdma_setup: rx DMA: 40 buffers 1 desc/buf
ath_descdma_setup: rx DMA map: ff100000 (1920) -> 3155000 (1920)
ath_descdma_setup: tx DMA: 200 buffers 2 desc/buf
ath_descdma_setup: tx DMA map: ff101000 (19200) -> 31c8000 (19200)
ath_descdma_setup: beacon DMA: 4 buffers 1 desc/buf
ath_descdma_setup: beacon DMA map: ff106000 (192) -> 31cf000 (192)
ath_xr_rate_setup: rate table too small (13 > 15)
ath_rate_sample: 1.2 (0.9.3.3)
ath_rate_sample: ath_rate_attach
wifi0: 11a rates: 6Mbps 9Mbps 12Mbps 18Mbps 24Mbps 36Mbps 48Mbps 54Mbps
wifi0: 11b rates: 1Mbps 2Mbps 5.5Mbps 11Mbps
wifi0: 11g rates: 1Mbps 2Mbps 5.5Mbps 11Mbps 6Mbps 9Mbps 12Mbps 18Mbps 24Mbps 36
Mbps 48Mbps 54Mbps
wifi0: turboA rates: 6Mbps 9Mbps 12Mbps 18Mbps 24Mbps 36Mbps 48Mbps 54Mbps
wifi0: turboG rates: 6Mbps 12Mbps 18Mbps 24Mbps 36Mbps 48Mbps 54Mbps
wifi0: H/W encryption support: WEP AES AES_CCM TKIP
wifi0: mac 10.5 phy 6.1 radio 6.3
wifi0: Use hw queue 1 for WME_AC_BE traffic
wifi0: Use hw queue 0 for WME_AC_BK traffic
wifi0: Use hw queue 2 for WME_AC_VI traffic
wifi0: Use hw queue 3 for WME_AC_VO traffic
wifi0: Use hw queue 8 for CAB traffic
wifi0: Use hw queue 9 for beacons
ath_rate_sample: ath_rate_ctl_reset 00:00:00:00:00:00 no rates (fixed 4294967295
)
ath_node_alloc: an c3dd0000
wifi0: Atheros 5212: mem=0x3fff0000, irq=3
     ath_pci: loaded successfully

ifconfig ath0 up
ath_init: mode 1
ath_stop_locked: invalid 0 flags 0x1002
ath_startrecv: mtu 1500 cachelsz 32 rxbufsize 3104

Change History

02/01/08 05:57:49 changed by mrenzmann

  • description changed.

Please try if this issue still exists in trunk and/or 0.9.4-rc1.

02/01/08 21:32:25 changed by lware2002@hotmail.com

I am still getting the hanging once if bring up the ath0 interface. I am using a custom PCI core and wanted to know if PCI DMA was a necessary requirement. I added some debug code to the driver and it seems to crash in ath_mode_init called in routing ath_startrecv

02/06/08 16:57:01 changed by mentor

  • priority changed from critical to minor.
  • summary changed from system hangs on if ath0 up to System Hang on Custom PCI Core.

Can you reproduce this bug using a non-custom PCI core and trunk?

I'm just going to assume that bus mastering is such a good idea, that nobody will want to bother trying to support a PCI bus without it. Downgrading to minor for now.