Please note: This project is no longer active. The website is kept online for historic purposes only.
If you´re looking for a Linux driver for your Atheros WLAN device, you should continue here .

Ticket #1696 (reopened defect)

Opened 14 years ago

Last modified 12 years ago

Hard freeze - intermittent - different cards

Reported by: tigerwolf@tigerden.com Assigned to:
Priority: major Milestone:
Component: madwifi: other Version: v0.9.3.3
Keywords: Cc:
Patch is attached: 0 Pending:

Description (Last modified by mentor)

Machine hard freezes requiring power cycle reboot. No error messages, just total lock-up. Freezes seem random, but operation longer than a few minutes has never been observed. Freezes do not appear to be related to amount of network traffic. Both 0.9.3.3 and ng-r3036 act the same.

Freezes happen on the following machines (several identical models tried to rule out hardware): - Hitachi Visiondesk 1120 - 450MHz K6-2 CPU w/ 256meg Ram - Linux 2.6.18 or 2.6.20 kernels both 'stock' or custom compiled kernels. - Distro is Vector Linux 5.8 (Slackware 10 based) with latest updates.

Both Netgear and Trendnet PCI cards, both with 5212 chips, show identical behavior.

Machines work fine with Hawking (TI chip/acx111 driver) or Zyxel (Atheros AR5005VL chip/ndiswrapper) type cards.

I've read other tickets regarding hard freezes, so this does appear to be a non-trivial issue.

I am not a programmer type, but am willing to try to provide additional info if you can describe what to look for.

Change History

12/17/07 17:29:29 changed by spam@plattenreiter.net

Hi,

I have one of the new Ubiquiti SWX SRX PCMCIA EXpress Cards. I have set up madwifi 0.9.3.3 and got freezes all the time.

would like to contribute with some core dumps if anyone is so nice to help me with it?

thanks

sven

12/20/07 00:22:42 changed by mentor

  • priority changed from blocker to major.

12/20/07 00:29:00 changed by mentor

  • description changed.
  • summary changed from Hard freeze - intermittant - different cards to Hard freeze - intermittent - different cards.

12/30/07 13:35:54 changed by altar@altern.org

I do also have the same problem here. I'm running an ubuntu 7.10 server with kernel 2.6.22 with a dlink g520 (B4/4.30) (AR5212 chipset).

I'm using it in master mode to create my wireless network. The WPA protection is brought using the hostapd daemon but it doesn't looks like the source of the problem since I've disabled it and the computer still hangs up.

I'll provide any information you need.

Thanks.

01/02/08 00:44:02 changed by altar@altern.org

Okey, I've just tried the r3091 and looks like it solves my problem.

I wish you the same luck guys.

01/06/08 04:49:52 changed by mentor

  • status changed from new to closed.
  • resolution set to fixed.
  • milestone set to version 0.9.4.

Thanks

01/09/08 08:25:50 changed by tigerwolf@tigerden.com

The fixes may have worked for poster 'alter', but problem described in the original post persists with ng-r3122. System still freezes after random times.

01/13/08 13:47:43 changed by anonymous

I was too quick to conclude. 2 freezes in a row today.

01/18/08 13:44:42 changed by hijacka@googlemail.com

Do you have any advices, how to complete a debug for this case? would like to contribute with some logs. still have system hang ups all the time...

cheers

01/19/08 18:46:59 changed by mrenzmann

  • status changed from closed to reopened.
  • resolution deleted.

(follow-up: ↓ 12 ) 01/20/08 04:00:26 changed by mentor

  • milestone deleted.

(in reply to: ↑ 11 ) 04/21/08 22:53:55 changed by anonymous

Just curious if this is even still being looked at. I'm having the same problem, and was curious if there was some kind of update as I really won't want to have to move away from MadWIFI... Anything I can do to help?

04/21/08 23:23:11 changed by mentor

Sorry, it's not being looked at particularly closely.

Standard thing to try: try with a newer subversion checkout.

If it still doesn't work, the most helpful thing would be to see if you can get the console output from serial or using netconsole around when the machine freezes.

To everyone: Is it just one or two people experiencing this? Or lots and lots?

04/22/08 01:41:43 changed by altar@altern.org

Still got the problem over here too.

04/22/08 01:47:25 changed by anonymous

it hangs for me too, can it be related to this error I get sometimes?

wifi0: FAILED verification of AR5K_PHY_WEAK_OFDM_HIGH_M2 default value [found=0x40 (64) expected=0x40 (64)].
              (unknown):0x9868:0x409a4190:.1...... 1..11.1. .1.....1 1..1....:unknown

04/22/08 13:52:15 changed by anonymous

The worst problem about this is that I can't get it to happen consistently. Sometimes it takes 45 seconds, sometimes it takes 3 minutes, sometimes it takes 35 minutes. Does anyone have some action that makes this consistently happen?

(follow-up: ↓ 18 ) 05/03/08 19:50:40 changed by anonymous

And what about this?

wifi0: FAILED verification of AR5K_PHY_WEAK_CCK_THRESH default value [found=0x8 (8) expected=0x8 (8)].
              (unknown):0xa208:0xd03e4788:11.1.... ..11111. .1...111 1...1...:unknown

(in reply to: ↑ 17 ) 05/03/08 19:54:04 changed by foodoc

Replying to anonymous:

And what about this?

> wifi0: FAILED verification of AR5K_PHY_WEAK_CCK_THRESH default value [found=0x8 (8) expected=0x8 (8)].
>               (unknown):0xa208:0xd03e4788:11.1.... ..11111. .1...111 1...1...:unknown

well, that message is from a workaround... this is necessary, because the current HAL has some problems with ANI (see ticket #705 ).

05/10/08 22:14:08 changed by anonymous

HI, two days ago I recieved my Ubiquiti Express card which I have been trying to get to work properly under Ubuntu 7.10, BackTrack? 3Beta and Backtrack 2 without any success. After bootup (having the card inserted) my system (under all mentioned OS versions) seems to respond very slow untill it lockes. I upgrated the madwifi drivers on all OS systems to the latest version 0.9.4 but the problem still remains. Has anybody solved this issue, is there any data I can provide in order to assists in resolving this issue ??

Thanks allot

05/12/08 18:45:31 changed by posting@blx4.net

Hi,

I'm still seeing similar freezes here. System is AMD64/Gentoo 2.6.23, AP mode with two different cards (one at a time).

Interestingly, r2756 seems stable, but looses the connection/association as soon as some load is put on the link (a news website with some jpegs is sufficient :)

Latest trunk crashes relatively quickly and there're issues with WPA and hostapd.

One observation, my older card (PCI D-Link DWL-G520 b/g) locks up faster. A newer mini-PCI (Gigabyte a/b/g, AR5006X according to lscpi) reports stuck beacons for a while and ultimately freezes the box.

Please, let me know if you need more info. Problem is that this box is also my file server, so I'm not too interested in having it freeze on me too often :)

Thx !

06/02/08 17:17:59 changed by spam@plattenreiter.net

Hi,

today I had some time to test with the new builds. what I tried (ubi pcmcia express):

  • build r3680 with karma patches == no freezes
  • I tried to build r3680 with the aircrack-ng injection patch
  • madwifi-ng-r3386v3.patch: it didnt compile, this is the error message:
    sven@rasputin:~/pen/wlan/madwifi-r3680-052708$ make
    Checking requirements... ok.
    Checking kernel configuration... ok.
    make -C /lib/modules/2.6.24-16-386/build SUBDIRS=/home/sven/pen/wlan/madwifi-r3680-052708 modules
    make[1]: Entering directory `/usr/src/linux-headers-2.6.24-16-386'
      CC [M]  /home/sven/pen/wlan/madwifi-r3680-052708/ath/if_ath.o
    /home/sven/pen/wlan/madwifi-r3680-052708/ath/if_ath.c: In function 'ath_tx_startraw':
    /home/sven/pen/wlan/madwifi-r3680-052708/ath/if_ath.c:3000: error: 'struct ieee80211_phy_params' has no member named 'try0'
    make[3]: *** [/home/sven/pen/wlan/madwifi-r3680-052708/ath/if_ath.o] Error 1
    make[2]: *** [/home/sven/pen/wlan/madwifi-r3680-052708/ath] Error 2
    make[1]: *** [_module_/home/sven/pen/wlan/madwifi-r3680-052708] Error 2
    make[1]: Leaving directory `/usr/src/linux-headers-2.6.24-16-386'
    make: *** [modules] Fehler 2
    

one of the madwifi guys told me on irc I should try r3480. both patches (karma & aircrack-ng) works. I rebooted, changed to command line type "wlanconfig ath0 destroy && wlanconfig create ath0 wlandev wifi0 monitor". this works ... "ifconfig ath0 up" ... thats the moment where the systems freezed again.

so, maybe anybody is able to take a closer look on the conjunction with the injection (aircrack-ng) patches?

thanks

sven

08/14/08 22:39:57 changed by jeroen.benckhuijsen@gmail.com

Hi,

Just reporting I'm also experiencing random freezes. Mostly happens every 2 to 3 hours, so about 3/4 times a day. The problem is definitly madwifi related as it started when adding the wireless card. No messages in any log, so a hardware freeze..

Setup: Up-to-date Ubuntu 8.04/x86_64 Latest madwifi from svn (at least weekly update) Atheros AR5418 (Linksys WMP300N) Asus NVidia NForce motherboard AMD64 X2 CPU

Hope anybody is able to solve this problem. I'm a programmer with 5+ years C/C++ experience, though never development within the Linux kernel. However if I can help, let me know.

Regards,

Jeroen

11/24/08 21:59:36 changed by hsteinhaus@gmx.de

The same effect occurs here on a small embedded system (Geode @ 233 MHz, 128MB RAM). The hardware contains a AR5211 chip using a RF5211 and a RF2111 phy (2 and 5 GHz). The kernel is a custom-built 2.6.26 using the madwifi 0.9.4 drivers.

After seeing the first messages of this type, the system appears very sluggish and finally reboots (maybe the watchdog triggers).

wifi0: FAILED verification of AR5K_PHY_SIG_FIRPWR default value [found=0xb0 (-80) expected=0xba (-70)].
              (unknown):0x9858:0x7ec00d2e:.111111. 11...... ....11.1 ..1.111.:unknown
wifi0: FAILED verification of AR5K_PHY_WEAK_CCK_THRESH default value [found=0x6 (6) expected=0x8 (8)].
              (unknown):0xa208:0x503e4646:.1.1.... ..11111. .1...11. .1...11.:unknown
wifi0: FAILED verification of AR5K_PHY_AGCSIZE_DESIRED default value [found=0xc2 (-62) expected=0xde (-34)].
              (unknown):0x9850:0x0c28b0da:....11.. ..1.1... 1.11.... 11.11.1.:unknown
wifi0: FAILED verification of AR5K_PHY_AGCCOARSE_LO default value [found=0xba (-70) expected=0xcc (-52)].
              (unknown):0x985c:0x313a5d5e:..11...1 ..111.1. .1.111.1 .1.1111.:unknown
wifi0: FAILED verification of AR5K_PHY_AGCCOARSE_HI default value [found=0x74 (-12) expected=0x6e (-18)].
              (unknown):0x985c:0x313a5d5e:..11...1 ..111.1. .1.111.1 .1.1111.:unknown
wifi0: FAILED verification of AR5K_PHY_SIG_FIRPWR default value [found=0xb0 (-80) expected=0xba (-70)].
              (unknown):0x9858:0x7ec00d2e:.111111. 11...... ....11.1 ..1.111.:unknown
wifi0: FAILED verification of AR5K_PHY_WEAK_CCK_THRESH default value [found=0x6 (6) expected=0x8 (8)].
              (unknown):0xa208:0x503e4646:.1.1.... ..11111. .1...11. .1...11.:unknown
wifi0: FAILED verification of AR5K_PHY_AGCSIZE_DESIRED default value [found=0xc2 (-62) expected=0xde (-34)].
              (unknown):0x9850:0x0c28b0da:....11.. ..1.1... 1.11.... 11.11.1.:unknown
wifi0: FAILED verification of AR5K_PHY_AGCCOARSE_LO default value [found=0xba (-70) expected=0xcc (-52)].
              (unknown):0x985c:0x313a5d5e:..11...1 ..111.1. .1.111.1 .1.1111.:unknown
wifi0: FAILED verification of AR5K_PHY_AGCCOARSE_HI default value [found=0x74 (-12) expected=0x6e (-18)].
              (unknown):0x985c:0x313a5d5e:..11...1 ..111.1. .1.111.1 .1.1111.:unknown

11/25/08 10:56:45 changed by sven

Hi,

i can reproduce this issue on windows vista and windows xp. on suse linux and ubuntu. I think in my case it is a hardware defect.

cheers sven

12/14/08 20:43:00 changed by Kodemonk

I tried something radical, and seems to work...

Just set a return on ath/.svn/text-base/if_ath_hal_extensions.h.svn-base

static inline void verification_warning(struct ath_hal *ah, const char *name,
    u_int32_t reg, u_int32_t mask,
    u_int32_t shift, u_int32_t expected, int is_signed) {
        return; <--------------------------- ADDED !!!!!!!!!

        int ret = field_eq(ah, reg, mask, shift, expected, is_signed);
        if (!ret) {
                printk("%s: %s verification of %s default value "
                       "[found=0x%x (%d) expected=0x%x (%d)].\n",
                       SC_DEV_NAME(ah->ah_sc),
                       (ret ? "PASSED" : "FAILED"),
                        name,
                       (get_field(ah, reg, mask, shift, is_signed) & (mask >> shift)),
                       get_field(ah, reg, mask, shift, is_signed),
                       (expected & (mask >> shift)), /* not sign extended */
                       expected);
                ath_hal_print_decoded_register(ah, NULL, reg,
                                               OS_REG_READ(ah, reg), OS_REG_READ(ah, reg), 0);
        }
}

So far, so good ;D

(in reply to: ↑ description ) 06/27/09 00:51:12 changed by xin.e.liu@gmail.com

I have have similar problem. In my case, I use linux kernel 2.6.29 madwifi latest svn source code AR5418 chipset

When I set the card to monitor mode directly, system freezes immediately. What I do is, I first set the card into sta mode, then set it into monitor mode without destroying the vap. After that, I destroy the interface. Then I set the card into monitor mode. It works and system doesn't freeze immediately.

However, if I switch the channel during monitoring, I get a lot of warning messages like

wifi1: FAILED verification of AR5K_PHY_SIG_FIRPWR default value [found=0x0 (0) expected=0xba (-70)].
              (unknown):0x9858:0x00000d2e:........ ........ ....11.1 ..1.111.:unknown
wifi1: FAILED verification of AR5K_PHY_WEAK_OFDM_HIGH_M1 default value [found=0x4d (77) expected=0x4d (77)].
              (unknown):0x9868:0x409a4190:.1...... 1..11.1. .1.....1 1..1....:unknown

Then, randomly, after sometime, system freezes. Sometimes several minutes, sometimes several hours. I don't know what exactly causes this problem.

Leo

Replying to tigerwolf@tigerden.com:

Machine hard freezes requiring power cycle reboot. No error messages, just total lock-up. Freezes seem random, but operation longer than a few minutes has never been observed. Freezes do not appear to be related to amount of network traffic. Both 0.9.3.3 and ng-r3036 act the same. Freezes happen on the following machines (several identical models tried to rule out hardware): - Hitachi Visiondesk 1120 - 450MHz K6-2 CPU w/ 256meg Ram - Linux 2.6.18 or 2.6.20 kernels both 'stock' or custom compiled kernels. - Distro is Vector Linux 5.8 (Slackware 10 based) with latest updates. Both Netgear and Trendnet PCI cards, both with 5212 chips, show identical behavior. Machines work fine with Hawking (TI chip/acx111 driver) or Zyxel (Atheros AR5005VL chip/ndiswrapper) type cards. I've read other tickets regarding hard freezes, so this does appear to be a non-trivial issue. I am not a programmer type, but am willing to try to provide additional info if you can describe what to look for.