Please note: This project is no longer active. The website is kept online for historic purposes only.
If you´re looking for a Linux driver for your Atheros WLAN device, you should continue here .

Ticket #1684 (new defect)

Opened 14 years ago

Madwifi driver doesn't work with HTB (Hierarchical Token Bucket)

Reported by: lzbroszczyk@proximetry.com Assigned to:
Priority: major Milestone:
Component: madwifi: driver Version: v0.9.3.3
Keywords: HTB Shaping Cc:
Patch is attached: 0 Pending:

Description

I've tried to use HTB with madwifi driver and it's some kind broken. Without any HTB queue i got ~3.5MB/s transfer rate and when i apply one queue i can get max ~1.2-1.3MB/s, on standard burst/cburst parameter. when i increase these parameters like 10-100 times i will get my 3.5MB/s but you loose control over the flow. I test it with ubiquti cards SR2,SR4,SR5. When i try to do that with intel wifi card with driver from linux kernel there was no problem, everything worked as expected(on default values of burst/cburst). If you got any questions i will gladly answer.