Please note: This project is no longer active. The website is kept online for historic purposes only.
If you´re looking for a Linux driver for your Atheros WLAN device, you should continue here .

Ticket #1678 (new defect)

Opened 14 years ago

Last modified 14 years ago

No monitor mode traffic

Reported by: initrage@gmail.com Assigned to:
Priority: major Milestone:
Component: madwifi: driver Version: v0.9.3.3
Keywords: ettercap,monitor,ath2 Cc: initrage@gmail.com
Patch is attached: 0 Pending:

Description (Last modified by mrenzmann)

I run slackware 12.0. I had compiled and installed a new kernel (2.6.23.9) and used the old config to build it with minimal configuration changes. Everything is detected ok. Once I booted the new kernel I make clean'd and recompiled and make install'd the latest madwifi drivers downloaded here. After a reboot (testing module autoload) I found that the ath0 device didn't exist. Ath2 was the first device to be created.

I thought I would mention this as it might be linked to the problem I have with ettercap for monitoring my traffic. Using the same basic parameters on my pcmcia device I can sniff traffic with no problem. However switching to the ath2 interface run without error but doesn't receive any packets! Of course before running ettercap I:

  1. destroyed ath2
  2. recreated it using: wlanconfig ath create wlandev wifi0 wlanmode monitor
    • the output of this command was ath0 but the only athX created was ath2.
  3. ifconfig ath2 up
  4. echo '801' > /proc/sys/net/ath2/dev_type
    • apparently default are Prism headers so I have to change this to 802.11 headers or ettercap will fail immediately.
  5. ettercap -T -V hex -u -i ath2 // //

I get no received packets! However when I do this with my cheap pcmcia network card it works just fine. Im assuming I'm either missing something important or that lack of ath0 is the cause of this problem. Below are some interesting bits from dmesg after boot:

net ath2: device_rename: sysfs_create_symlink failed (-17)

Any ideas?

Change History

12/04/07 15:52:08 changed by mentor

  • summary changed from first device is ath2. fails to monitor traffic to No monitor mode traffic.

I'm going to go ahead and blame udev for the interface name problem. There is documentation about this on the wiki.

As to the second, would you try and reproduce with trunk?

12/04/07 17:13:42 changed by mrenzmann

  • description changed.

02/21/08 19:53:31 changed by initrage@gmail.com

Ok I forgot to reply back when I solved the problem with ettercap. Luckily I found this randomly while searching for udev bugs in slackware. I solved the problem with ettercap. The issue was that for SOME reason running ifconfig ath2 up didn't actually bring the interface up. ifconfig ath2 down followed by ifconfig ath2 up did the trick.

I have no idea why this would or should matter. In the case when I just boot up ifconfig ath2 down followed by up does NOT work. ifconfig ath2 up will work! After this, only bringing it down then up again will work for subsequent use.

And I still have that udev problem. Not sure exactly how to fix that one yet.