Please note: This project is no longer active. The website is kept online for historic purposes only.
If you´re looking for a Linux driver for your Atheros WLAN device, you should continue here .

Ticket #1669 (new enhancement)

Opened 14 years ago

Last modified 13 years ago

Patch for supporting dynamic turbo channels in 802.11g mode

Reported by: s.gottschall@newmedia-net.de Assigned to:
Priority: minor Milestone:
Component: madwifi: driver Version: trunk
Keywords: Cc:
Patch is attached: 1 Pending:

Description (Last modified by mrenzmann)

iwpriv ath0 mode 6 will enable support for dynamic turbo-g channels
iwpriv ath0 mode 7 will enable support for dynamic turbo-a channels

Signed-off-by: Sebastian Gottschall <s.gottschall@newmedia-net.de>

Attachments

turbog_support.diff (0.9 kB) - added by s.gottschall@newmedia-net.de on 11/27/07 23:59:01.
patch for enabling turbog support

Change History

11/27/07 23:59:01 changed by s.gottschall@newmedia-net.de

  • attachment turbog_support.diff added.

patch for enabling turbog support

11/28/07 10:00:00 changed by mrenzmann

  • patch_attached set to 1.
  • description changed.

12/04/07 10:07:03 changed by ck

I did try to add this patch, but I still cannot enable turbo a / g it always shows as following

Interface doesn't accept private ioctl... mode (8BF1): No such device or address

hmmmmmm, has it something to do with the HAL?

01/13/08 17:38:26 changed by vank@cn.inetsysinc.com

hello, i added this path, and it seems doesn't work.., i had tried several times, there is not any error on the screen. when I use iwconfig ath0 to see the detail, it still shows 802g mode ,i can't see "Tg" , thank you very much !

03/05/08 02:00:06 changed by anonymous

Does anyone know if this patch works?

(follow-up: ↓ 6 ) 07/27/08 03:10:43 changed by anonymous

I've tried to use the 108Mbps mode, using madwifi, and two turbo-g boards, without any success. I don't have tried the patch available here yet. But we can say that there is no useful document on that topic. Some sources says to do iwpriv turbo, and to change the iwpriv mode to 3... But, anyway when I use the 'netperf' benchmark command on udp packets, the maximum rate is always around 30Mbps, I've the same value with a non atheros board.

The wifi master I use, runs the openwrt (a linux distribution for embedded device), with the full madwifi driver, and windows displays a speed of 108Mbps with an atheros board. But anyway I can't have the maximum bitrate allowed with theses boards: around 60Mbps (udp packets)... The master is not the source of this problem. 'netperf' displays two values, the bitrate allowed by the driver, and the real bitrate that reach the target. Theses both values are at 30Mbps, from the laptop side. (and 100Mbps and 30Mbps from the target on an ethernet network).

Can we use a static 108Mbps configuration on the g band. And do you have any trustful documents on that topic ?

the 'airodump' command from aircrack package seems to display a dot "." on 108 enabled master, but anyway I don't have find any madwifi command that display the stations that are using this mode... If you have any source of information that will be helpful ?

(in reply to: ↑ 5 ) 07/27/08 07:55:30 changed by mrenzmann

Replying to anonymous:

Can we use a static 108Mbps configuration on the g band. And do you have any trustful documents on that topic ?

This subject is misplaced in the ticket tracker. Please forward your request to our regular support channels. Thanks.