Please note: This project is no longer active. The website is kept online for historic purposes only.
If you´re looking for a Linux driver for your Atheros WLAN device, you should continue here .

Ticket #1658 (new defect)

Opened 14 years ago

Last modified 13 years ago

false/ridiculous Qualitiy values with "iwlist athX scan"

Reported by: jan@saxnet.de Assigned to:
Priority: minor Milestone:
Component: madwifi: other Version: v0.9.3.3
Keywords: Cc:
Patch is attached: 0 Pending:

Description

Hi,

I'm using madwifi stable 0.9.3.3 on a 2.6.27-7 kernel with a voyage-image on a wrap board with wistron cm9 cards. When I try to scan how many other accesspoints are in my area, I get some crazy quality-values like 214/70. Strong accesspoints are shown correct, but weak APs are always shown with far too high values. But these values are fluctuating from the real quality-value (like Quality=10/70) to these abnormal high values. The same problem appears on the same hardware with an older 20.99 revcount madwifi.

I hope you can help us.

regards

Jan

Change History

12/01/08 23:05:52 changed by JaFojtik@seznam.cz

I confirm this bug:

ESSID:"default"
 Frequency:2.462 GHz (Channel 11)
 Quality=1/70  Signal level=162/162  Noise level=161/161

ESSID:"Internet"
 Frequency:2.412 GHz (Channel 1)
 Quality=4/70  Signal level=-91 dBm  Noise level=-95 dBm


ESSID:"MEDVEDNET"
 Frequency:2.447 GHz (Channel 8)
 Quality=2/70  Signal level=-93 dBm  Noise level=-95 dBm

ESSID:"perseus-dobeska.com"
 Frequency:2.457 GHz (Channel 10)
 Quality=254/70  Signal level=159/162  Noise level=161/161

04/18/09 12:46:22 changed by fojtik

I have found that this problem affects also other branches:

0.9.4, trunk, and free. (madwifi-free-r3975-20090407 madwifi-trunk-r3967-20090402)