Please note: This project is no longer active. The website is kept online for historic purposes only.
If you´re looking for a Linux driver for your Atheros WLAN device, you should continue here .

Ticket #1656 (new defect)

Opened 14 years ago

Last modified 14 years ago

Computer freezes after an unpredictable time under load

Reported by: ondra@spi-net.org Assigned to:
Priority: major Milestone:
Component: madwifi: driver Version: trunk
Keywords: Cc:
Patch is attached: 0 Pending:

Description (Last modified by mentor)

The two routers with this defect do freeze at least every few hours. A half day is only possible without load (at night). Under load the freeze occurs to half an hour.

I've been trying for a couple of weeks which madwifi driver version X kernel won't be doing this anymore. I am not sure whether this all is a madwifi bug, distro problem, or hardware issue. I however am completely without further ideas what to do so I'm begging for advice.

The first computer is a WRAP with two Atheros wireless cards (presently there are two CM11, but CM9 behave the same).

Debugging enabled:

dev.wifi0.debug: 0x800d01e0<reset,mode,beacon,watchdog,calibrate,state,node,fat>
dev.wifi1.debug: 0x800d01e0<reset,mode,beacon,watchdog,calibrate,state,node,fat>
net.ath0.debug: 0x00ec18c0<assoc,auth,scan,state,power,wpa,acl,inact,roam>
net.ath1.debug: 0x00ec18c0<assoc,auth,scan,state,power,wpa,acl,inact,roam>

Kernel version:

Linux ant 2.6.22.12-LARA-WRAP-router-debug #1
Tue Nov 13 20:38:46 CET 2007 i586 Unknown Geode by NSC GNU/Linux

I'm using MAC acl on both cards. No encryption enabled.

On both cards:

bgscan = 0
bintval = 350
mode = 11b
frag thr = 700
rts thr = 400

The streangest thing seems to me, that the problems started approx two weeks ago. There was no change in anything effecting the computers except the temperature lowered. The environment of our network is very noisy for many other stations are running there. Diversity is disabled in the following way (sysctl.conf lines):

dev.wifi0.diversity = 0
dev.wifi0.rxantenna = 1
dev.wifi0.txantenna = 1

dev.wifi1.diversity = 0
dev.wifi1.rxantenna = 1
dev.wifi1.txantenna = 1

this very unlikely to effected the wireless because of the problems were there before I set this up.

On every wireless card there is one AP VAP.

I have a notebook connected to the WRAP using a serial line. This way I'm able to log everything what the kernel outputs (right?). The output is datified but a bit ugly.

2007-11-19T14:29:53,021537310+0100:   319.305631] ath1: [00:19:e0:83:03:b3] UAPSD bit settings from STA: 00
2007-11-19T14:29:53,049195542+0100:   319.325370] ath1: [00:19:e0:83:03:b3] station reassociated at aid 1: long preamble, long slot time, QoS
2007-11-19T14:29:53,369318268+0100:   319.367880] ath0: [00:12:0e:34:71:34] probe station due to inactivity
2007-11-19T14:29:58,110120908+0100:   319.589790] ath_calibrate: channel 2442/a0
2007-11-19T14:30:09,899722218+0100:   324.165582] ath_rate_node_init:
2007-11-19T14:30:09,907372605+0100:   324.175157] ath_node_alloc: an c6a4a000
2007-11-19T14:30:10,855736191+0100:   324.219050] ath_calibrate: channel 2417/a0
2007-11-19T14:30:28,141993802+0100:   324.893553] ath_calibrate: channel 2442/a0
2007-11-19T14:30:40,875566492+0100:   325.360961] ath_calibrate: channel 2417/a0
2007-11-19T14:30:58,161792254+0100:   326.147186] ath_calibrate: channel 2442/a0
2007-11-19T14:31:09,883326548+0100:   326.573069] ath_rate_node_init:
2007-11-19T14:31:09,890977774+0100:   326.582652] ath_node_alloc: an c6477000
2007-11-19T14:31:10,907351380+0100:   326.623663] ath_calibrate: channel 2417/a0
2007-11-19T14:31:28,193630225+0100:   327.489202] ath_calibrate: channel 2442/a0
2007-11-19T14:31:40,927221076+0100:   327.930651] ath_calibrate: channel 2417/a0
2007-11-19T14:31:58,209427612+0100:   328.621374] ath_calibrate: channel 2442/a0
2007-11-19T14:32:10,947028469+0100:   329.362369] ath_calibrate: channel 2417/a0
2007-11-19T14:32:16,583753654+0100:   329.673277] ath_rate_node_init:
2007-11-19T14:32:16,591421643+0100:   329.682852] ath_node_alloc: an c6b4a000
2007-11-19T14:32:17,063800567+0100:   329.711476] ath_rate_node_init:
2007-11-19T14:32:17,075476605+0100:   329.721052] ath_node_alloc: an c65b4000
2007-11-19T14:32:17,935683190+0100:   329.759738] ath_rate_node_init:
2007-11-19T14:32:17,943579994+0100:   329.769303] ath_node_alloc: an c658f000
2007-11-19T14:32:18,539984983+0100:   329.801071] ath1: [00:19:e0:83:03:b3] recv auth frame with algorithm 0 seq 1
2007-11-19T14:32:18,555687233+0100:   329.822499] ath1: [00:19:e0:83:03:b3] station authenticated (open)
2007-11-19T14:32:18,580966226+0100:   329.841286] ath1: [00:19:e0:83:03:b3] UAPSD bit settings from STA: 00
2007-11-19T14:32:18,603814294+0100:   329.860926] ath1: [00:19:e0:83:03:b3] station reassociated at aid 1: long preamble, long slot time, QoS
2007-11-19T14:32:23,592605923+0100:   330.143899] ath0: [00:12:0e:34:71:34] probe station due to inactivity
2007-11-19T14:32:28,349180938+0100:   330.360755] ath_calibrate: channel 2442/a0
2007-11-19T14:32:41,086858346+0100:   330.891331] ath_calibrate: channel 2417/a0
2007-11-19T14:32:58,369036105+0100:   331.810120] ath_calibrate: channel 2442/a0
2007-11-19T14:33:09,902498779+0100:   332.617203] ath_rate_node_init:
2007-11-19T14:33:09,910182972+0100:   332.626802] ath_node_alloc: an c6492000
2007-11-19T14:33:11,118594062+0100:   332.895805] ath_calibrate: channel 2417/a0
2007-11-19T14:33:28,400832168+0100:   335.731554] ath_calibrate: channel 2442/a0
2007-11-19T14:33:35,649778298+0100:   336.092020] ath1: [00:19:e0:83:03:b3] UAPSD bit settings from STA: 00
2007-11-19T14:33:35,677435971+0100:   336.111728] ath1: [00:19:e0:83:03:b3] station reassociated at aid 1: long preamble, long slot time, QoS
2007-11-19T14:33:41,178412954+0100:   336.585516] ath_calibrate: channel 2417/a0
2007-11-19T14:33:58,460643238+0100:   337.967540] ath_calibrate: channel 2442/a0
2007-11-19T14:33:59,668819087+0100:   338.121221] ath1: [00:19:e0:83:03:b3] UAPSD bit settings from STA: 00
2007-11-19T14:33:59,696495757+0100:   338.140936] ath1: [00:19:e0:83:03:b3] station reassociated at aid 1: long preamble, long slot time, QoS
2007-11-19T14:34:11,238550345+0100:   339.086016] ath_calibrate: channel 2417/a0
2007-11-19T14:34:37,645653747+0100: C Engines WRAP.1C/1D/1E v1.11
2007-11-19T14:34:37,653408904+0100: 40 KB Base Memory
2007-11-19T14:34:40,789982115+0100: 15360
31744
48128
64512
80896
97280
113664
130048 KB Extended Memory
2007-11-19T14:34:40,793117089+0100: 
2007-11-19T14:34:40,809723986+0100: 1F0 Master 0000 KCF256M-KT3                             
2007-11-19T14:34:40,821713774+0100: hys C/H/S 503/16/63 Log C/H/S 503/16/63
2007-11-19T14:34:40,877706069+0100: 
2007-11-19T14:34:42,878327691+0100: ILO 22.7.3 boot: 
2007-11-19T14:34:43,150218028+0100: oading linux-2.6.22.12
2007-11-19T14:34:43,157987433+0100: IOS data check successful
2007-11-19T14:34:47,810918044+0100:     0.000000] Linux version 2.6.22.12-LARA-WRAP-router-debug (root@charon) (gcc version 4.2.2 (Gentoo 4.2.2 p1.0)) #1 Tue Nov 13 20:38:46 CET 2007
2007-11-19T14:34:47,822641858+0100:     0.000000] BIOS-provided physical RAM map:
2007-11-19T14:34:47,842612825+0100:     0.000000]  BIOS-e820: 0000000000000000 - 00000000000a0000 (usable)
2007-11-19T14:34:47,862594128+0100:     0.000000]  BIOS-e820: 00000000000f0000 - 0000000000100000 (reserved)
2007-11-19T14:34:47,882635499+0100:     0.000000]  BIOS-e820: 0000000000100000 - 0000000008000000 (usable)
2007-11-19T14:34:47,902619317+0100:     0.000000]  BIOS-e820: 00000000fff00000 - 0000000100000000 (reserved)
2007-11-19T14:34:47,910639609+0100:     0.000000] 128MB LOWMEM available.
2007-11-19T14:34:47,934651035+0100:     0.000000] Entering add_active_range(0, 0, 32768) 0 entries of 256 used
2007-11-19T14:34:47,942615171+0100:     0.000000] Zone PFN ranges:
2007-11-19T14:34:47,954636250+0100:     0.000000]   DMA             0 ->     4096
2007-11-19T14:34:47,966643919+0100:     0.000000]   Normal       4096 ->    32768
2007-11-19T14:34:47,978627001+0100:     0.000000] early_node_map[1] active PFN ranges
2007-11-19T14:34:47,990638022+0100:     0.000000]     0:        0 ->    32768
2007-11-19T14:34:48,002647087+0100:     0.000000] On node 0 totalpages: 32768
2007-11-19T14:34:48,014833841+0100:     0.000000]   DMA zone: 32 pages used for memmap
2007-11-19T14:34:48,030648125+0100:     0.000000]   DMA zone: 0 pages reserved
2007-11-19T14:34:48,042642662+0100:     0.000000]   DMA zone: 4064 pages, LIFO batch:0
2007-11-19T14:34:48,054633847+0100:     0.000000]   Normal zone: 224 pages used for memmap
2007-11-19T14:34:48,070646773+0100:     0.000000]   Normal zone: 28448 pages, LIFO batch:7
2007-11-19T14:34:48,082653881+0100:     0.000000] DMI not present or invalid.
2007-11-19T14:34:48,106642118+0100:     0.000000] Allocating PCI resources starting at 10000000 (gap: 08000000:f7f00000)
2007-11-19T14:34:48,122639678+0100:     0.000000] Built 1 zonelists.  Total pages: 32512
2007-11-19T14:34:48,158652626+0100:     0.000000] Kernel command line: auto BOOT_IMAGE=linux-2.6.22.12 ro root=302 console=ttyS0,38400 panic=7 reboot=bios debug acpi=off noapic
2007-11-19T14:34:48,174658845+0100:     0.000000] No local APIC present or hardware disabled
2007-11-19T14:34:48,186686629+0100:     0.000000] mapped APIC to ffffd000 (01101000)
2007-11-19T14:34:48,194675910+0100:     0.000000] Initializing CPU#0
2007-11-19T14:34:48,210751697+0100:     0.000000] PID hash table entries: 512 (order: 9, 2048 bytes)
2007-11-19T14:34:48,226660971+0100:     0.000000] Detected 233.319 MHz processor.
2007-11-19T14:34:48,238690990+0100:    12.200547] Console: colour dummy device 80x25
2007-11-19T14:34:48,258677602+0100:    12.666522] Dentry cache hash table entries: 16384 (order: 4, 65536 bytes)
2007-11-19T14:34:48,282641252+0100:    12.688366] Inode-cache hash table entries: 8192 (order: 3, 32768 bytes)
2007-11-19T14:34:48,350712739+0100:    12.749019] Memory: 126964k/131072k available (1463k kernel code, 3708k reserved, 681k data, 140k init, 0k highmem)
2007-11-19T14:34:48,366697447+0100:    12.780473] virtual kernel memory layout:
2007-11-19T14:34:48,382711489+0100:    12.780502]     fixmap  : 0xfffbc000 - 0xfffff000   ( 268 kB)
2007-11-19T14:34:48,398684463+0100:    12.780539]     vmalloc : 0xc8800000 - 0xfffba000   ( 887 MB)
2007-11-19T14:34:48,418715497+0100:    12.780577]     lowmem  : 0xc0000000 - 0xc8000000   ( 128 MB)
2007-11-19T14:34:48,434698808+0100:    12.780615]       .init : 0xc031c000 - 0xc033f000   ( 140 kB)
2007-11-19T14:34:48,451117679+0100:    12.780653]       .data : 0xc026dc1d - 0xc0318044   ( 681 kB)
2007-11-19T14:34:48,470713153+0100:    12.780690]       .text : 0xc0100000 - 0xc026dc1d   (1463 kB)
2007-11-19T14:34:48,494667024+0100:    12.896006] Checking if this processor honours the WP bit even in supervisor mode... Ok.
2007-11-19T14:34:48,600015115+0100:    13.001623] Calibrating delay using timer specific routine.. 467.55 BogoMIPS (lpj=935101)
2007-11-19T14:34:48,614729461+0100:    13.026818] Mount-cache hash table entries: 512
2007-11-19T14:34:48,646758944+0100:    13.041587] CPU: After generic identify, caps: 00808131 01818131 00000000 00000000 00000000 00000000 00000000
2007-11-19T14:34:48,674730924+0100:    13.071948] CPU: After all inits, caps: 00808131 00818131 00000000 00000001 00000000 00000000 00000000
2007-11-19T14:34:48,686745857+0100:    13.100463] Compat vDSO mapped to ffffe000.
2007-11-19T14:34:48,698737600+0100:    13.113109] CPU: NSC Unknown stepping 01
2007-11-19T14:34:48,722668563+0100:    13.125110] Checking 'hlt' instruction... OK.
2007-11-19T14:34:48,738691267+0100:    13.140672] NET: Registered protocol family 16
2007-11-19T14:34:48,762742645+0100:    13.157181] PCI: PCI BIOS revision 2.10 entry at 0xfc47b, last bus=0
2007-11-19T14:34:48,774739417+0100:    13.176326] PCI: Using configuration type 1
2007-11-19T14:34:48,786705737+0100:    13.188911] Setting up standard PCI resources
2007-11-19T14:34:48,822733771+0100:    13.223832] PCI: Probing PCI hardware
2007-11-19T14:34:48,834707634+0100:    13.234911] PCI: Probing PCI hardware (bus 00)
2007-11-19T14:34:48,858686652+0100:    13.258809] PCI: Device 0000:00:12.5 not found by BIOS
2007-11-19T14:34:48,878739477+0100:    13.276982] Time: tsc clocksource has been installed.
2007-11-19T14:34:48,894727537+0100:    13.296071] NET: Registered protocol family 2
2007-11-19T14:34:48,950756153+0100:    13.310005] IP route cache hash table entries: 1024 (order: 0, 4096 bytes)
2007-11-19T14:34:48,970763160+0100:    13.331271] TCP established hash table entries: 4096 (order: 3, 32768 bytes)
2007-11-19T14:34:48,994760895+0100:    13.352831] TCP bind hash table entries: 4096 (order: 2, 16384 bytes)
2007-11-19T14:34:49,010979448+0100:    13.372398] TCP: Hash tables configured (established 4096 bind 4096)
2007-11-19T14:34:49,022731759+0100:    13.391505] TCP reno registered
2007-11-19T14:34:49,042764469+0100:    13.402877] scx200: NatSemi SCx200 Driver
2007-11-19T14:34:49,054805105+0100:    13.415570] scx200: GPIO base 0xf400
2007-11-19T14:34:49,070789534+0100:    13.426452] scx200: Configuration Block base 0x9000
2007-11-19T14:34:49,086769491+0100:    13.442672] audit: initializing netlink socket (disabled)
2007-11-19T14:34:49,102807002+0100:    13.459029] audit(946744412.416:1): initialized
2007-11-19T14:34:49,114792879+0100:    13.474579] io scheduler noop registered
2007-11-19T14:34:49,130739311+0100:    13.486469] io scheduler anticipatory registered (default)
2007-11-19T14:34:49,814959333+0100:    14.172367] Real Time Clock Driver v1.12ac
2007-11-19T14:34:49,823005049+0100:    14.184947] nsc_gpio initializing
2007-11-19T14:34:49,834912419+0100:    14.195052] cs5535_gpio: DIVIL not found
2007-11-19T14:34:49,858885010+0100:    14.206893] Serial: 8250/16550 driver $Revision: 1.90 $ 4 ports, IRQ sharing disabled
2007-11-19T14:34:49,878854020+0100:    14.230733] serial8250: ttyS0 at I/O 0x3f8 (irq = 4) is a NS16550A
2007-11-19T14:34:49,906894171+0100:    14.256322] Uniform Multi-Platform E-IDE driver Revision: 7.00alpha2
2007-11-19T14:34:49,930897215+0100:    14.275525] ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
2007-11-19T14:34:49,946888628+0100:    14.300001] SC1200: IDE controller at PCI slot 0000:00:12.2
2007-11-19T14:34:49,954894951+0100:    14.316841] SC1200: chipset revision 1
2007-11-19T14:34:49,974885474+0100:    14.328145] SC1200: not 100% native mode: will probe irqs later
2007-11-19T14:34:49,994893040+0100:    14.345992]     ide0: BM-DMA at 0xfc00-0xfc07, BIOS settings: hda:pio, hdb:pio
2007-11-19T14:34:50,019105064+0100:    14.367927]     ide1: BM-DMA at 0xfc08-0xfc0f, BIOS settings: hdc:pio, hdd:pio
2007-11-19T14:34:50,030885593+0100:    14.389834] Probing IDE interface ide0...
2007-11-19T14:34:50,134875036+0100:    14.411358] Clocksource tsc unstable (delta = 90345007 ns)
2007-11-19T14:34:50,154876176+0100:    14.427918] Time: pit clocksource has been installed.
2007-11-19T14:34:50,478992704+0100:    14.445576] hda: KCF256M-KT3, ATA DISK drive
2007-11-19T14:34:51,159319783+0100:    14.463437] hda: selected mode 0x42
2007-11-19T14:34:51,175040192+0100:    14.473969] hda: sc1200_set_xfer_mode(UDMA 2)
2007-11-19T14:34:51,187057359+0100:    14.487321] ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
2007-11-19T14:34:51,199036531+0100:    14.501847] Probing IDE interface ide1...
2007-11-19T14:34:51,779141666+0100:    14.528802] Probing IDE interface ide1...
2007-11-19T14:34:52,359490425+0100:    14.554271] hda: max request size: 128KiB
2007-11-19T14:34:52,383197601+0100:    14.566406] hda: 507024 sectors (259 MB) w/0KiB Cache, CHS=503/16/63, UDMA(33)
2007-11-19T14:34:52,391189116+0100:    14.588768]  hda: hda1 hda2
2007-11-19T14:34:52,407212938+0100:    14.601695] i8042.c: No controller found.
2007-11-19T14:34:52,423192337+0100:    14.614399] mice: PS/2 mouse device common for all mice
2007-11-19T14:34:52,439213085+0100:    14.630874] enabling scx200 high-res timer (1 MHz +0 ppm)
2007-11-19T14:34:52,451645419+0100:    14.647374] TCP cubic registered
2007-11-19T14:34:52,467210491+0100:    14.657130] Time: scx200_hrt clocksource has been installed.
2007-11-19T14:34:52,479256434+0100:    14.674179] Initializing XFRM netlink socket
2007-11-19T14:34:52,491226665+0100:    14.687174] NET: Registered protocol family 1
2007-11-19T14:34:52,507225901+0100:    14.700353] NET: Registered protocol family 17
2007-11-19T14:34:52,519204793+0100:    14.713778] Using IPI Shortcut mode
2007-11-19T14:34:52,539244767+0100:    14.729799] kjournald starting.  Commit interval 5 seconds
2007-11-19T14:34:52,559264905+0100:    14.746453] EXT3-fs: mounted filesystem with ordered data mode.
2007-11-19T14:34:52,575234246+0100:    14.764378] VFS: Mounted root (ext3 filesystem) readonly.
2007-11-19T14:34:52,591196044+0100:    14.782332] Freeing unused kernel memory: 140k freed
2007-11-19T14:34:52,695217617+0100: INIT: version 2.86 booting 

The last message is different every time. Sometimes it's an reassociation request sometimes the channel calibrate.

Change History

11/19/07 22:40:22 changed by strasak@bubakov.net

Do you use latest trunk version? There has been bugs in refcounting which caused kernel panics or even hard lockups, they seems to be fixed in very recent trunk.

(follow-up: ↓ 5 ) 11/20/07 22:13:49 changed by Ondřej Vostal <ondra@spi-net.org>

I knew I'll forget something. The version I used wasn't the latest trunk somewhere aroung 2700. Anyway I tried the latest trunk available r2859 but the computer froze again.

The debugging config is somehow different so I must first figure out what configuration won't output more info than the router is able to stand. I'll post the kernel messages as soon I'll get them.

And thanks for the reply.

I'll try the old madwifi now (0.9.2.1). Maybe they'll work.

11/21/07 04:44:16 changed by mentor

  • priority changed from minor to major.

11/21/07 04:45:14 changed by mentor

  • description changed.

(in reply to: ↑ 2 ; follow-up: ↓ 6 ) 11/21/07 21:57:03 changed by Ondřej Vostal <ondra@spi-net.org>

Kernel version:

Linux ant 2.6.22.12-LARA-WRAP-router-debug #1
Tue Nov 13 20:38:46 CET 2007 i586 Unknown Geode by NSC GNU/Linux

Madwifi (from modinfo):

version:        0.9.3.2
srcversion:     F1ED01FDEFF40A3C458CC49
vermagic:       2.6.22.12-LARA-WRAP-router-debug mod_unload GEODEGX1

The same behaviour as observed with the other versions.

Now I installed 0.9.2.1 with 2.6.16 kernel; and trying...

(in reply to: ↑ 5 ) 11/22/07 18:59:33 changed by Ondřej Vostal <ondra@spi-net.org>

This time there is some kernel backtrace:

[  177.144125] Unable to handle kernel paging request at virtual address 000866ac
[  177.166204]  printing eip:
[  177.174432] 000866ac
[  177.181111] *pde = 00000000
[  177.189607] Oops: 0000 [#1]
[  177.198022] Modules linked in: bridge wlan_acl wlan_scan_ap genrtc ath_pci ath_rate_sample wlan ath_hal scx200_gpio scx200_wdt
[  177.232761] CPU:    0
[  177.232782] EIP:    0060:[<000866ac>]    Tainted: P      VLI
[  177.232820] EFLAGS: 00010246   (2.6.16-LARA-WRAP-router-debug #6) 
[  177.275136] EIP is at 0x866ac
[  177.284091] eax: 0000000a   ebx: c66ada20   ecx: c66ada20   edx: c02c1b14
[  177.304487] esi: 00000000   edi: 00000000   ebp: 0000000a   esp: c02c1acc
[  177.324864] ds: 007b   es: 007b   ss: 0068
[  177.337195] Process swapper (pid: 0, threadinfo=c02c0000 task=c02842a0)
[  177.356544] Stack: <0>c01256c5 0000000a 0007e6ce c02c1b14 c02c1b14 c02bcb70 0000000a c66ada20 
[  177.383448]        c02c1b14 c0125744 c02c1b14 ffffff0a c66eba48 c660f2c0 c0104a5e ffffffff 
[  177.409002]        c652a4e4 c010338a ffffffff 3ffedf78 000002be c652a4e4 c66eba48 c660f2c0 
[  177.434557] Call Trace:
[  177.441968]  [<c01256c5>] handle_IRQ_event+0x22/0x4e
[  177.457088]  [<c0125744>] __do_IRQ+0x53/0x8f
[  177.470078]  [<c0104a5e>] do_IRQ+0x46/0x54
[  177.482551]  [<c010338a>] common_interrupt+0x1a/0x20
[  177.497646]  [<c887dd42>] ieee80211_encap+0xc33/0xdc9 [wlan]
[  177.515243]  [<c88a5f9a>] ath_hardstart+0xada/0xcf0 [ath_pci]
[  177.532815]  [<c01059cb>] timer_interrupt+0x48/0x69
[  177.547663]  [<c88a5437>] ath_intr+0x919/0x9a2 [ath_pci]
[  177.563883]  [<c01ddf51>] qdisc_restart+0xb0/0x146
[  177.578434]  [<c01d5666>] dev_queue_xmit+0xba/0x19f
[  177.593251]  [<c887d0c3>] ieee80211_hardstart+0x2c9/0x315 [wlan]
[  177.611824]  [<c01d56bd>] dev_queue_xmit+0x111/0x19f
[  177.626916]  [<c88b0d9b>] br_dev_queue_push_xmit+0xd3/0xda [bridge]
[  177.646024]  [<c88b4998>] br_nf_post_routing+0x14a/0x159 [bridge]
[  177.664589]  [<c88b0cc8>] br_dev_queue_push_xmit+0x0/0xda [bridge]
[  177.683375]  [<c01ea3f8>] nf_iterate+0x2c/0x5e
[  177.696896]  [<c88b0cc8>] br_dev_queue_push_xmit+0x0/0xda [bridge]
[  177.715693]  [<c88b0cc8>] br_dev_queue_push_xmit+0x0/0xda [bridge]
[  177.734481]  [<c01ea5e8>] nf_hook_slow+0x3e/0xb6
[  177.748533]  [<c88b0cc8>] br_dev_queue_push_xmit+0x0/0xda [bridge]
[  177.767327]  [<c88b0dd0>] br_forward_finish+0x2e/0x41 [bridge]
[  177.785081]  [<c88b0cc8>] br_dev_queue_push_xmit+0x0/0xda [bridge]
[  177.803869]  [<c88b4849>] br_nf_forward_finish+0xc4/0xc9 [bridge]
[  177.822408]  [<c88b4fe2>] br_nf_forward_ip+0x11d/0x12f [bridge]
[  177.840427]  [<c88b0da2>] br_forward_finish+0x0/0x41 [bridge]
[  177.857915]  [<c01ea3f8>] nf_iterate+0x2c/0x5e
[  177.871438]  [<c88b0da2>] br_forward_finish+0x0/0x41 [bridge]
[  177.888935]  [<c88b0da2>] br_forward_finish+0x0/0x41 [bridge]
[  177.906422]  [<c01ea5e8>] nf_hook_slow+0x3e/0xb6
[  177.920474]  [<c88b0da2>] br_forward_finish+0x0/0x41 [bridge]
[  177.937969]  [<c88b0e29>] __br_forward+0x46/0x57 [bridge]
[  177.954422]  [<c88b0da2>] br_forward_finish+0x0/0x41 [bridge]
[  177.971910]  [<c88b1856>] br_handle_frame_finish+0xb2/0xea [bridge]
[  177.990977]  [<c88b4de9>] br_nf_pre_routing_finish+0x290/0x29b [bridge]
[  178.011093]  [<c88b4b59>] br_nf_pre_routing_finish+0x0/0x29b [bridge]
[  178.030660]  [<c01ea5e8>] nf_hook_slow+0x3e/0xb6
[  178.044710]  [<c88b4b59>] br_nf_pre_routing_finish+0x0/0x29b [bridge]
[  178.064313]  [<c88b5970>] br_nf_pre_routing+0x658/0x688 [bridge]
[  178.082613]  [<c88b597f>] br_nf_pre_routing+0x667/0x688 [bridge]
[  178.100918]  [<c88b17a4>] br_handle_frame_finish+0x0/0xea [bridge]
[  178.119703]  [<c01ea3f8>] nf_iterate+0x2c/0x5e
[  178.133225]  [<c88b17a4>] br_handle_frame_finish+0x0/0xea [bridge]
[  178.152019]  [<c88b17a4>] br_handle_frame_finish+0x0/0xea [bridge]
[  178.170809]  [<c01ea5e8>] nf_hook_slow+0x3e/0xb6
[  178.184859]  [<c88b17a4>] br_handle_frame_finish+0x0/0xea [bridge]
[  178.203655]  [<c88b19d8>] br_handle_frame+0x14a/0x18e [bridge]
[  178.221408]  [<c88b17a4>] br_handle_frame_finish+0x0/0xea [bridge]
[  178.240205]  [<c01d3e18>] netif_receive_skb+0x10b/0x1c5
[  178.256055]  [<c01b99a9>] intr_handler+0x2f5/0x50b
[  178.270644]  [<c01d5423>] process_backlog+0x6c/0xd5
[  178.285464]  [<c01d54df>] net_rx_action+0x53/0xda
[  178.299761]  [<c0113a57>] __do_softirq+0x34/0x7f
[  178.313795]  [<c0113ac4>] do_softirq+0x22/0x26
[  178.327310]  [<c0104a63>] do_IRQ+0x4b/0x54
[  178.339791]  [<c010338a>] common_interrupt+0x1a/0x20
[  178.354883]  [<c0101748>] default_idle+0x2b/0x53
[  178.368907]  [<c01017a8>] cpu_idle+0x38/0x4d
[  178.381899]  [<c02c25ab>] start_kernel+0x212/0x214
[  178.396464] Code:  Bad EIP value.
[  178.406531]  <0>Kernel panic - not syncing: Fatal exception in interrupt
[  178.427222]  <0>Rebooting in 7 seconds..PC Engines WRAP.1C/1D/1E v1.11

Now I'm trying to replace the WRAP with normal (old) computer. There are some problems: rebooting, panics; apparantly they are but not originating from madwifi drivers.