Please note: This project is no longer active. The website is kept online for historic purposes only.
If you´re looking for a Linux driver for your Atheros WLAN device, you should continue here .

Ticket #1586 (reopened defect)

Opened 14 years ago

Last modified 14 years ago

Problem with MadWifi and (?) Reiser4

Reported by: anonymous Assigned to:
Priority: minor Milestone:
Component: madwifi: driver Version: trunk
Keywords: Cc:
Patch is attached: 0 Pending:

Description

After modprobe ath_pci, i obtain this kind of kernel oops, when i'm lucky... or kernel panic. This is happens after i create a vap for monitor mode.

No oops or kernel panic occurs when ath:pci is not loaded.

kernel: linux-2.6.22-kamikaze9 System: gentoo 2007.0 desktop Madwifi version: trunk (12 october)

BUG: unable to handle kernel paging request at virtual address 003e0042
 printing eip:
c01f3adc
*pde = 00000000
Oops: 0002 [#1]
PREEMPT
Modules linked in: wlan_scan_sta ath_rate_minstrel ath_pci wlan ath_hal(P) hwmon_vid snd_pcm_oss snd_mixer_oss nvidia(P) tuner tvaudio bttv video_buf ir_common btcx_risc tveeprom snd_emu10k1 snd_rawmidi firmware_class snd_ac97_codec ac97_bus snd_pcm snd_timer snd_page_alloc snd_util_mem snd_hwdep snd
CPU:    0
EIP:    0060:[<c01f3adc>]    Tainted: P       VLI
EFLAGS: 00010286   (2.6.22-kamikaze9 #10)
EIP is at blocknr_set_merge+0x9c/0x160
eax: f00fd408   ebx: e2c69f70   ecx: 003e003e   edx: f43a2100
esi: f00fd400   edi: f43a2100   ebp: f43a20e0   esp: da727bc8
ds: 007b   es: 007b   fs: 0000  gs: 0033  ss: 0068
Process runscript.sh (pid: 18297, ti=da726000 task=cca70f90 task.ti=da726000)
Stack: e2c69f00 f00fda00 f00fda08 e2c69f70 e2c69ee0 f43a2170 f43a20e0 c01e7bd7
       f43a20e0 00000008 e2c69ee0 f5c64460 c01e86fc c02143f5 c01dd4aa 00000000
       00000001 00000000 d639483c 72742d73 00000000 00000000 d6394804 00000000
Call Trace:
 [<c01e7bd7>] capture_fuse_into+0x147/0x240
 [<c01e86fc>] reiser4_try_capture+0x4ec/0x9b0
 [<c02143f5>] pointer_at+0x5/0x10
 [<c01dd4aa>] get_htable+0xa/0x20
 [<c01e2220>] longterm_lock_znode+0x280/0x4c0
 [<c01f1362>] coord_by_handle+0x4f2/0xd80
 [<c01f1eb8>] reiser4_object_lookup+0xc8/0x110
 [<c01ff6f0>] find_file_item_nohint+0x50/0x60
 [<c01ff776>] find_file_state+0x76/0xc0
 [<c0200200>] read_unix_file+0x70/0x4f0
 [<c0112a01>] do_page_fault+0x321/0x5f0
 [<c0201520>] open_unix_file+0x0/0x1a0
 [<c0173669>] __dentry_open+0x169/0x1e0
 [<c0173795>] nameidata_to_filp+0x35/0x40
 [<c01793b0>] open_exec+0x90/0xb0
 [<c01757c1>] vfs_read+0xa1/0x140
 [<c0200190>] read_unix_file+0x0/0x4f0
 [<c017921d>] kernel_read+0x3d/0x60
 [<c01792ef>] prepare_binprm+0xaf/0xe0
 [<c017a892>] do_execve+0xd2/0x1b0
 [<c0100edf>] sys_execve+0x2f/0x90
 [<c01028ee>] sysenter_past_esp+0x5f/0x85
 =======================
Code: 04 89 3f eb b8 8b 4c 24 08 83 e8 08 89 44 24 04 8b 11 8b 41 04 89 10 89 42 04 89 09 8b 07 89 49 04 8b 37 8b 08 8b 50 04 83 ee 08 <89> 51 04 89 0a 89 40 04 89 00 8b 44 24 04 e8 f1 fb ff ff 85 c0
EIP: [<c01f3adc>] blocknr_set_merge+0x9c/0x160 SS:ESP 0068:da727bc8
note: runscript.sh[18297] exited with preempt_count 2
BUG: scheduling while atomic: runscript.sh/0x10000003/18297
 [<c0587e4a>] schedule+0x27a/0x370
 [<c011ba06>] __call_console_drivers+0x36/0x50
 [<c0117906>] __cond_resched+0x16/0x40
 [<c058811a>] cond_resched+0x2a/0x40
 [<c015fbc7>] unmap_vmas+0x477/0x4d0
 [<c0162e19>] exit_mmap+0x69/0xf0
 [<c0119802>] mmput+0x32/0xb0
 [<c011e8ab>] do_exit+0xfb/0x880
 [<c03a65bd>] do_unblank_screen+0x5d/0x150
 [<c0103e26>] die+0x206/0x210
 [<c01129b4>] do_page_fault+0x2d4/0x5f0
 [<c0120743>] tasklet_action+0x33/0x70
 [<c01126e0>] do_page_fault+0x0/0x5f0
 [<c0589b4a>] error_code+0x6a/0x70
 [<c01f3adc>] blocknr_set_merge+0x9c/0x160
 [<c01e7bd7>] capture_fuse_into+0x147/0x240
 [<c01e86fc>] reiser4_try_capture+0x4ec/0x9b0
 [<c02143f5>] pointer_at+0x5/0x10
 [<c01dd4aa>] get_htable+0xa/0x20
 [<c01e2220>] longterm_lock_znode+0x280/0x4c0
 [<c01f1362>] coord_by_handle+0x4f2/0xd80
 [<c01f1eb8>] reiser4_object_lookup+0xc8/0x110
 [<c01ff6f0>] find_file_item_nohint+0x50/0x60
 [<c01ff776>] find_file_state+0x76/0xc0
 [<c0200200>] read_unix_file+0x70/0x4f0
 [<c0112a01>] do_page_fault+0x321/0x5f0
 [<c0201520>] open_unix_file+0x0/0x1a0
 [<c0173669>] __dentry_open+0x169/0x1e0
 [<c0173795>] nameidata_to_filp+0x35/0x40
 [<c01793b0>] open_exec+0x90/0xb0
 [<c01757c1>] vfs_read+0xa1/0x140
 [<c0200190>] read_unix_file+0x0/0x4f0
 [<c017921d>] kernel_read+0x3d/0x60
 [<c01792ef>] prepare_binprm+0xaf/0xe0
 [<c017a892>] do_execve+0xd2/0x1b0
 [<c0100edf>] sys_execve+0x2f/0x90
 [<c01028ee>] sysenter_past_esp+0x5f/0x85
 =======================

Change History

10/15/07 02:28:44 changed by Maurs

Changed version kernel:

2.6.23 gentoo-sources + reiser4 patch. Problems are the same. When i start airodump-ng or kismet there are a lot of kernel oops!!!

10/16/07 06:49:10 changed by mrenzmann

I don't see any MadWifi-related function in the posted trace.

In addition, you say that the oops doesn't happen without MadWifi being loaded. Then you say that the oops occurs when you create a monitor VAP - you can't create a monitor VAP without MadWifi being loaded, obviously, so no big surprise here.

The fact that it's possible to trigger the oops through a MadWifi-related functionality does not necessarily mean the bug is CAUSED by MadWifi.

I might be wrong, but from what I see I'd say that this is no MadWifi bug, just one that MadWifi happens to trigger by accident.

10/16/07 14:00:59 changed by mrenzmann

  • status changed from new to closed.
  • resolution set to worksforme.

Closing as "worksforme" as suggested by IRC user schurig who talked to reporter on IRC:

13:52:43 < schurig> otaku42: please close 1586 :-)
13:54:01 < schurig> otaku42: he got an oops even when he did "ifconfig ath0 up", so it hasn't to do anything with monitor mode
13:54:23 < schurig> otaku42: so I would say it's a "not for me" bug, probably hardware, power supply, SDRAM
13:55:34 < schurig> otaku42: also, he doesn't always get the same oops, it varies, e.g. "segmentation violation" vs. "schedule in atomic context". That too sounds very fishy and not like an madwifi software problem

(follow-up: ↓ 5 ) 03/16/08 23:05:19 changed by Maurs

It was not a hardware problem.

Recentely i tried both ath5k and madwifi-ng drivers. With ath5k i have not any problem. With madwifi-ng I had got the same problems as first wrote in this ticket.

Pls, reopen it...

(in reply to: ↑ 4 ) 03/17/08 06:05:16 changed by mrenzmann

  • status changed from closed to reopened.
  • resolution deleted.

Replying to Maurs:

Pls, reopen it...

Done. Now please provide further information about your system and the steps that are required on your system to reproduce this issue.