Please note: This project is no longer active. The website is kept online for historic purposes only.
If you´re looking for a Linux driver for your Atheros WLAN device, you should continue here .

Ticket #1495 (closed defect: fixed)

Opened 12 years ago

Last modified 11 years ago

kernel oops when in bridging ath0 to eth0

Reported by: ken@glaserelectronics.com Assigned to:
Priority: major Milestone: version 0.9.5
Component: madwifi: driver Version: v0.9.3.1
Keywords: kernel oops panic bridge Cc:
Patch is attached: 0 Pending:

Description (Last modified by mrenzmann)

Cards tested: D-Link Air Premier AG (DWL-AG530) (PCI)

  • P/N: BDWLAG530.A3
  • H/W Ver: A3
  • F/W Ver: 1.00

Linksys Wireless A+G Notebook Adapter (PCMCIA)

  • dual-band (5GHz and 2.4GHz)
  • Model WPC55AG version 1.3
  • Cisco Systems logo

Software:

  • MadWifi 0.9.3.1 (release version)
  • Bridge Utilities v1.2
  • Kernel 2.6.21.5-smp (Slackware sources)

Compiled MadWifi separately for use on notebook computer running Slackware 12.0 kernel 2.6.21.5-smp.

Compiled custom kernel for Geode computer using Slackware sources with ath_pci patch compiled into kernel.

Following steps in bridge docs on website:

modprobe ath_pci
iwconfig ath0 essid 'ssid' nick 'testbr' ap (ap mac)
iwconfig ath0 channel 11 rate 54M
iwpriv ath0 wds 1
modprobe r8169
ifconfig ath0 0.0.0.0 up
ifconfig eth0 0.0.0.0 up
brctl addbr br0
brctl addif ath0
brctl addif eth0

Using above setup (ath0-eth0), kernel oops after about 90 minutes.

Using above setup and bridging between eth0 (sis900) and eth1 (r8169) worked fine. Tested for 36 hours.

Connected to ap as client only (no bridging) worked fine. Tested for 3 days (weekend).

Attempting to get netconsole output.

Attachments

testbr.netconsole (8.1 kB) - added by ken@glaserelectronics.com on 08/09/07 18:24:04.
syslog netconsole message after oops
madwifi.config (43.8 kB) - added by ken@glaserelectronics.com on 08/09/07 20:35:37.
kernel 2.6.21.5 madwifi.config (Slackware kernel source)
rc.netconsole (317 bytes) - added by Ken Roberts <ken@glaserelectronics.com> on 08/10/07 19:58:46.
rc.wifi (1.9 kB) - added by Ken Roberts <ken@glaserelectronics.com> on 08/10/07 20:04:12.
Bridge configuration script

Change History

08/08/07 07:37:19 changed by mrenzmann

  • description changed.

Please provide a dump of the kernel oops message you get. Then try if the problem still exists in trunk.

08/09/07 18:24:04 changed by ken@glaserelectronics.com

  • attachment testbr.netconsole added.

syslog netconsole message after oops

08/09/07 18:26:09 changed by ken@glaserelectronics.com

Added netconsole syslog message.

D/L trunk today and see how it goes

08/09/07 20:35:37 changed by ken@glaserelectronics.com

  • attachment madwifi.config added.

kernel 2.6.21.5 madwifi.config (Slackware kernel source)

08/10/07 19:58:46 changed by Ken Roberts <ken@glaserelectronics.com>

  • attachment rc.netconsole added.

08/10/07 20:04:12 changed by Ken Roberts <ken@glaserelectronics.com>

  • attachment rc.wifi added.

Bridge configuration script

08/10/07 20:08:32 changed by Ken Roberts <ken@glaserelectronics.com>

Installed r2635 using same setup above (module compiled into kernel source). Problem now is bootp is having fits.

Normal bootp sequence:

IP 0.0.0.0.bootpc -> 255.255.255.255.bootps (request)
IP 192.168.1.1.bootps -> 192.168.1.101.bootpc (reply)

What I'm seeing on the computer trying to boot via the bridge:

IP 0.0.0.0.bootpc -> 255.255.255.255.bootps (request)
IP 192.168.1.1.bootps -> 255.255.255.255.bootpc (reply)

Of course, the booting computer does not recognize the IP address or the packet information being returned.

The good news is that it does not appear to be locking up any more (at least during the test timeframe of around 2 hours - if I manually assign an IP to the local computer on the wired side.

Also, attached the script I use to bring up the interface and the script I use for netconsole logging.
Any thoughts?

08/10/07 20:31:10 changed by Ken Roberts <ken@glaserelectronics.com>

On further checking, the bootp reply is being relayed as it should (bootpreply of 255.255.255.255.bootpc is coming from the wifi router upstairs like that).

Tried dhcpcd on ath0 and it worked fine.

Now to try and figure out why my computer doesn't like that.

08/10/07 20:51:38 changed by Ken Roberts <ken@glaserelectronics.com>

Back to the arp issue again - arp request/replies are not getting through the bridge.

08/10/07 21:29:20 changed by Ken Roberts <ken@glaserelectronics.com>

possibility: problems with MadWifi driver and AirLink?+ AP?

08/10/07 21:42:09 changed by Ken Roberts <ken@glaserelectronics.com>

When using the bridge via 2 wired ethernets, bootp/arp works fine.

When using my DLink card in the notebook (with the Atheors drivers), bootp/arp works fine.

When using the Atheros AR5212 802.11abg PCI NIC bridging to the notebook via RTL8110SC, bootp/arp are hosed.

All wireless connecting to the AirLink?+ AP.

08/14/07 18:16:04 changed by Ken Roberts <ken@glaserelectronics.com>

Can probably mark this as closed.

Test has been up for >24hrs without killing the system using r2635.

08/15/07 06:34:52 changed by mrenzmann

  • status changed from new to closed.
  • resolution set to fixed.
  • milestone set to version 0.9.4.

Thanks for the feedback. Feel free to reopen the ticket in case the issue occurs again with r2635 or later.

02/11/08 06:22:38 changed by mrenzmann

  • milestone changed from version 0.9.4 to version 0.9.5.